Sign in with
Sign up | Sign in
Your question

punk'd by too many FX

Last response: in Home Audio
Share
Anonymous
July 18, 2005 2:32:53 AM

Archived from groups: rec.audio.pro (More info?)

After doing most of my serious recording using a stand-alone recorder
(HD-24) I have been doing more & more on my 1.6 Pentium M laptop using
Cubase SX. Just got some new plug-ins and was doing some multi-track
mixing, adding FX to some BGVs and hit the wall. Everything started
skipping and clicking. Tried tome buffer adjustments to no avail. then
removed the last 3 verb assignments and everything started working OK
again.

I have read about outboard processors that take the strain off of the
computer itself but for those who have been working all computer based
recording for a while, thought I'd ask what my options are to be able
to increase the number and usage of my plugins without causing the
multi-track program to take a dump.

It's a Toshiba Satellite S-311 & I'm running XP home and clean my
computer daily of any spyware/adware/virus' and defrag almost daily. I
have cleaned most of my startup programs using msconfig. I am A+ cert.
and know quite a bit about getting the most out of my processor but I
know there are some of you out there that have much more experience
with audio and the interactions of.

Thoughts?

peakester

More about : punk

Anonymous
July 18, 2005 3:00:56 AM

Archived from groups: rec.audio.pro (More info?)

As my post says, "I was doing some multi-track mixing".
peakester
Anonymous
July 18, 2005 8:59:14 AM

Archived from groups: rec.audio.pro (More info?)

peakester@earthlink.net wrote:
> As my post says, "I was doing some multi-track mixing".
> peakester

Some plugins, and reverbs in particular, can be expensive
(resource-wise). If you are not doing so already, you might want to
reduce the number of reverb instances needed - by sharing them on an FX
channel (or buss). These main (couple or few) FX busses can then be
accessed (via buss send-level) by the tracks in need.

Also, try a DSP card to offload the processing from your Notebook -
something like the TC Electronic PowerCore (FireWire). The UAD-1 is
also nice but only supports PCI (if I remember correctly).

Hassan
Related resources
Anonymous
July 18, 2005 9:01:05 AM

Archived from groups: rec.audio.pro (More info?)

It isn't always necessary to apply the effects to each channel
individually. See if you can send your channels to a group and apply
the effects over that group. This is especially effective on reverb,
which tends to be the heaviest effect.
Anonymous
July 18, 2005 9:58:05 AM

Archived from groups: rec.audio.pro (More info?)

On 17 Jul 2005 22:32:53 -0700, peakester@earthlink.net wrote:

>After doing most of my serious recording using a stand-alone recorder
>(HD-24) I have been doing more & more on my 1.6 Pentium M laptop using
>Cubase SX. Just got some new plug-ins and was doing some multi-track
>mixing, adding FX to some BGVs and hit the wall. Everything started
>skipping and clicking. Tried tome buffer adjustments to no avail. then
>removed the last 3 verb assignments and everything started working OK
>again.
>
>I have read about outboard processors that take the strain off of the
>computer itself but for those who have been working all computer based
>recording for a while, thought I'd ask what my options are to be able
>to increase the number and usage of my plugins without causing the
>multi-track program to take a dump.

Don't use the FX while recording. Save them for mixdown time.
Mike T.
Anonymous
July 18, 2005 12:37:37 PM

Archived from groups: rec.audio.pro (More info?)

What reverbs are you using!?!?!

I run an IBM T41 Thinkpad with Pentium M 1.6GHz (like yours), and 512M
of RAM. So far, this rig has handled exceptionally well. I have a few
suggestions, though:

1) consider a plugin soundcard to take some stress off the CPU (I just
bought an E-mu 1616 and it has a reverb on the chip, though it's not
the greatest it doesn't tax the CPU).

2) follow this lengthy bit of advice (taken from somewhere else, dunno
where or when):

One of the best results is to remove ALL cards except for the video
card
and add one card at a time and playing with the slot configurations
Second: Change the "Role" of the computer..
Right click "My Computer"
Select "Properties"
Select the "Performance" tab
Click on the "File System" button
Change the role of your PC from a Desktop to a Network Server...this
will
allow faster
streams of audio.(Restart)
Third: Make sure nothing is started up when you launch Windows:
In your Start Menu you will go to RUN
Type in MSCONFIG and press OK
Select the "Startup" tab and deselect EVERYTHING BUT YOUR SYSTEM
TRAY!!!
Press "Apply" ...Press "OK" (Restart)
NEW-----It turns out when you disable your startup items from this
System
Config Utility program
it creates a "second" Run category in your registry which "could" lead
to
a possible
issue at some point due to it creating a dash(-) after the word run.
In Start Menu you will go to RUN
Type in Regedit and press OK
Expand Hkey_Local_Machine
Expand Software
Expand Microsoft
Expand Windows
Expand Current Version
Find the folder labeled Run
Highlite each item and delete the key leaving your Systrem Tray alone
You will also see a Run Services folder
Hhighlite each item and delete each one and remove them all
Now...if you have done the MSCONFIG tweak in the startup tab you will
see
two folders here...Run
and Run-.....Delete the Run- folder and then continue as decribed above
on
the NEW way of
tweaking the startup..do the same with the Run Services- folder as well

Fourth: Make sure DMA is ON for your Hard Drives and Auto-Insert
Notification is OFF for your CDROMS
Right click "My Computer"
Select "Properties"
Select the "Device Manager" tab
Expand(Press the + sign) Disk Drives
Double click on the Drive you need to change
Select the "Settings" tab and make sure DMA has a check next to it.
Windows will give
you a prompt...hit OK..Do this for the second drive as well(If you dont
have a second
drive....GET ONE!!)
Expand the CDROMS
Select the "settings" tab and make sure Auto-Insert Notification is
unchecked. Do this
for all CDROMS and CDR/RW's(Restart)
Fifth: Optimize your Swap File:
Right click "My Computer"
Select "Properties"
Select the "Performance" tab
Press the "Virtual Memory" button
Depending on how much RAM you have is how you figure out what to set
the
Virtual
Memory to....As apposed to Windows 95 days the rule about making the
swap
file twice
the size of your memory is no longer needed...ever since FAT32 that has
all but gone
away. Nowadays you will need less...for example-128MB RAM is about
192Min
and Max
256MB RAM you should set to 128Min and Max. Obvioulsy it is not going
to
hurt your
system if you allocate more than your memory but it is not needed and
will
use your hard
drive more than you need it to.
Explanation of Virtual Memory....Windows allocates your entire hard
drive
as a means of shuffling
data back and forth from Memory as it is needed. When an application is
running threads of
information are put into memory(RAM) and processed..when that thread is
done and the next thread is ready windows uses the hard drive to
prepare
the thread then swaps it with the thread that has been used allready.
Depending on the software and the machine, the size of the threads
can get larger and smaller using any available space on your
drive....Fragmentation hell and it
also can cause your machine to crash/stall when it has to search the
entire drive for the next thread.
Thus making the swap file the same size for Minimum and Maximum you are
telling Windows to
use only a certain part of the drive and to use the fastest part of it
as
well...the outside track. Thus
windows has less of an area to find the next thread and continue on as
normal
**** VERY IMPORTANT***************
YOU MUST DEFRAG YOUR HARD DRIVE AFTER RESTARTING!!! DO NOT USE THE
see a Run Services folder<br>
X-UIDL: p!-"!(i1"!1RM!!~4e!!
Hhighlite each item and delete each one and remove them all<br>
Now...if you have done the MSCONFIG tweak in the startup tab you will
see two folders here...Run <br>
and Run-.....Delete the Run- folder and then continue as decribed above
on the NEW way of<br>
tweaking the startup..do the same with the Run Services- folder as well
</font>
<p><font size=3 color=#333333 face="Times New Roman"><br>
Fourth: Make sure DMA is ON for your Hard Drives and Auto-Insert
Notification is OFF for your CDROMS<br>
Right click "My Computer"<br>
Select "Properties"<br>
Select the "Device Manager" tab<br>
Expand(Press the + sign) Disk Drives<br>
Double click on the Drive you need to change<br>
Select the "Settings" tab and make sure DMA has a check next to it.
Windows will give <br>
you a prompt...hit OK..Do this for the second drive as well(If you dont
have a second <br>
drive....GET ONE!!)<br>
Expand the CDROMS<br>
Select the "settings" tab and make sure Auto-Insert Notification is
unchecked. Do this <br>
for all CDROMS and CDR/RW's(Restart) </font>
<p><font size=3 color=#333333 face="Times New Roman">Fifth: Optimize
your Swap File:<br>
Right click "My Computer"<br>
Select "Properties"<br>
Select the "Performance" tab<br>
Press the "Virtual Memory" button<br>
Depending on how much RAM you have is how you figure out what to set
the Virtual<br>
Memory to....As apposed to Windows 95 days the rule about making the
swap file twice<br>
the size of your memory is no longer needed...ever since FAT32 that has
all but gone <br>
away. Nowadays you will need less...for example-128MB RAM is about
192Min and Max<br>
256MB RAM you should set to 128Min and Max. Obvioulsy it is not going
to hurt your<br>
system if you allocate more than your memory but it is not needed and
will use your hard<br>
drive more than you need it to. </font>
<p><font size=3 color=#333333 face="Times New Roman">Explanation of
Virtual Memory....Windows
allocates your entire hard drive as a means of shuffling<br>
data back and forth from Memory as it is needed. When an application is
running threads of <br>
information are put into memory(RAM) and processed..when that thread is
done and the next thread is
ready windows uses the hard drive to prepare the thread then swaps it
with the thread that has been
used allready. Depending on the software and the machine, the size of
the threads <br>
can get larger and smaller using any available space on your
drive....Fragmentation hell and it<br>
also can cause your machine to crash/stall when it has to search the
entire drive for the next
thread.<br>
Thus making the swap file the same size for Minimum and Maximum you are
telling Windows to<br>
use only a certain part of the drive and to use the fastest part of it
as well...the outside track.
Thus<br>
windows has less of an area to find the next thread and continue on as
normal </font>
<p><font size=3 color=#333333 face="Times New Roman">**** VERY
IMPORTANT***************<br>
YOU MUST DEFRAG YOUR HARD DRIVE AFTER RESTARTING!!! DO NOT USE THE <br>
WINDOWS DEFRAGGER..IT DOES NOT OPTIMIZE YOUR SWAP FILE...IT LEAVES THE
<br>
CURRENT STATE IN TACT....USE NORTON'S TO DEFRAG AND MAKE SURE YOU <br>
TELL IT TO OPTIMIZE THE SWAP FILE!!! THIS CAN BE FOUND USUALLY IN THE
<br>
ADVANCED SECTION OF THE PROGRAM<br>
***********************************<br>
<br>
Sixth: Lower your Bit Depth rate for your Display settings:<br>
Right click on your desktop and select "Properties"<br>
This will bring you to your Display Properties window<br>
Select the "Settings" tab<br>
Change the "Color" settings to 16Bit...32Bit will eat up your
performance<br>
Screen resolution is of your choice...I prefer 1024x768...larger screen
area<br>
Not always is it best to go out and get the most "RAM" intensive video
card.<br>
Staying with a 16MB video(AGP of course) is a fine standard to be
at.<br>
Try and stay away from PCI video cards..puts a strain on your PCI bus!
</font>
<p><font size=3 color=#333333 face="Times New Roman">Seven: Power
Schemes:<br>
Right click on your desktop and select "Properties"<br>
This will bring you to your Display Properties window<br>
Select the "Screen Saver" tab<br>
Set Screen Saver to NONE<br>
Press the "Settings" button in the Energy Saver area<br>
For Power Schemes choose Home/Office Desk<br>
Set System Standby to NEVER<br>
Turn off monitor to NEVER<br>
Turn off Hard Disks to NEVER<br>
<br>
Eight: Multimedia Settings:<br>
Make sure windows doesnt use your sound card to "Map" thru it<br>
Go to your Start menu>Settings>Control Panel<br>
Double click on Multimedia<br>
Select the "devices" tab<br>
Expand the Audio Devices item<br>
Double click on the audio card/device in question<br>
Check the box that says "Do not map thru this device" <br>
Press Apply(Restart) </font>
<p><font size=3 color=#333333 face="Times New Roman">Nine: Stop the
Scheduled Tasks from running<br>
Go to your Start menu>Accessories>System Tools>Scheduled Tasks<br>
Double click on "Tune-up Application Start"<br>
At the bottom of the screen deselect "Enabled" </font>
<p><font size=3 color=#333333 face="Times New Roman">Ten: Network
Settings:<br>
If you are connected to the internet via your PC DAW via a modem/DSL
but are NOT <br>
using File Sharing >remove Client For Microsoft Networks<br>
Go to your Start menu>Settings>Control Panel<br>
Double click on Network>Highlite "Client for Microsoft Networks<br>
Press "Remove"<br>
When you close out of the Network box it will tell you your network is
not complete and <br>
do you want to continue...say YES!!(Restart) </font>
<p><font size=3 color=#333333 face="Times New Roman">Eleven: More
System Configuration<br>
These steps arent neccessary but reccomended<br>
In your Start Menu you will go to RUN<br>
Type in MSCONFIG and press OK<br>
Select the "Config.sys" tab<br>
Deselect everything<br>
Select the "Autoexec.bat" tab<br>
Deselect everything<br>
Press Apply..Press OK(Restart) </font>
<p><font size=3 color=#333333 face="Times New Roman">As far as "tweak"
settings are
concerned this should do it. Obviously there are system requirements
too but this a known issue and
all should be aware that a PII 400 is the minumum reccomended
processor. 128MB RAM minimum(256
Reccomended) AGP Video card...No internet...Constantly making sure your
hard drive(s) are
optimized(defragged) and also not installing every software known to
man(which can corrupt the
registry) As far as "Physical" building of a system one should not put
two hard drives on
one IDE cable..this will cause bus speeds to be bogged down.
Partitioning a single hard drive does
not make it two drives...it only "emulates" a second drive..there is
still one mechanical
arm reading the two parts of one drive...this can cause skips or
possible stutters. I reccomend
using your main drive for ALL applications and the secondary drive for
ALL data...audio
files..program information..etc !
Anonymous
July 18, 2005 7:18:44 PM

Archived from groups: rec.audio.pro (More info?)

On 17 Jul 2005 23:00:56 -0700, peakester@earthlink.net wrote:

>As my post says, "I was doing some multi-track mixing".
>peakester

Oops! And I thought it was just my mouth that ran with no direction
from my brain. Now it's my fingers, too.

I'll second the advice that others have given about using just one
instance of a reverb. Not only does it conserve resources, but it also
makes all the instruments sound like they are in the same room ... if
a natural reverb is what you want.

Still, I have come across a reverb that recommends dual P4 3.2GHz and
1 GB of RAM to run in real time. I can only use that algorithm by
letting it process the mix off-line, then listening to the result
after.

Mike T.
Anonymous
July 18, 2005 8:37:51 PM

Archived from groups: rec.audio.pro (More info?)

<peakester@earthlink.net> wrote in message
news:1121664773.096891.158790@o13g2000cwo.googlegroups.com...
> After doing most of my serious recording using a stand-alone recorder
> (HD-24) I have been doing more & more on my 1.6 Pentium M laptop using
> Cubase SX. Just got some new plug-ins and was doing some multi-track
> mixing, adding FX to some BGVs and hit the wall. Everything started
> skipping and clicking. Tried tome buffer adjustments to no avail. then
> removed the last 3 verb assignments and everything started working OK
> again.
>

> Thoughts?
>

Process a track or a group of tracks through an effect, making a new track.
Make that new track a part of your mix. Move on.

jb
Anonymous
July 18, 2005 10:25:17 PM

Archived from groups: rec.audio.pro (More info?)

peakester@earthlink.net wrote:

> Thoughts?

One procedure that has helped me gain track/plugin
counts is to group tracks together as stereo tracks
whenever possible, for example record the drum
OH's as a stereo track rather than two mono tracks.
The stereo interleaved files are quicker to access
by the OS.

rd
Anonymous
July 19, 2005 1:50:44 AM

Archived from groups: rec.audio.pro (More info?)

peakester@earthlink.net wrote:
> After doing most of my serious recording using a stand-alone recorder
> (HD-24) I have been doing more & more on my 1.6 Pentium M laptop using
> Cubase SX. Just got some new plug-ins and was doing some multi-track
> mixing, adding FX to some BGVs and hit the wall. Everything started
> skipping and clicking. Tried tome buffer adjustments to no avail. then
> removed the last 3 verb assignments and everything started working OK
> again.
>
> I have read about outboard processors that take the strain off of the
> computer itself but for those who have been working all computer based
> recording for a while, thought I'd ask what my options are to be able
> to increase the number and usage of my plugins without causing the
> multi-track program to take a dump.
>
> It's a Toshiba Satellite S-311 & I'm running XP home and clean my
> computer daily of any spyware/adware/virus' and defrag almost daily. I
> have cleaned most of my startup programs using msconfig. I am A+ cert.
> and know quite a bit about getting the most out of my processor but I
> know there are some of you out there that have much more experience
> with audio and the interactions of.
>
> Thoughts?
>
> peakester

I have read the posts about tweaking my PC, much of which I have
already done, and it seems like I will probably have more headroom
using all ouboard gear with the stand-alone unit and my DM-24 or Spirit
Studio analog board. The problem is my editing is a little more limited
in this situation and the Alesis does not have undo functions in record
mode. Although I am willing to make some compromises, I know that the
big studio units don't have to cut corners or use work-arounds in
ProTools or Nuendo or the like. Is this just because of processing
power? I love the ease of having everything, including the automation,
in one location but I also love to be able to apply different effects
without being chained to one reverb for the whole project. I want to be
sure that I have the headroom, processor-wise, to get a lot of stuff
going before I absolutely depend on the computer to do everything,
especially in front of a client.

Have any of you used outboard DSP units like the TC Electronics? I do
have Firewire and USB 2 options.

Is it, after all, about having a kick-ass computer or will the outboard
DSP unit do the deed?

peakester
Anonymous
July 19, 2005 6:49:37 PM

Archived from groups: rec.audio.pro (More info?)

<peakester@earthlink.net> wrote:
>
> I know that the big studio units don't have to cut corners or use
> work-arounds in ProTools or Nuendo or the like. Is this just because
> of processing power?


In the case of Pro Tools, you can choose between two system approaches:
LE, which uses the computer's processing power (i.e. "native"), or TDM,
which just uses the computer as a host and does the audio processing
with dedicated, proprietary DSP cards. With TDM, you can increase
processing power by adding DSP cards.

--
"It CAN'T be too loud... some of the red lights aren't even on yet!"
- Lorin David Schultz
in the control room
making even bad news sound good

(Remove spamblock to reply)
!