Sign in with
Sign up | Sign in
Your question

Unsolvable question on RAID0 and Raptors?

Last response: in Storage
Share
August 8, 2003 1:08:50 PM

I am having an issue running my SATA Raptor 10k drives in a RAID 0 configuration. Benchmarks show that while running a RAID 0 they are actually running slower than with a single drive. I am at a lose as to whether this is a hardware or driver issue. I have all of the latest drivers installed supplied by ASUS and I'm still runnging slower than I should be.

With the collective experience of the people who visit these boards I am sure some reasonable conclusion can be made about what is going on here. I have looked on the boards of another site and it appears at least 2 others have posted identical problems as I, with different motherboards. I have an Asus P4S8X, another has an ASUS P4C800 Deluxe, and one has a KT4 Ultra SR Mobo (MSI). What we all have in common is unreasonably low Hard drive scores with two western digital raptors RAID 2+0 Striped config. I know it isnt the drives, I benchmarked a single raptor on my system and came up with a 1300, when I put two in a raid 0 config the score dropped to 790! I installed an IDE WD 40GB drive and moved the pagefile to it and my scores increased to around 1300, but should be much faster yet. Based on the way raid works it should be doubling my mb/s transfer rates not halfing it. All of these motherboards contain either the Promise FastTrak 376 (tm) Controller or its cousin Promise FastTrak 378 (tm) Controller, which I believe use the same drivers. As on asus's web site drivers for both come from same zip. I have tried backtracking to an older version of the drivers but it offers no improvement at all. Some have suggested benching on Sandra, I havent, but another has and it offered no improvement in the stats. I would say it might be the BIOS not being optimized, but the fact that its on 3 differenent motherboards tells me otherwise. One thing that caught my eye was is in the hardware profiles under harddrives the array is listed as "Promise 2+0 Stripe/RAID0 SCSI Disk Device" being run by Microsoft Driver Version 5.1.2535.0 from 7/1/2001. That may not be the prob but the date of the driver for the array (not the controller mind you) predates SATA RAID by a long while. Those who like a challenge please help us out, its driving me nuts." I still strongly feel it has something to do with the hardware SATA controller, as my startup times are not much faster than a standard IDE.

I would greatly appreciate any help or insight that could be offered. TIA
September 3, 2003 4:01:00 PM

sorry to hear you are having problems, that would drive nuts as well knowing how expensive the Raptors are. Unfortunately for you I am only running one Raptor so I don't have any experience with that problem.

I run an Asus a7n8x deluxe. I know Asus has updates to the sata controller you may want to check out (not sure for your mobo).

you can dramatically decrease your boot time using 'bootvis.exe' ... you can download this for free via Microsoft, but I noticed they removed the d-load link (temporarily). Send me your email and I can send my copy of bootvis when I get home tonight.

good luck
!