Sign in with
Sign up | Sign in
Your question

Wifi turns off during sleep mode

Last response: in Windows 7
Share
July 24, 2012 4:08:32 PM

My wifi turns off when my computer goes into the sleep mode. I have to hit F8-- turn it off and then turn it back on again. How do I get it to stay on all the time? Thanks!

More about : wifi turns sleep mode

July 24, 2012 4:12:08 PM

more than likely it is a feature in your power options. my dell will turn off the NIC card when unplugged from the wall to save energy.
just check into your power options settings.
m
0
l
a c 395 $ Windows 7
July 24, 2012 4:18:02 PM

Navigate to the control panel and open the Device Manager. Open the Network adapters section, right-click your wifi adapter and choose Properties. Navigate to the Power Management tab, uncheck allow the computer to turn off this device and set it to allow this device to wake the computer and then save the changes you made.
m
0
l
Related resources
a b $ Windows 7
July 24, 2012 4:42:24 PM

SR-71 Blackbird said:
Navigate to the control panel and open the Device Manager. Open the Network adapters section, right-click your wifi adapter and choose Properties. Navigate to the Power Management tab, uncheck allow the computer to turn off this device and set it to allow this device to wake the computer and then save the changes you made.


that's how you do it
m
0
l
July 25, 2012 2:15:22 AM

:bounce:  thank you! Worked perfectly!
m
0
l
July 26, 2012 1:22:53 PM

dbregis said:
My wifi turns off when my computer goes into the sleep mode. I have to hit F8-- turn it off and then turn it back on again. How do I get it to stay on all the time? Thanks!



Actually, it didn't work. I followed your directions, unchecked the box you indicated but was unable to check the box to allow it to say on. The computer wouldn't let me check it.
m
0
l
a b $ Windows 7
July 26, 2012 1:28:02 PM

All you need to do is UNSELECT <Allow the computer to turn off this device to save power>
You can't select the others if that is unchecked
m
0
l
July 26, 2012 1:36:37 PM

That's exactly what I did, but it didn't work. There are 3 adapters listed: Microsoft, Realteak and Ateros. I don't understand the difference but I changed all of them. I have rebooted several times and it still doesn't take.
m
0
l
a b $ Windows 7
July 26, 2012 1:56:50 PM

Then you need to go into

Power Options - Change plan settings (for the selected Power Plan) - Change advanced power settings - Wireless Adapter Settings - Power Saving Mode - Plugged In: Maximum Performance
m
0
l
August 5, 2012 12:47:05 AM

First, thank you for your help! I've been on vacation so... I did what you said and found that it was already on maximum performance. The problem just won't go away. After I log on, I hit F8 and turn off my wi-fi (it's supposedly on) and then turn it on again. Is there a solution??? Thanks.
m
0
l
January 4, 2013 9:51:22 AM

I've got a similar problem on a Dell Vostro and tried all of the above. Basically after the computer wakes from sleep the wifi is disconnected. Setting power mode to maximum performance and the options to prevent the OS from powering the onboard wifi down have no effect. Anyone with other ideas to try ? (also tried updating the wifi drivers from the Dell website, but Dell don't seem to have updated them since I bought the computer anyway). Perhaps someone knows how to determine the Broadcom wifi chipset version and were to get OEM drivers from ?
m
0
l
a b $ Windows 7
January 4, 2013 11:03:12 AM

it's very simple - don't allow the computer to enter Sleep mode - it's clearly a glitch or the wrong drivers are installed
m
0
l
January 8, 2013 4:49:24 PM

dingo07 said:
it's very simple - don't allow the computer to enter Sleep mode - it's clearly a glitch or the wrong drivers are installed


I don't believe it's a "glitch" because my HP laptop does the same thing. It seems to be a Windows 7 issue since that is when my issue started. I have yet to find a fix...
m
0
l
August 30, 2013 4:13:34 PM


Try this -
go to control panel - network and internet - manage wireless networks
delete all networks that have been created
click Profile types on the menu bar just above (Add, Adapterproperties etc)
and make sure it is set to - use all user profiles only
click Add (on the menu bar) then select manually create a network profile
then manually enter SSID encryption type and your security key
make sure you are connected to the internet then enter sleep mode
wake up computer and internet should still be connected.


I've had this problem with 3 separate computers all running 64 bit windows 7.
I have always managed to cure it by doing one of the following
1 - the method in the above post (delete networks and manually create a new one
2 - disable wake up password
3 - create a new standard account and use that
4 - tick the connect when ssid not broadcasting in network properties

one or a mixture of the above has always solved this problem for me.

Also remove any crapware. I had an Asus that had a power management utility installed, after removing it my internet stayed connected.
I think this issue is usually connected to the power options in someway.
m
0
l
November 10, 2013 6:34:28 AM

SR-71 Blackbird said:
Navigate to the control panel and open the Device Manager. Open the Network adapters section, right-click your wifi adapter and choose Properties. Navigate to the Power Management tab, uncheck allow the computer to turn off this device and set it to allow this device to wake the computer and then save the changes you made.



blackbird's solution is correct to the point. solved my wifi disconnection problem when computer goes into sleeping mode.
m
0
l
December 4, 2013 12:43:12 PM

I cannot believe this, but after months of trying to fix this (on and off, trying and then giving up), it turns out that, for me, checking ON (enabled) the "Allow the computer to turn off this device to save power” worked. Got this idea from http://support.microsoft.com/kb/2560995. My guess is that the driver expects to turn the network card back on after sleep or on a cold boot, and because the option is turned off, it toggles the "switch" from being already on to off. Maybe? Anyway it works for me now, perfectly.
m
0
l
December 5, 2013 10:33:56 AM

Go to the control panel and open the Device Manager. Expand the Network adapters node, right-click your WiFi adapter and select Properties. Navigate to the Power Management tab, clear the Allow the computer to turn off this device check box and set the Allow this device to wake the computer check box and then save your changes.
m
0
l
December 11, 2013 11:02:56 AM

Having the same issue....have cleared the Allow the computer to turn off, but option for set the Allow to wake is still grayed out. Have also tried other power management settings, but still have the issue. Figure there still must be another power setting somewhere that we're missing...thoughts?

m
0
l
!