Sign in with
Sign up | Sign in
Your question

Remote Desktop Slow across LAN

Last response: in Windows 7
Share
July 27, 2012 1:26:22 PM

Have setup RD for Win 7 64 Ultimate (both boxes) on internal LAN. Connects no problem and the LAN operates at almost full Gbps when moving files between the two. I've disabled the A/V and firewall (Kaspersky A/V 2012 on client, MSE on host) but no changes.

Even with all the RDP options stripped down it is slow. Should it not be at virtual speed even with all the bells & whistles across the LAN?

Suggestions?
July 27, 2012 3:06:29 PM

that is quite odd, does your router have a firewall enabled? you can try setting the PC you are connecting to, to be in the DMZ on the router.
m
0
l
July 27, 2012 3:14:16 PM

Running Tomato 1.28.
Both boxes are on static IP.

Added Host to DMZ which did not solve the problem.

Have rebooted both boxes and router.


I've read a bunch of troubleshooting articles but they are old and deal mostly with Win 7 being client and either server or older Win Version.

Thought this would be a no brainer!
m
0
l
Related resources
a b $ Windows 7
July 27, 2012 3:27:45 PM

What exactly do you mean it's slow? As in slide-show slow? Or as in you move your mouse and 10 seconds later it moves in the RDP session?

Have you monitored your networking tab for your task manager for both machines while doing a session? You might also want to check out your performance and processes tab as well.

Edit: Also check your event log.
m
0
l
July 27, 2012 3:37:02 PM

Slow as in slide-show with patches of complete freeze.

I've watched performance and networking on client and no real spikes.

Edit: Warnings on Host for Termdd?
m
0
l
a b $ Windows 7
July 27, 2012 3:54:59 PM

What are your networking cards set to? Auto speed or hard coded for 1GB? If both are set to either one, try the other one.

For example if you both have them set to 1Gbps speed, try using the auto setting on both.

Did you also check out the performance tab to monitor whats going on with CPU usage?
m
0
l
a b $ Windows 7
July 27, 2012 4:08:31 PM

According to that event log - after searching for that error online - one of the NIC drivers you are using might be a problem. Either the NIC itself, or just the driver.

So you should check for an updated/or correct driver for both.
m
0
l
July 27, 2012 4:11:17 PM

Performance was fine with minimal load on CPU.

I've changed both NIC's to 1Gbps from Auto. Not much change but I'll keep going at it.

I had expected to be able to run progs with relative instant response!
m
0
l
a b $ Windows 7
July 27, 2012 4:36:49 PM

disable desktop background on remote pc
m
0
l
July 27, 2012 4:41:56 PM

already done and when running properly you should be able to run full experience across Gbit LAN.
m
0
l
a b $ Windows 7
July 27, 2012 4:55:42 PM

Have you tried changing the RD port number, long shot.
m
0
l
July 27, 2012 5:09:49 PM

Think default is 3389 which I've done port forwarding on the router (works the same with or without the forwarding). Suppose I could look into changing it.

Other devices on the network are Denon AVR3312, Bell Sat 9242 PVR, iphone and ipad through wifi.

The articles I read (dated 2009) dealt with auto-tuning changes and some other tweaks which must have been corrected in SP because reg keys they refer to are either already changed or removed.
m
0
l
a b $ Windows 7
July 27, 2012 5:10:57 PM

have you tried to ping the pc's ip address yet, how many ms is the responce time
m
0
l
a b $ Windows 7
July 27, 2012 6:28:45 PM

Did you check for newer drivers for your NICS? Or at least the one with the event viewer log?
m
0
l
April 11, 2013 8:11:35 PM

My problem was solved this way:
1. Open IIS Manager
2. Right-click on Default Web Site, Manage Web Site, Advanced Settings...
3. In the window that opens, expand Connection Limits
4. Go to Maximum Bandwidth (Bytes/second)
The value should be at least 10 million (10000000)
5. Click OK and the speed should immediately increase.
If you have a fiber optic Internet connection to the server, make it a billion.
m
0
l
September 17, 2013 10:52:52 AM

Yes it worked for me also, Thanks bro
m
0
l
!