Sign in with
Sign up | Sign in
Your question
Solved

Windows 7 forgets "Allow this device to wake the computer" settings

Tags:
  • Windows 7
  • Computers
  • Devices
  • Keyboards
Last response: in Windows 7
Share
July 27, 2012 1:35:18 PM

Hi everyone

I am experiencing a very frustrating problem. My Windows 7 Ultimate 64bit (version 6.1, build 7601, service pack 1) forgets the "Allow this device to wake the computer" settings made for my usb keyboard and mouse after a few sleep/resume cycles.

Here is what I do and experience:

Go to "Device manager" -> Right click on a device (HID keyboard, HID mouse or similar) and click "Properties" -> Go to "Power Management" tab" -> Enable "Allow this device to wake the computer" ->Click "Ok" -> Close "Device manager".

Then after putting the computer to sleep and waking it (with either mouse or keyboard) 2-3 times the "Allow this device to wake the computer" first gets disabled for the keyboard and then a few cycles later for the mouse.

It reproducible for me with my setup. Same thing happens every time the above is done. It also happens regardless of whether "USB selective suspend setting" is enabled or disabled. It is also independent of "Allow keyboard wake" setting in BIOS.

Also when waking from sleep (after moving the mouse, pressing the keyboard or pressing the case power button) both mouse and keyboard are not recognized. Then after 5-10 sec the usb-device-found sound is played and the mouse start responding. Then after a futher 5-40sec the keyboard starts responding. This might be related or it might not be. It could be that the setting is lost when the keyboard is not recognized/recognized again. On the other hand, testing this by simply unplugging the keyboard while in Windows, the setting is not forgot.

So to sum up: After a couple of sleep/resume cycles, I am unable to wake my computer by mouse or keyboard because the settings gets disabled.

Any ideas as to what is going on here? Later today I'll see if it is persistent over a reinstall of Windows.

Aditional info:
Motherboard: GA-Z77X-UD3H
All windows updates installed

More about : windows forgets device wake computer settings

Best solution

July 27, 2012 1:47:44 PM

wuhtzu said:
Hi everyone

I am experiencing a very frustrating problem. My Windows 7 Ultimate 64bit (version 6.1, build 7601, service pack 1) forgets the "Allow this device to wake the computer" settings made for my usb keyboard and mouse after a few sleep/resume cycles.

Here is what I do and experience:

Go to "Device manager" -> Right click on a device (HID keyboard, HID mouse or similar) and click "Properties" -> Go to "Power Management" tab" -> Enable "Allow this device to wake the computer" ->Click "Ok" -> Close "Device manager".

Then after putting the computer to sleep and waking it (with either mouse or keyboard) 2-3 times the "Allow this device to wake the computer" first gets disabled for the keyboard and then a few cycles later for the mouse.

It reproducible for me with my setup. Same thing happens every time the above is done. It also happens regardless of whether "USB selective suspend setting" is enabled or disabled. It is also independent of "Allow keyboard wake" setting in BIOS.

Also when waking from sleep (after moving the mouse, pressing the keyboard or pressing the case power button) both mouse and keyboard are not recognized. Then after 5-10 sec the usb-device-found sound is played and the mouse start responding. Then after a futher 5-40sec the keyboard starts responding. This might be related or it might not be. It could be that the setting is lost when the keyboard is not recognized/recognized again. On the other hand, testing this by simply unplugging the keyboard while in Windows, the setting is not forgot.

So to sum up: After a couple of sleep/resume cycles, I am unable to wake my computer by mouse or keyboard because the settings gets disabled.

Any ideas as to what is going on here? Later today I'll see if it is persistent over a reinstall of Windows.

Aditional info:
Motherboard: GA-Z77X-UD3H
All windows updates installed


Seems like a weird problem. Just out of curiosity, have you updated the BIOS to the latest ? I have a hunch that you tried that already.

Check the USB hubs in Device Manager, I'm not sure off the top of my head if those can sleep as well via the allow this device to wake up computer.

Lastly, is your keyboard and mouse combo connected to the computer directly or via a USB hub like a monitor ? What's the make and model of your keyboard and mouse ? I know some specific keyboards love to disconnect themselves once in a short while.
Share
July 27, 2012 1:55:19 PM

Maxx_Power said:
Seems like a weird problem. Just out of curiosity, have you updated the BIOS to the latest ? I have a hunch that you tried that already.

Check the USB hubs in Device Manager, I'm not sure off the top of my head if those can sleep as well via the allow this device to wake up computer.

Lastly, is your keyboard and mouse combo connected to the computer directly or via a USB hub like a monitor ? What's the make and model of your keyboard and mouse ? I know some specific keyboards love to disconnect themselves once in a short while.


Thank you for your reply.

Actually I have not done a bios update yet, but I'll do it right away.

The keyboard is a Logitech Deluxe 250 keyboard ($10) and the mouse is a Logitech G700. I have not experienced this before, only after I build a new system (new motherboard). So as you might do, I actually find it very likely to be related to the motherboard and maybe the bios.

Also, the USB hubs do have a "Power Management" tab and they have a "Allow the computer to turn off this device to save power" option. I how ever have 2x "USB Root Hub", 1x "VIA USB2 Hub", 1x "VIA USB 3 Root Hub" and only the "Root Hub"'s sport this setting. One has it enabled, the other disabled. I will play around with this setting also.

Thanks again.
m
0
l
Related resources
July 27, 2012 1:58:44 PM

wuhtzu said:
Thank you for your reply.

Actually I have not done a bios update yet, but I'll do it right away.

The keyboard is a Logitech Deluxe 250 keyboard ($10) and the mouse is a Logitech G700. I have not experienced this before, only after I build a new system (new motherboard). So as you might do, I actually find it very likely to be related to the motherboard and maybe the bios.

Also, the USB hubs do have a "Power Management" tab and they have a "Allow the computer to turn off this device to save power" option. I how ever have 2x "USB Root Hub", 1x "VIA USB2 Hub", 1x "VIA USB 3 Root Hub" and only the "Root Hub"'s sport this setting. One has it enabled, the other disabled. I will play around with this setting also.

Thanks again.


Let me know how this works out.
m
0
l
July 27, 2012 2:28:12 PM

Maxx_Power said:
Let me know how this works out.


So the USB Hub settings didn't do much. I couldn't spot the difference.

But the BIOS update (from F5 to F11) solved everything. The settings are no longer forgotten and the mouse and keyboard are ready immediately after waking.

I feel stupid I forgot about the bios update. A few years back it was standard procedure for me to update the bios to the newest version at once (before even installing the OS). Maybe I should put that back into practice!

Thanks for suggesting the bios update.
m
0
l
July 27, 2012 2:34:48 PM

Best answer selected by wuhtzu.
m
0
l
!