Windows 7 won't load after splash screen

CPU: Intel i5 2500k
GPU: MSI GTX 560ti Twin Frozr II
MOBO: MSI p67a-gd65
PSU: CoolerMaster gx 650
OS: Windows 7 Home Premium - OEM

As the title states, Windows 7 will not load for me after the splash screen. Before this happened, I was having problems with my graphics drivers repeatedly crashing. I updated to the latest NVIDIA drivers and upon restarting the computer the screen had a shade of pink. I started to do a restore and when the computer rebooted, the screen went black after the splash screen with nothing but the mouse pointer.

I went in to my UEFI click bios and ran a memory test which said the memory was fine. I tested a Visiontek Radeon 5750 which returned the same result, a black screen after the splash screen. The only thing that I can conclude is that there is problem with the operating system. I may however, be very wrong.

Does this sound like an operating system error? If it is, I can get Windows 7 professional upgrade for $65 because I am a student. If this is not an operating system error, what might it be?
4 answers Last reply
More about windows load splash screen
  1. pink screen usually means there is a problem with the GPU or the GPU drivers.
  2. That's what I thought as well. But like I said, when I plugged in the radeon 5750, I still couldn't get a display. I'm not sure if there's a way to test the PCI slot for the card or maybe there's an issue with the power supply? I'm totally clueless.

    Edit: When I say pink screen, it was a shade of pink across the screen not an entirely pink screen. I could still see the desktop and icons. I'm not sure if that matters.
  3. can you try a different monitor or video cable?
  4. When I tested the radeon 5750 it was on a different monitor and with an hdmi cable rather than the dvi cable I have to use for the 560 and it was the same result.
Ask a new question

Read More

Windows 7 Splash Screen