Sign in with
Sign up | Sign in
Your question

SCSI Emulation of IDE Drives - WTF

Tags:
  • Hard Drives
  • SCSI
  • Devices
  • DVD Drives
  • Storage
  • Product
Last response: in Storage
Share
October 19, 2003 3:28:52 AM

Okay I have no idea what caused this but one day Windows XP thinks that all my drives are SCSI drives when they are, in fact, IDE. Those drives are an Seagate B7200.7 80GB and a Pioneer 106S DVD drive.

In Device Manager, there is:
ST380011A SCSI Disk Device
PIONEER DVD-ROM DVD-106 SCSI CdRom Device

There are entries for the 'old' devices, exactly the same as above but without the SCSI rubbish, hidden (non-attached devices). Windows says "Currently, this hardware device is not connected to the computer. (Code 45)"

Interestingly this doesn't seem to be causing many problems, I haven't noticed any performance drop or anything. However, I can no longer use digital audio extraction on my DVD drive. AudioGrabber and EAC and similar programs report ASPI errors, unable to communicate with drive, etc.

THIS IS A BIG NO-NO AND I MUST FIX.

I have tried everything, uninstalling the drives, controller drivers, new drivers... nothing works.

What's really bizzarre is that these drives have been happy on my system for almost six months now, and I really have no idea what changed.

The errors with my DAE programs are not such that they're not seeing the drive, but rather that they can't talk to it. Telling them that the drive is SCSI doesn't work. I have tried using different versions of ASPI, but I don't think that's the problem.

HELP PLEASE?

More about : scsi emulation ide drives wtf

October 23, 2003 8:35:22 AM

bump... anyone have any ideas at all?
October 23, 2003 9:05:12 AM

Not really, well maybe some. Lets give it a try...
I would think the place to look at is the IDE controller, appearently Windows thinks this is a SCSI controller and therefore the drives attached to it are SCSI devices. for hds that would not be a problem, but for ATAPI devices it might.
Are these drives conneced to the mobo or to a PCI (RAID) controller? I'm asking this because a raid controller might list itself in the bios as a scsi device, because older bioses may recognise SCSI controllers but not RAID controllers (this is neccessary to boot from the device).

So far this is all I can think of...
Related resources
October 23, 2003 9:21:29 AM

Thanks for your reply but no.

The devices are both connected to a non-raid supporting motherboard. They are listed as IDE devices in the BIOS.

I haven't changed any settings that I'm aware of in the BIOS.

What's interesting is that the feeling I'm getting is that this is something that is 'supposed' to happen; i.e. Windows can use SCSI emulators for ATAPI devices when it needs to... for example I read somewhere that it used to be a solution to the 137gB or whatever limit for IDE... My drive is only 80gB tho.
October 23, 2003 10:00:26 AM

Well, that's clear at least. The problem is Windows then.

Can you tell me what you see in the device manager? I would now expect the IDE ATA/ATAPI controllers tree to contain 2 channels + Standard dual channel PCI IDE controller, which should not be connected, and some SCSI controller tree. Is that correct?
October 23, 2003 1:38:57 PM

No. Nothing that I can notice has changed there.

IDE/ATAPI Controllers:
- Primary Ultra ATA/ATAPI Channel
- Secondary Ultra ATA/ATAPI Channel
- VIA Bus Master Ultra ATA Controller (dual mode)

All connected and working fine. I can't see any SCSI crap except where it's mentioned on the drives themselves.

I gather from what I've read that the idea of SCSI emulation is to just use SCSI drivers so that the system thinks they are SCSI... but actually not, so the controllers don't need to be changed... not sure what I'm talking about really, but there you go. It's a mystery.

I could e-mail you a screen shot of device manager I guess.
October 23, 2003 2:12:34 PM

This is getting interesting.

If you go to the generic tab of the disks you'll see location, type and manufacturer. Could you pass these to me please? Maybe, if you're at it, also the entries in the volumes tab.

Now i reread the original question. It's DAO that's bothering you... Its quite some time ago I tinkered with Audiograbber, but you're using aspi and not raw audio extraction... I seem to recall audiograbber recommends raw data extraction (faster); maybe you could fiddle a little with these audiograbber settings... plse check whether AG is configured to the SCSI CDROM and not to the non-functional original CDROM...
October 23, 2003 2:26:26 PM

Device Type: Disk drives / DVD/CD-ROM drives
Manufacturer: (Standard disk drives) / (Standard CD-ROM drives)
Location: Bus Number 0, Target ID 0, LUN 0

The location is the same for both.

Volume:

Disk: Disk 0
Type: Basic
etc

There is also a SCSI properties tab, with tagged queueing and synchronous transfers options (both unchecked).

It is just the DAE that's the problem. However, from my original post: "The errors with my DAE programs are not such that they're not seeing the drive, but rather that they can't talk to it. Telling them that the drive is SCSI doesn't work. I have tried using different versions of ASPI, but I don't think that's the problem."

It's not just AudioGrabber, all other DAE software I have tried has the same problem. When you say raw I think you mean MSCDEX; this is not available in Windows XP, you have to use ASPI of some sort.

AudioGrabber is set to the only CD drive available, and it auto-detects IDE etc (not SCSI). I have tried forcing it to SCSI, but that doesn't work either. EAC is a little more sophisticated, it recognizes the drive, but then fails upon testing it.
October 24, 2003 3:23:38 AM

That happened to me once when i installed a bad set of Via 4in1 drivers... the 4.28's If i recall correctly.

All my IDE drives became SCSI and my burner wouldnt burn anymore.

A reinstall of different/new drivers fixed the problem.

<b>I am not a AMD fanboy.
I am not a Via fanboy.
I am not a ATI fanboy.
I AM a performance fanboy.
And a low price fanboy. :smile:
Regards,
Mr no integrity coward.</b>
October 24, 2003 11:05:33 AM

I dont see anything else but badly installed drivers.
Have you tried removing both IDE and SCSI controller in the device manager and reinstalling them? Are you sure you have installed the newest VIA 4in1 drivers?

NB I have been (un)pleasantly surprised lately when I reinstalled my Win2K system; some driver updates were working definitely better when installed new on a fresh system than as an update on an older system. Suppose installing drivers is more difficult than I thought...
October 29, 2003 3:47:52 PM

mine do that too. it's not a big deal. for me it was the ata100 drivers on my old board were just put under the scsi category in windows. that doesnt necesarily mean that its scsi emulation ........lol...

------------
Apples are good.
August 30, 2010 4:04:18 PM

Hey Badmonkey. Did you ever get this problem fixed? I have the same thing happening.
!