Debugging hardware startup problems

I'm trying to help a friend with a PC problem. Here's the specs: Windows 98, Microstar MS-6368 Socket 370 w/ PIII 866, on-board video & sound, 10 gig HDD, CD, CDRW, FDD, 56K PCI, 1 stick of 256MB PC133, etc.

Randomly, when you first turn his PC on, it powers up but nothing happens. No beep codes and no video. But after several attempts of powering it on and off, it will eventually boot up to Windows 98. I have noticed that after a successful boot, if I shutdown and restart it within a short period of time it seems to boot up fine almost always.

Here's what I've done so far...
1) I stripped the machine of anything not needed and it still had the same problems (randomly of course). I left only the CPU, HDD, memory, on-board video and sound connected (no FDD, no Cd drives, and no 56K PCI modem).
2) Swapped HDDs, no change.
3) Swapped memory, no change.
4) Swapped IDE cables, no change.
5) Virus scan came back clean running the HDD on my PC as a slave drive.
6) I tried another PCI video card (but I didn't disable the on-board video if that matters any).
7) I reseated everything, literally everything (power supply connector, CPU, memory, all cables, etc).
8) Swapped power supplies, still no luck.
9) I reset the CMOS jumper, no change.
10) I replaced the CMOS battery, no change.
11) Tried different power cord, no change.
12) I have this plugged into my monitor, keyboard & mouse and no changes either.

ANY IDEAS??? I'm totally lost here and need any assistance or suggestions that anyone has to offer. Unfortunately I don't have any testing equipment if there's something in particular that I should be testing for problems - sorry.
6 answers Last reply
More about debugging hardware startup problems
  1. Could be a dying power supply or an intermittent fault in one of the components, but I'm not sure that really helps you.

    Barton 2500+, 512MB Corsair Platinum XMS 3200 CL2, Radeon 9700, WD Raptor 10,000 rpm S-ATA HDD, Asus A7V600, Enermax 460W SilentPlus PSU.
  2. Yea I'd definately give it a shot with a different power supply if that's at all possible.
  3. He already tried a power supply. Either you have a bad power switch or the motherboard is going out. Try take the power switch leads off the mother board and use a piece of wire to short across the two pins sticking up for the powerswitch. If computer starts correctly than you need a new switch. if not then motherboard is probably dying.
  4. Hey sturm... Great idea, hadn't thought to try that. I had an extra power switch lying around so I hooked it up and it worked, worked, worked, worked, then failed. But what I've noticed is that if you turn it on and wait a while (way longer than you should have to), it'll sometimes post the beep and the memory test will start and it boots up. Then if I shut it down and restart it the beep and memory test (boot screen) start normally (almost immediately). My original fear was that it's the motherboard as you've already alluded to - I think you may be right. So unless anyone has any other ideas, I'm going to assume it's a bad motherboard and advise my friend accordingly from there.
  5. Try reseating the CPU as well. I have seen a few rare instances where reseating the CPU has solved this very problem you discribe. Else, I have to agree with the MB theory
  6. That is something I tried as well. I just failed to list it in the above - sorry.
Ask a new question

Read More

Components