Sign in with
Sign up | Sign in
Your question

Audigy 2 / 2-ZS Driver Update

Tags:
  • Sound Cards
  • Sound Blaster
  • Creative
  • Components
Last response: in Components
Share
November 18, 2003 4:26:14 AM

There is a driver update for Creative Sound Blaster Audigy 2/Audigy 2 ZS

Here's the link : http://us.creative.com/support/downloads/

The update fixed a problem I was having with the Dolby Digital Decoder stuttering when using my Power DVD application.
Note for XP users . Create a restore point before updating...just in case. I had a weird problem occur when I updated . The PC hung when trying to restart Windows. and the drivers reported uncertified drivers were installed. After I rebooted I re-ran the installation and it worked the second time and the drivers were reported as MS certified. Bizarre!! Good luck updating.

Here are the highlights of the update that are listed at Creative:

EAX 4.0 ADVANCED HD Driver Update for Creative Sound Blaster Audigy 2/Audigy 2 ZS
SBA2-WEBUP-W4-LB

This driver update contains enhancements and fixes to improve the performance of your Creative Sound Blaster Audigy 2 or Creative Sound Blaster Audigy 2 ZS product.
Added Feature:

EAX 4.0, containing DirectSound and Open AL API extensions, to utilize the EAX 4.0 ADVANCED HD Multiple Environment feature

Fixes:

Removes noise from analog speakers after switching to VXD drivers using Driver Utility.
Allows compressed and uncompressed AC-3 signals when using VXD drivers.
Resolves noise and distortion issues during extended playback of DVD movies.
Removes popping and clicking sounds when decoding AC-3 signals from external DVD players.
Updates the speaker settings when connecting or disconnecting headphones from the Platinum Drive or Audigy 2 Drive after changing the volume level and returning from Standby mode.
Removes popping sounds when compressed .WAV files are played back in Feature Showcase Demonstration.
Updates the speaker volume setting after changing the volume level and restarting the computer.
Removes distortion on MIDI notes when the latency is set to below 20 ms on ASIO tracks.
Removes static from .MP3 and .WAV files during playback.
Outputs Dolby Digital and DTS signals from the software DVD player in 'SPDIF In decode' mode.
Launches the OSD (On-Screen Display) main menu when the remote control's Start button is pressed.
Removes the error message when launching Creative Graphic Equalizer.
Synchronizes monitored SPDIF In Input signals with Input SPDIF signals.
Resolves the volume increase issue when adjusting bass or treble levels during DVD-Audio playback.
Mutes all audio output when the Platinum Drive or Audigy 2 Drive's 'Push Mute' button is pressed once.
Requirements:

Microsoft© Windows© XP, Windows 2000, Windows Me (Millennium Edition) or Windows 98 SE (Second Edition)
Creative Sound Blaster Audigy 2 card, Audigy 2 Platinum eX card, Audigy 2 ZS card or Audigy 2 ZS Platinum Pro card installed, with or without drivers.
Notes:

This EAX 4.0 driver update is not meant for USB Audigy 2 NX or other external Sound Blaster audio products.
If you later wish to install older or newer versions of Audigy 2 or Audigy 2 ZS drivers, you must first uninstall the EAX 4.0 driver update. Uninstallation steps for the EAX 4.0 driver update is displayed during installation.

More about : audigy driver update

November 19, 2003 3:44:32 AM

i didn't have any crackles and clicks befoer updating....
rolling back.......

http://www.mp3.com/dxl ASUS A7N8X, xp3200+ (218x10.5), 2xKINGSTON HYPERX PC3500 512MB(218mhz, at 2 3 3 7) segate 120g 8mb ATA100 segate 80g 2mb ATA100, Creamware pulsar2, ATI9800pro 128mb, audigy2zs
November 19, 2003 5:18:20 AM

This was already posted on the 15th <A HREF="http://forumz.tomshardware.com/hardware/modules.php?nam..." target="_new">here</A>.

The Audigy1 drivers didnt do much for my card but the ZS drivers improved Audigy 1 soundquality alot as expected.
Audigy 2 drivers did the same thing on release.

----
I just tell it like it is and some can't handle it. If your experience is different, well congratu-fukulation.
<b>I’M NOT A ATI FANBOY, I’M NOT A NV FANBOY, I’M A STABILITY FANBOY</b>
Related resources
November 19, 2003 12:21:38 PM

i get frequent clicks wiht winamp when using my keyboard typing text
no problem with games

however, after shuting down my pc and boot up again
the clicks are gone....... wierd!

http://www.mp3.com/dxl ASUS A7N8X, xp3200+ (218x10.5), 2xKINGSTON HYPERX PC3500 512MB(218mhz, at 2 3 3 7) segate 120g 8mb ATA100 segate 80g 2mb ATA100, Creamware pulsar2, ATI9800pro 128mb, audigy2zs
November 19, 2003 6:46:26 PM

That is strange, are you using any sort of special plugins with winamp?

Those are the kinds of things that have (over the years) led me away from my sound blasters.

----
I just tell it like it is and some can't handle it. If your experience is different, well congratu-fukulation.
<b>I’M NOT A ATI FANBOY, I’M NOT A NV FANBOY, I’M A STABILITY FANBOY</b>
November 19, 2003 11:28:11 PM

no other plugins with winamp
didn't have any problem
but it's totally fine now, i feel good now.
anyhow it might just due to my bad luck and good luck.....

i just totally [-peep-] my car today on the way home..... or maybe just becuse i don't have my wintertires on, but fortunely i'm totally fine.

oh yeah if interested, check out

<A HREF="http://www.rockacola.com/music/dylan.asp?song=2&no=4289..." target="_new">http://www.rockacola.com/music/dylan.asp?song=2&no=4289...;/A>

i finished that track yesterday
full of dreamy textures.

http://www.mp3.com/dxl ASUS A7N8X, xp3200+ (218x10.5), 2xKINGSTON HYPERX PC3500 512MB(218mhz, at 2 3 3 7) segate 120g 8mb ATA100 segate 80g 2mb ATA100, Creamware pulsar2, ATI9800pro 128mb, audigy2zs
!