Sign in with
Sign up | Sign in
Your question
Solved

AHCI Crashing Windows on boot

Last response: in Windows 7
Share
August 2, 2012 5:27:12 AM

Hi guys. So I just bought myself a Crucial M4 SSD. And the guy at the store told me to make it run even faster to go into the BIOS and turn the HDDs to AHCI. So after installing Windows and playing around a bit I decided to go to the BIOS and do it. But then when the Windows sunburst comes up it crashes. What gives? I was reading somewhere else that there needs to be a registry change somewhere too? Any of you genius' got the answer for me?

Incase it matters I'm running an ASUS Crosshair IV Formula and Windows 7 Enterprise.

Thx in advance.
a b $ Windows 7
August 2, 2012 5:35:39 AM

the registry file you need to change in windows is:

hkey local machine>System>CurrentControlSet>Services>msahci and change "name" to the value 0
m
0
l
August 2, 2012 5:39:58 AM

As far as i know the only way to fix this problem would be to reinstall windows, you generally can't change between ide and ahci mode with a current windows installation.

I'm sure some one will correct me if im wrong.
m
0
l
Related resources
August 2, 2012 5:40:45 AM

well i stand corrected. lol.
m
0
l
August 2, 2012 4:00:01 PM

dudewitbow said:
the registry file you need to change in windows is:

hkey local machine>System>CurrentControlSet>Services>msahci and change "name" to the value 0


Sorry but... how do I get to that lol and the "name" is that the exact name my BIOS displays for my SSD?
m
0
l

Best solution

August 2, 2012 4:15:23 PM

Dankaru said:
Sorry but... how do I get to that lol and the "name" is that the exact name my BIOS displays for my SSD?

As to 'how'

windows button > search 'regedit' > right-click regedit and run as administrator.

in Regedit

navigate the tree in the left pane knowing that it is strictly alphabetical.

HKeyLocalMachine
|
|
->System
|
|
->CurrentControlSet
|
|
->Services
|
|
->msahci

in the right pane you will find the entry for your drive. edit the entry by right-clicking it and change its value to '0'

close regedit. no save needed as the registry is live.

reboot

done


Q
Share
August 2, 2012 5:13:47 PM

Best answer selected by Dankaru.
m
0
l
a b $ Windows 7
August 2, 2012 5:26:33 PM

Flying-Q said:
As to 'how'

windows button > search 'regedit' > right-click regedit and run as administrator.

in Regedit

navigate the tree in the left pane knowing that it is strictly alphabetical.

HKeyLocalMachine
|
|
->System
|
|
->CurrentControlSet
|
|
->Services
|
|
->msahci

in the right pane you will find the entry for your drive. edit the entry by right-clicking it and change its value to '0'

close regedit. no save needed as the registry is live.

reboot

done


Q

nice.
microsoft also has an app to do this for you automatically on the support web-site.
good work none the less..

http://support.microsoft.com/kb/922976
m
0
l
!