De-fragment tool not opening

Hey guys, I kinda need some help here.
I just recently reformatted my pc and installed windows 7 Home Premium.
Today I come to find that the Disk De-fragment tool is not working. When I click it nothing happens.
I looked and found that the service is running, and I restarted it to be sure but still nothing. I have googled some similar problems but none had the answer I need.

Even if I go to %windir%\inf the file dfrg.inf does not exist. So this prevents me from simply installing it again.

Does anyone know what I can do?
5 answers Last reply
More about fragment tool opening
  1. Instal a 3rd party defragger such as Mydefrag, and see if that works.

    If it doesn't than perhaps a system repair is in order. Cheers
  2. You could just use an aftermarket defrag tool. I use Auslogics disk defrag on all my non SSD drives and have for years. It's free and much better than the one built into Windows as it will optimize files to the fastest part of your drive.

    http://www.auslogics.com/en/software/disk-defrag/

    Defraggler is also a good choice from the CCleaner and Speccy people.

    http://www.piriform.com/defraggler
  3. Well I tried Defraggler and it worked. It just is weird how the default windows one didn't work. Oh well, thanks for the help guys.
  4. We're assuming your drive is not a SSD. If it is a SSD, Windows won't run defrag on it. Defrag should NOT be run on a SSD. It does nothing for performance, and shortens the life of the drive.
  5. Yea I forgot to add it is NOT an SSD.
Ask a new question

Read More

Configuration Windows 7