Sign in with
Sign up | Sign in
Your question
Closed

Setup was unable to format the partition. The disk

Last response: in Windows XP
Share
June 4, 2002 3:41:42 AM

When trying to isntall Windows XP Pro. I get the following error message:
"Setup was unable to format the partition. The disk may be damaged."
I'm then informed that my SCSI drive is not properly teminated or that the switch is off. Funny thing is that I'm installing XP on an IDE drive.
Any and all help is appreciatec.
Thanks.
June 4, 2002 4:07:48 AM

I tried a search at the <A HREF="http://support.microsoft.com/" target="_new">Microsoft Help and Support site</A>, but wasn't able to find anything that might pertain to you.

<font color=green>I'm then informed that my SCSI drive is not properly teminated or that the switch is off.</font color=green>
What was the specific error?

Are you trying to set up your partitioning scheme during Windows XP setup? Try using FDISK instead, because it produces less problems.

You can get one here: <A HREF="http://www.bootdisk.com/" target="_new">Bootdisk.com</A>

Bryan

<A HREF="http://www.btvillarin.com" target="_new">btvillarin.com</A>
<font color=red>Site's back up! L33t!</font color=red>
June 4, 2002 4:54:37 AM

Thanks, . Here is the complete error message I get:

"Setup was unable to format the partition. The disk may be damaged. Make sure the drive is switched on and properly connected to your computer. If the disk is a SCSI disk, make sure your SCSI devices are properly terminated. Consult your computer or SCSI adapter documentation for more information.

You will have to select a different partition for Windows NT. Press ENTER to continue."

The thing is, I'm using an IDE drive. I also ran and bought a new hard drive when I got this message for the first time; however, after connecting the brand new drive (Maxtor 80GB, ATA133, 7200 RPM) I still got the same message.
This error message is ocurring during setup.
Thanks in advance.
Related resources
June 4, 2002 6:02:32 AM

Well, did you try the FDISK utility? I say use that to format and partition your hard drive. Then, try the Windows XP setup again. Also, make sure your BIOS supports this hard drive.

What are your system specs? Be specific, especially with component models.

Bryan

<A HREF="http://www.btvillarin.com" target="_new">btvillarin.com</A>
<font color=red>Site's back up! L33t!</font color=red>
June 4, 2002 7:09:01 AM

In addition to Bryan's excellent suggestions, you can also use the <A HREF="http://www.maxtor.com/softwaredownload/default.htm" target="_new">MaxBlast Plus II v1.30</A> utility to partition the new Maxtor drive. This can be helpful if your current BIOS has difficulty detecting the entire size of the drive.

I would suggest re-checking the <A HREF="http://maxtor.custhelp.com/cgi-bin/maxtor.cfg/php/endus...**&p_li=" target="_new">jumper</A> settings, and you should look in the BIOS and make sure the drive has been correctly identified. If the drive cannot be detected, even with a new cable, you may need to flash your mainboard BIOS to a newer version, and/or purchase an <A HREF="http://www.maxtor.com/products/UltraATA133/default.htm" target="_new">ATA/133</A> controller card.

If you ran into this problem with a previous hard drive on the same cable ... swap out the cable, and be sure the blue end of the connector goes into the primary IDE controller port on the mainboard. If you are attempting to connect the drive using an older ATA/33 cable ... get a new one.

Another option would be to temporarily install the drive on another system for testing purposes. Check to see: #1 ... if the drive can be detected, and #2 ... if the drive can be partitioned and formatted. If this is successful, and you receive a similar error on your system while attempting to install the operating system on the new drive, the mainboard itself may be at fault.

It's also possible that the error is due to faulty RAM, and/or incorrect memory timing settings in the BIOS. RAM issues are often responsible for errors while attempting to detect/install new hardware or install an operating system. Make sure these settings are on the BIOS defaults, and if you have more than one RAM module, try partitioning the drive with only one stick at a time, until you locate the dodgy component.

Finally, be sure that the first bootable device listed in the BIOS is A, or the floppy drive when partitioning from a floppy disk, and CD-ROM when booting from the operating system CD. The hard drive should be listed as the second bootable device during this process, and it can be listed as the first bootable device after the OS installation for a faster boot.

If none of the above works that either of us have detailed, your mainboard might have sustained some damage, like a bad capacitor, and you should have it checked out at a local shop, or by the manufacturer.

Toejam31

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
__________________________________________________________

<font color=purple>"Some push the envelope. Some just lick it. And some can't find the flap."</font color=purple>
June 4, 2002 10:08:51 AM

Quote:
If the disk is a SCSI disk, make sure your SCSI devices are properly terminated.

The key word in that sentence is "If". It's just a boilerplate error message with suggestions for both types of interface (IDE/SCSI). It's not saying you have SCSI, just saying "If" you have SCSI this is what you should check.

<i>It's always the one thing you never suspected.</i>
June 4, 2002 11:49:01 AM

I had this prob with 2k, would just get started then tell me the disk corrupt, fdisk/format, same again, turned out to be a bad ram stick, funny though how it ran for ages with 98 on, with no probs at all.


If they squeeze olives to get olive oil, how do they get baby oil?
June 5, 2002 12:52:07 AM

Thanks, everyone for your suggestions. The system is up and running.
The hard drive's jumpers were set to "Cable Select" by default. I changed this to "Master." Also, I opted for the "quick" NFTS formatting option.
I'm not sure which of these changes is responsible for fixing the problem; perhaps it's both. Whatever the case might be, it works.
I hope this can be of help to someone else in the future.
Once again, thanks to you all for the input.
June 5, 2002 1:58:48 AM

Good job on getting your computer up. And, nice call Toey about checking those jumpers. :smile:

See ya around...
Bryan

<A HREF="http://www.btvillarin.com" target="_new">btvillarin.com</A>
<font color=red>Site's back up! L33t!</font color=red>
May 5, 2009 3:36:08 AM

im having the same problem... have tried everything, as well as remving the 2gigs of ram i bought before the problem started(couldnt boot into vista, so formatted the drive) now trying to install xp but getting the same error...would you guys please assist me?
May 5, 2009 1:31:57 PM

Start a new thread instead of resurrecting a 7 yr old one, look at the thread date
!