Sign in with
Sign up | Sign in
Your question

Preventing "Users" folder from being shared.

Tags:
Last response: in Windows 7
Share
March 8, 2010 12:05:19 AM

Ive been using an official release of Win7 before it was even available on the main market (Deal through the science departments of my and other universities) and this problem has been bothering me for a while. Windows 7 INSISTS on sharing my "Users" folder all the time. It states explicitly, when you click on the "What are the public folders?" link within the Network Sharing center in CP, that it wont allow you to immediately share Windows System folders (It mentions the Users folder as being one) or an entire Drive such as C: and it doesn't recommend doing this either. It says this, but it still decides to share the Users folder without asking.

Heres the specifics::

I can right click on the Users folder and go to properties and then the sharing tab. It will be listed as Shared. I then go to Advanced Sharing. I go to Permissions and completely Remove "Everyone" from this list and then uncheck Share this folder and hit apply. It successfully becomes unshared and is unlisted on my network.

I can then choose another folder such as one on my desktop, in my "My Documents" folder, or something similar, and go to its sharing Tab and choose to share it. Works just fine and only that folder becomes shared and is listed.

HOWEVER - If I choose a folder in a location such as those previously mentioned and right click it and go to share with and choose "Homegroup (Read)", it shares my ENTIRE Users directory. Not just that folder.

I want to make it so Users folder NEVER becomes listed on the network EVER unless I explicitly tell it to. This is one of the ways I feel WinXP was better :/ , I didnt do this crap. I do have password protected sharing turned on, yes - and no one will be able to just access it on a wim. But I still am cautious (I connect on campus networks all the time) and granted a little OCD about things doing stuff I didnt request to be done, but I feel like it shouldn't be this hard to make work.


On a side note: Im checking it using my laptop to see this happen. The thing is, they both have the same login ID and password (though the computer-name is different). Because of this when I go to open Users on my desktop from my laptop, it doesnt request the PW where as it would if my brother tried it from his desktop. Im thinking maybe the listing of ALL folders under Users is showing up for this reason? But the permissions are set for (Administrators (NAME-PC\NAME)) where as my laptop is (NAME-LT\NAME) for example. So Im reluctant to think thats part of the reason since I feel it should be differentiating folder list options because of differing computer-name IDs.

Can some one help me with this? :( 
a b $ Windows 7
March 8, 2010 4:34:00 AM

What edition of Windows 7 are you using? AFAIK only Professional and Ultimate have the advanced file-sharing functionality you need to better control file sharing on your network
m
0
l
March 8, 2010 2:04:59 PM

It's Professional, and it does have the advanced file sharing mode that Ive gone into. I have completely removed "Everyone" from all permissions sections such that the only people that should be able to folder list, access, read, etc etc the "Users" directory would be SYSTEM, Administrators (PCNAME\LOGIN), and Users (PCNAME\LOGIN).
m
0
l
Related resources
August 9, 2010 12:08:30 PM

Go to control panel > Folder Options > View tab. Scroll down to the bottom and uncheck "Use Sharing Wizard (Recommended)."
m
0
l
April 25, 2011 3:46:40 AM

Shovelmaster, you are awesome!!! Thank-you!!! (re: uncheck use sharing wizard)
m
0
l
December 1, 2011 6:58:45 AM

Thanks all who asked and answered this question. It helped me too.

And to me it seems extremely unwise for Windows to silently share the entire Users folder. It would not be obvious to most users that this happens, and doesn't it present a security threat?
m
0
l
February 18, 2014 8:47:59 AM

Thanks bud. I use ispy to monitor my room because of stickey fingered roommates. When i get out of the shower i go straight to my room to free up the batthroom. My laptop has. No passcodes and acess my two hard drives(pc) that share music and videos. I leave the laptop in the living room for all to use. Apparently some snoop went browsing my files and found in the user directory my cameras recordings. Stupid windows.
m
0
l
!