Sign in with
Sign up | Sign in
Your question

Weirdest Thing I've Ever Seen My Computer Do

Last response: in Storage
Share
December 15, 2003 6:27:54 PM

Ever since I've attached my new hard-drive (I now have two identical models, both 40GB Maxtor 5T040H4), I'm unable to boot from my CD-ROM (the two hard-drives are connected to IDE channel 1, the CD-ROM is by itself on IDE channel 2). Every time it attemps to boot from the CD-ROM I get the error message "cannot boot from CD, unable to find NTLDR." This might be helpful if I knew what NTLDR stood for... Very strangely, if I press CRTL+H while it's attempting to boot, it works fine (I found this out by pure luck... it's the only way I could re-install Windows XP).

I tried disconnecting the second hard-drive to see if it would reverse the problem, but it didn't. I also reset the CMOS and that didn't fix the problem either.

My mainboard is an ABIT KG7, and I'm not sure what kind of CD Drive I have, but under Device Manager, Windows XP calls it a "E-IDE CDROM 36X/AKW".

If you have any idea what can cause this kind of bug, or if you happen to know what "NTLDR" stands for, just reply to this message or send me an e-mail sometime, I'm very grateful for any help I can get about this.
December 16, 2003 7:41:45 AM

NTLDR stands for NT loader. As for the problem, did you try rearranging the boot sequence within the BIOS yet?

Undeniable facts #12:
Wisdom follows stupidity like a bitch.
December 16, 2003 6:06:45 PM

I've tried re-arranging the boot order several times... but I really need the CD-ROM to come before any of the HDDs for it to boot from CD when I want it to (otherwise it'll ignore the CD cause it'll find a working HDD). This doesn't seem to have fixed the problem....

I think the problem has to do with my Master Boot Record. A while back, I had FreeBSD loaded on my computer, and I had it overwrite the MBR so that I could choose to run either Windows or FreeBSD at startup... Then I formatted the drive with FreeBSD on it, and re-installed Windows after that.

I'm not sure how re-installing windows affects the Master Boot Record, but I know for a fact that my MBR isn't the "usual" windows MBR. I suspect that fixing the MBR will fix my problem. However, I'm not sure at all how to do this, and clearing the CMOS wasn't the solution.
!