Sign-in / Sign-up
Your question

Windows will recognize my portable hard drive but it wont show in my computer

Tags:
  • Drivers
  • Computers
  • Portable Hard Drive
  • Windows 7
Last response: in Windows 7
August 5, 2012 10:30:31 AM

Hello,
When i plug my WD passport portable hard drive into my computer, the hd will start up (the little LED will eliminate) and windows will make the "usb connection" sound and down the bottom right of the screen i have the option to safely remove my passport 0740. So windows picks up my hd but it just wont show up in my computer, it works on my other computer just not this one. i have tried changing the drive letters and that doesnt seem to help. Any ideas? using windows 7 ultimate

More about : windows recognize portable hard drive wont show computer

August 5, 2012 10:57:48 AM

Is it possible that you have accidentally closed the "drives with removable storage" tab?
And when you plug it in, does the autoplay screen pop up?
m
0
l
March 16, 2013 10:38:26 PM

mine has that same issue it does not show auto play or on my computer but it is on disk manager. help
m
0
l
Related resources
a b $ Windows 7
a b \ Driver
March 17, 2013 7:33:14 AM

If it's visible in Disk Management and has no drive letter assigned to it, right-click on it and choose Change Driver Letter & Paths.
Click "Add".
Choose a letter.
Click 'OK' and wait for the system to update itself.
m
2
l
November 27, 2013 1:15:22 PM

I had the same situation. Plugged in my WD Passport 0704 and nothing came up or showed up as a removable device in "My Computer". Also nothing showed up in Disk Management as well. But it was allowing me to safely eject the drive.

I searched the net and found most of them mention the above "disk management" solution".

If none of the above works..... This worked for me:
suggestion - unplug the drive before trying this... and uninstall all the light-grey devices that will display. I also remove light-grey devices under "WD Drive Management Devices"
------------------------------------------------------
jack4rall - Apr 25, 2012 02:27PM
Hello,
Try this 1
Click on Start --> In search box, type cmd. When it show "Command Prompt" or "cmd.exe" in the search list,
right-click on it and select the option "Open as administrator".
Open the command prompt and type the below commands:

set devmgr_show_nonpresent_devices=1 (--> Press Enter)
start devmgmt.msc (--> Press Enter)

"Device Manager" window will be opened.
Now in the device manager, click on "View" --> Select "Show hidden devices"
Now expand the nodes "Disk Drives" and "Universal serial bus controller" by clicking on "+" symbol. If you find any light-greyed entries --> Right click on it --> Select "Uninstall".
Restart your PC and connect your external drive.
Good Luck
--------------------------------------------------

Found at http://en.kioskea.net/forum/affich-650763-western-digit...
m
0
l
March 19, 2014 4:49:34 PM

Rokime said:
Hello,
When i plug my WD passport portable hard drive into my computer, the hd will start up (the little LED will eliminate) and windows will make the "usb connection" sound and down the bottom right of the screen i have the option to safely remove my passport 0740. So windows picks up my hd but it just wont show up in my computer, it works on my other computer just not this one. i have tried changing the drive letters and that doesnt seem to help. Any ideas? using windows 7 ultimate


I had te SAME problem as described! I finally solved it, it was some 'Virtual Drives' installed via CloneDVD that created that issue, hope it helps! (I uninstalled all virtual drives and CloneCD/DVD and restarted, now perfect!)

Francis
m
0
l
September 11, 2014 2:46:21 PM

Guys, use disk management to assign a drive path letter and viola.

My problem:

Win 8.1
All usb periphs fine
Couldn't get Toshiba/wd flash drives to recognize
Could see them as "mass storage device" in device manager
Could see them under disk management but didn't have drive path assigned (no letter designation)
Could _not_ see them in "my computer"

My solution:

Both drives were formatted e:\ and f:\ from my 7 computer....my 8.1 already has internal e:\ and f:\

So, on my 8.1 machine, click file explorer icon > this computer > right click this PC > disk management > drive should be visible minus drive path > right click drive> change drive letter and path > follow instructions and choose a drive path not currently being used i.e. K or L or Q.

Viola, should get notifications that drive is recognized etc. I did check backwards compatibility of the fix. They still work on my 7 machine just fine. I also tried to change the drive path through the 7 machine to one not being utilized on the 8.1 but that didn't work, you have to change the drive path on the 8/8.1 machine for this fix to work....good luck!.
m
0
l
September 21, 2014 10:38:49 AM

Alamoz28 said:
Guys, use disk management to assign a drive path letter and viola.

My problem:

Win 8.1
All usb periphs fine
Couldn't get Toshiba/wd flash drives to recognize
Could see them as "mass storage device" in device manager
Could see them under disk management but didn't have drive path assigned (no letter designation)
Could _not_ see them in "my computer"

My solution:

Both drives were formatted e:\ and f:\ from my 7 computer....my 8.1 already has internal e:\ and f:\

So, on my 8.1 machine, click file explorer icon > this computer > right click this PC > disk management > drive should be visible minus drive path > right click drive> change drive letter and path > follow instructions and choose a drive path not currently being used i.e. K or L or Q.

Viola, should get notifications that drive is recognized etc. I did check backwards compatibility of the fix. They still work on my 7 machine just fine. I also tried to change the drive path through the 7 machine to one not being utilized on the 8.1 but that didn't work, you have to change the drive path on the 8/8.1 machine for this fix to work....good luck!.


This worked! Thanks.
m
0
l
October 28, 2014 12:29:14 PM

HI, same problem here and think that allocating a disk letter should be the solution but keep getting a dialogue box pop-up that says 'The operation failed to complete bec the Disk Mgt console view is not up to date. Refresh the view by using the refresh task. If the problem persists close the DM console, then restart DM or restart the computer'.

Just that no amount of restarting DM or the pc as instructed,would help. The same dialogue box pops up every time. I'm on Windows Vista and could see my portable hard disk in DM that just reflect these text '465.6GB'. The 'change disk letter' command does however work on the other C and D (recovery) drives, just not this one. I wonder if it's because I did not install SP2 for vista (had installation probs before) or else format the disk disk but is a hassle to transfer out all data first.

Lastly, tried the 'uninstall grey-out entries' bit but I didn't see any grey-out bits.. just the the picture icon and description text.

Appreciate any further advice thxs.


m
0
l
November 10, 2014 1:12:48 AM

phil22 said:
If it's visible in Disk Management and has no drive letter assigned to it, right-click on it and choose Change Driver Letter & Paths.
Click "Add".
Choose a letter.
Click 'OK' and wait for the system to update itself.


thank you dear, that helped 100% and very simple.
i think we are getting this issue because of:

maybe we tried to repartition the hard driver, or set the drive as primary drive, your external hard drive may work first time, but because it is primary and when you unplug it unsafely, it may lose the ability to be recognized again, so change the drive letter as it was before, and keep trying letter and it works.
m
0
l
November 19, 2014 12:57:00 AM

Alamoz28 said:
Guys, use disk management to assign a drive path letter and viola.

My problem:

Win 8.1
All usb periphs fine
Couldn't get Toshiba/wd flash drives to recognize
Could see them as "mass storage device" in device manager
Could see them under disk management but didn't have drive path assigned (no letter designation)
Could _not_ see them in "my computer"

My solution:

Both drives were formatted e:\ and f:\ from my 7 computer....my 8.1 already has internal e:\ and f:\

So, on my 8.1 machine, click file explorer icon > this computer > right click this PC > disk management > drive should be visible minus drive path > right click drive> change drive letter and path > follow instructions and choose a drive path not currently being used i.e. K or L or Q.

Viola, should get notifications that drive is recognized etc. I did check backwards compatibility of the fix. They still work on my 7 machine just fine. I also tried to change the drive path through the 7 machine to one not being utilized on the 8.1 but that didn't work, you have to change the drive path on the 8/8.1 machine for this fix to work....good luck!.


Change drive letter and path is greyed out. Now what?
m
0
l
January 1, 2015 6:28:35 AM

All these solutions are good and well, but what benefit does it have when the problem isnt resolved when the next time u plugin the USB hdd and u need to go all over again to Hard drive management etc etc ... Any concrete solution that "really" fix this problem ?
Imo, i reckon it has something to to do with beiing a primary partion instead of an extended one, or to have 1 hidden one and 1 not hidden but for one reason they both stay hidden ? ( This is my situation atm ).
Thats what i think of myself, because with the same hdd i didnt had this problem earlier having 1 primary "BOOT" ( not hidden ) partition and 1 extended "DATA" ( not hidden ) partition.
Its from the start i made them 2 primary partitions ( the "boot" i made hidden to work faster not detecting it as its not needed when i acces an OS ) this problem was starting to occur, and not on 1 system, on more systems ;) 

So i think (imo) there are 2 reasons : mixed hidden and not hidden partition or working with multiple "primary" partitions wich makes this problem pop up on some systems?
Plugging in before pc is turned-on wont work aswell, only manually adding driveletters works atm.
m
0
l
January 1, 2015 7:32:02 AM

Hi I got the same issue and I fixed it by plug in it to my pc before start the windows!
If there is no any other solution, you can try this also!
m
0
l
March 27, 2015 10:06:35 PM

thifran said:
Rokime said:
Hello,
When i plug my WD passport portable hard drive into my computer, the hd will start up (the little LED will eliminate) and windows will make the "usb connection" sound and down the bottom right of the screen i have the option to safely remove my passport 0740. So windows picks up my hd but it just wont show up in my computer, it works on my other computer just not this one. i have tried changing the drive letters and that doesnt seem to help. Any ideas? using windows 7 ultimate


I had te SAME problem as described! I finally solved it, it was some 'Virtual Drives' installed via CloneDVD that created that issue, hope it helps! (I uninstalled all virtual drives and CloneCD/DVD and restarted, now perfect!)

Francis


Hi.. How did you do. please explain. I had the same issue. Drive showing as H: in computer. Not able to open Disk Management when WD my passport connected. I reinstalled drive but still not working. Please advise.
m
0
l
April 3, 2015 6:49:31 PM

Furdmonster said:
Alamoz28 said:
Guys, use disk management to assign a drive path letter and viola.

My problem:

Win 8.1
All usb periphs fine
Couldn't get Toshiba/wd flash drives to recognize
Could see them as "mass storage device" in device manager
Could see them under disk management but didn't have drive path assigned (no letter designation)
Could _not_ see them in "my computer"

My solution:

Both drives were formatted e:\ and f:\ from my 7 computer....my 8.1 already has internal e:\ and f:\

So, on my 8.1 machine, click file explorer icon > this computer > right click this PC > disk management > drive should be visible minus drive path > right click drive> change drive letter and path > follow instructions and choose a drive path not currently being used i.e. K or L or Q.

Viola, should get notifications that drive is recognized etc. I did check backwards compatibility of the fix. They still work on my 7 machine just fine. I also tried to change the drive path through the 7 machine to one not being utilized on the 8.1 but that didn't work, you have to change the drive path on the 8/8.1 machine for this fix to work....good luck!.


Change drive letter and path is greyed out. Now what?


Apologies for ages of delay.......did you resolve this? If not please describe more explicitly where this occurs in the process and I'll do my best to help you out.

m
0
l
November 10, 2015 6:38:22 AM

Rokime said:
Hello, When i plug my WD passport portable hard drive into my computer, the hd will start up (the little LED will eliminate) and .....


Hey, I hope you meant "illuminate". The word "eliminate" means "to remove", and sometimes, in the medical world, it means to empty one's bowels. Just noting for future reference.....
m
0
l
March 7, 2016 6:40:27 PM

on windows 10, go to computer management > disk management and then right click on the HD and choose "Change driver letter or path"
choose any different letter and then hi OK,

that's how I fixed my similar issue just now
m
1
l
March 27, 2016 1:17:54 PM

Rokime said:
Hello,
When i plug my WD passport portable hard drive into my computer, the hd will start up (the little LED will eliminate) and windows will make the "usb connection" sound and down the bottom right of the screen i have the option to safely remove my passport 0740. So windows picks up my hd but it just wont show up in my computer, it works on my other computer just not this one. i have tried changing the drive letters and that doesnt seem to help. Any ideas? using windows 7 ultimate


Same issues here with THREE of these stupid things! Why I didnt learn after the first 2 failed I will never know, clearly I enjoy getting ripped off. I called WD and put my problem to them were upon they told me I should have backed up my files O_O I told him ummm thats what I bought your F*&$ing xtrnal HD for, hung up and went out and bought a Seagate!
m
0
l
July 18, 2016 7:11:45 PM

This is not a solution but a cry for help.

I have slightly a different circumstance from everyone else. I am using Windows 10 and I ,also, can not read my external hard drive. I can not see it in the "Devices and Drives" but I can see under "Devices and Printers" and can also eject it. However, I do not see it under Disk Management, but I do see it under Device Manager - Disk Drivers. I have tried updating the Driver softwares and no change. It is obvious to me that a drive needs to be assigned to this external drive but it does not show up in the Disk Management. Is it normal, under Disk Management, to find a "Disk 2" with a symbol of red circle and a down arrow? Underneath the Disk 2 it says unknown and not initialized. I have tried to initialized it but get this message: "the semaphore timeout period has expired."

Also, I have tried removing the device from "Devices and Printers" and "Disk drives," then add the device, but no change.
Another interesting observation, if I restart my computer and have this external hard drive connected, my computer would not completely restart. It will get stuck in the inital first stage of the restart. The only way to allow my computer to continue restarting is for me to disconnect the external hard drive from the computer.

Additional information:
I usually had two external hard drives connected to my computer at the same time. Now only one of the two is accessible. However, if I turn off the accessible one and then turn it back on, it will take at least 10 minutes for my computer to acknowledge it. (That is not normal.) This particular external hard drive not does affect the restart of my computer.

The nonreadable/ nonaccessible external hard drive is model Buffalo HD-LCU3.

Any suggestions?
m
0
l
July 20, 2016 9:06:52 AM

Thanks a Million! Solved the problem
m
0
l