Sign in with
Sign up | Sign in
Your question

ActiveX Error Messages

Last response: in Windows XP
Share
Anonymous
June 10, 2005 7:26:13 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Hi,

I wanted to install some software yesterday, and it came on a CD as you
would expect. But when I tried to autoplay the CD, (the CD also
contained al, the installation instructions), all I got was the
following error message:

"Your current security settings prohibit running ActiveX controls on
this page. As a result, the page may not display correctly."

The error message was correct, in that all that was displayed was a
blank window...

I tried to amend my security settings in Internet Explorer, which were
already set to 'Medium' in any case, by lowering them to 'Low'. (I
wasn't on-line or anything, of course; I just wanted the CD to play.)
But even after doing that I still got the error message, and I have yet
to see my software installation instructions...

I also get an odd error message when I try to view Help in Office XP,
which I believe is also related to the ActiveX thing:

"A Runtime Error has occurred. Do you wish to Debug? Line: 22 Error:
Automation server can't create object"

Does anyone know where else it is possible to change the ActiveX
settings please?

I am running Windows XP Pro SP2.

Cheers,
Robin McInnes
Cheshire, UK

(Email address contains a spam-trap. Remove it to mail me.)

More about : activex error messages

Anonymous
June 10, 2005 7:26:14 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

On Fri, 10 Jun 2005 15:26:13 +0100, Robin McInnes wrote:

> Hi,
>
> I wanted to install some software yesterday, and it came on a CD as you
> would expect. But when I tried to autoplay the CD, (the CD also
> contained al, the installation instructions), all I got was the
> following error message:
>
> "Your current security settings prohibit running ActiveX controls on
> this page. As a result, the page may not display correctly."
>
> The error message was correct, in that all that was displayed was a
> blank window...
>
> I tried to amend my security settings in Internet Explorer, which were
> already set to 'Medium' in any case, by lowering them to 'Low'. (I
> wasn't on-line or anything, of course; I just wanted the CD to play.)
> But even after doing that I still got the error message, and I have yet
> to see my software installation instructions...
>
> I also get an odd error message when I try to view Help in Office XP,
> which I believe is also related to the ActiveX thing:
>
> "A Runtime Error has occurred. Do you wish to Debug? Line: 22 Error:
> Automation server can't create object"
>
> Does anyone know where else it is possible to change the ActiveX
> settings please?
>
> I am running Windows XP Pro SP2.
>
> Cheers,
> Robin McInnes
> Cheshire, UK
>
> (Email address contains a spam-trap. Remove it to mail me.)

There's another setting in IE Internet Options that should help with this.
It's on the Advanced page and towards the bottom. Place a check in the box
next to "allow active content from CDs run on My Computer." That change
should get you through the installation.

You may also need to check the next box : "allow active content to run in
files on My Computer." This one is useful with some of the fancier html
help files provided with some programs.

--
Sharon F
MS-MVP ~ Windows Shell/User
Anonymous
June 10, 2005 7:26:14 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Robin McInnes wrote:
> Hi,
>
> I wanted to install some software yesterday, and it came on a CD as
> you would expect. But when I tried to autoplay the CD, (the CD also
> contained al, the installation instructions), all I got was the
> following error message:
>
> "Your current security settings prohibit running ActiveX controls on
> this page. As a result, the page may not display correctly."
>
> The error message was correct, in that all that was displayed was a
> blank window...
>
> I tried to amend my security settings in Internet Explorer, which were
> already set to 'Medium' in any case, by lowering them to 'Low'. (I
> wasn't on-line or anything, of course; I just wanted the CD to play.)
> But even after doing that I still got the error message, and I have
> yet to see my software installation instructions...
>
> I also get an odd error message when I try to view Help in Office XP,
> which I believe is also related to the ActiveX thing:
>
> "A Runtime Error has occurred. Do you wish to Debug? Line: 22 Error:
> Automation server can't create object"
>
> Does anyone know where else it is possible to change the ActiveX
> settings please?
>
> I am running Windows XP Pro SP2.
>
> Cheers,
> Robin McInnes
> Cheshire, UK
>
> (Email address contains a spam-trap. Remove it to mail me.)

Internet Options... > Advanced tab >scroll down to the Security section
> place a checkmark next to Allow active content from CDs to run on My
Computer.

--
Peace!
Kurt
Self-anointed Moderator
microscum.pubic.windowsexp.gonorrhea
http://microscum.com/mscommunity
"Trustworthy Computing" is only another example of an Oxymoron!
"Produkt-Aktivierung macht frei"
Related resources
Can't find your answer ? Ask !
Anonymous
June 11, 2005 7:55:38 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

kurttrail wrote:

>Robin McInnes wrote:
>
>
>>Hi,
>>
>>I wanted to install some software yesterday, and it came on a CD as
>>you would expect. But when I tried to autoplay the CD, (the CD also
>>contained al, the installation instructions), all I got was the
>>following error message:
>>
>>"Your current security settings prohibit running ActiveX controls on
>>this page. As a result, the page may not display correctly."
>>
>>The error message was correct, in that all that was displayed was a
>>blank window...
>>
>>I tried to amend my security settings in Internet Explorer, which were
>>already set to 'Medium' in any case, by lowering them to 'Low'. (I
>>wasn't on-line or anything, of course; I just wanted the CD to play.)
>>But even after doing that I still got the error message, and I have
>>yet to see my software installation instructions...
>>
>>I also get an odd error message when I try to view Help in Office XP,
>>which I believe is also related to the ActiveX thing:
>>
>>"A Runtime Error has occurred. Do you wish to Debug? Line: 22 Error:
>>Automation server can't create object"
>>
>>Does anyone know where else it is possible to change the ActiveX
>>settings please?
>>
>>I am running Windows XP Pro SP2.
>>
>>Cheers,
>>Robin McInnes
>>Cheshire, UK
>>
>>(Email address contains a spam-trap. Remove it to mail me.)
>>
>>
>
>Internet Options... > Advanced tab >scroll down to the Security section
> > place a checkmark next to Allow active content from CDs to run on My
>Computer.
>
>
>
Sharon & Kurt,

Thanks for that. Both the CD and the File options were both un-checked
in my IE Advanced Options Tab.

I have now checked them both. Unfortunately the CD will still not play,
(I get exactly the same error message), and I still get the error
message when I use Office help too.

Puzzling...

When amending the IE options, does it make any difference whether IE is
actually set as the default browser? My default browser is Firefox.

Cheers,
Robin McInnes
Cheshire, UK

(Email address contains a spam-trap. Remove it to mail me.)
Anonymous
June 11, 2005 7:55:39 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Robin McInnes wrote:
> kurttrail wrote:
>
>> Robin McInnes wrote:
>>
>>
>>> Hi,
>>>
>>> I wanted to install some software yesterday, and it came on a CD as
>>> you would expect. But when I tried to autoplay the CD, (the CD also
>>> contained al, the installation instructions), all I got was the
>>> following error message:
>>>
>>> "Your current security settings prohibit running ActiveX controls on
>>> this page. As a result, the page may not display correctly."
>>>
>>> The error message was correct, in that all that was displayed was a
>>> blank window...
>>>
>>> I tried to amend my security settings in Internet Explorer, which
>>> were already set to 'Medium' in any case, by lowering them to
>>> 'Low'. (I wasn't on-line or anything, of course; I just wanted the
>>> CD to play.) But even after doing that I still got the error
>>> message, and I have yet to see my software installation
>>> instructions... I also get an odd error message when I try to view
>>> Help in Office
>>> XP, which I believe is also related to the ActiveX thing:
>>>
>>> "A Runtime Error has occurred. Do you wish to Debug? Line: 22 Error:
>>> Automation server can't create object"
>>>
>>> Does anyone know where else it is possible to change the ActiveX
>>> settings please?
>>>
>>> I am running Windows XP Pro SP2.
>>>
>>> Cheers,
>>> Robin McInnes
>>> Cheshire, UK
>>>
>>> (Email address contains a spam-trap. Remove it to mail me.)
>>>
>>>
>>
>> Internet Options... > Advanced tab >scroll down to the Security
>> section
>>> place a checkmark next to Allow active content from CDs to run on
>>> My Computer.
>>
>>
>>
> Sharon & Kurt,
>
> Thanks for that. Both the CD and the File options were both un-checked
> in my IE Advanced Options Tab.
>
> I have now checked them both. Unfortunately the CD will still not
> play, (I get exactly the same error message), and I still get the
> error message when I use Office help too.
>
> Puzzling...
>
> When amending the IE options, does it make any difference whether IE
> is actually set as the default browser? My default browser is Firefox.
>
> Cheers,
> Robin McInnes
> Cheshire, UK
>
> (Email address contains a spam-trap. Remove it to mail me.)

Interesting problem. But I would try making IE your Default browser,
and then run you CD and Office help, and see if the problem persists.

--
Peace!
Kurt
Self-anointed Moderator
microscum.pubic.windowsexp.gonorrhea
http://microscum.com/mscommunity
"Trustworthy Computing" is only another example of an Oxymoron!
"Produkt-Aktivierung macht frei"
Anonymous
June 12, 2005 11:13:03 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Each time is try to access the compatibility wizard in Help and Support I
receive an error script message and and error saying "Automation server can't
create object"

I have tried the other suggestions on this topic - without success.

Any ideas?

David C

"kurttrail" wrote:

> Robin McInnes wrote:
> > kurttrail wrote:
> >
> >> Robin McInnes wrote:
> >>
> >>
> >>> Hi,
> >>>
> >>> I wanted to install some software yesterday, and it came on a CD as
> >>> you would expect. But when I tried to autoplay the CD, (the CD also
> >>> contained al, the installation instructions), all I got was the
> >>> following error message:
> >>>
> >>> "Your current security settings prohibit running ActiveX controls on
> >>> this page. As a result, the page may not display correctly."
> >>>
> >>> The error message was correct, in that all that was displayed was a
> >>> blank window...
> >>>
> >>> I tried to amend my security settings in Internet Explorer, which
> >>> were already set to 'Medium' in any case, by lowering them to
> >>> 'Low'. (I wasn't on-line or anything, of course; I just wanted the
> >>> CD to play.) But even after doing that I still got the error
> >>> message, and I have yet to see my software installation
> >>> instructions... I also get an odd error message when I try to view
> >>> Help in Office
> >>> XP, which I believe is also related to the ActiveX thing:
> >>>
> >>> "A Runtime Error has occurred. Do you wish to Debug? Line: 22 Error:
> >>> Automation server can't create object"
> >>>
> >>> Does anyone know where else it is possible to change the ActiveX
> >>> settings please?
> >>>
> >>> I am running Windows XP Pro SP2.
> >>>
> >>> Cheers,
> >>> Robin McInnes
> >>> Cheshire, UK
> >>>
> >>> (Email address contains a spam-trap. Remove it to mail me.)
> >>>
> >>>
> >>
> >> Internet Options... > Advanced tab >scroll down to the Security
> >> section
> >>> place a checkmark next to Allow active content from CDs to run on
> >>> My Computer.
> >>
> >>
> >>
> > Sharon & Kurt,
> >
> > Thanks for that. Both the CD and the File options were both un-checked
> > in my IE Advanced Options Tab.
> >
> > I have now checked them both. Unfortunately the CD will still not
> > play, (I get exactly the same error message), and I still get the
> > error message when I use Office help too.
> >
> > Puzzling...
> >
> > When amending the IE options, does it make any difference whether IE
> > is actually set as the default browser? My default browser is Firefox.
> >
> > Cheers,
> > Robin McInnes
> > Cheshire, UK
> >
> > (Email address contains a spam-trap. Remove it to mail me.)
>
> Interesting problem. But I would try making IE your Default browser,
> and then run you CD and Office help, and see if the problem persists.
>
> --
> Peace!
> Kurt
> Self-anointed Moderator
> microscum.pubic.windowsexp.gonorrhea
> http://microscum.com/mscommunity
> "Trustworthy Computing" is only another example of an Oxymoron!
> "Produkt-Aktivierung macht frei"
>
>
>
Anonymous
June 12, 2005 3:52:20 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

David C wrote:
> Each time is try to access the compatibility wizard in Help and
> Support I receive an error script message and and error saying
> "Automation server can't create object"
>
> I have tried the other suggestions on this topic - without success.
>
> Any ideas?


Try reinstalling the Windows Script Host.

http://download.microsoft.com/download/2/8/a/28a5a346-1...

--
Peace!
Kurt
Self-anointed Moderator
microscum.pubic.windowsexp.gonorrhea
http://microscum.com/mscommunity
"Trustworthy Computing" is only another example of an Oxymoron!
"Produkt-Aktivierung macht frei"
Anonymous
June 13, 2005 1:58:23 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

kurttrail wrote:

>>>
>>>
>>>
>>Sharon & Kurt,
>>
>>Thanks for that. Both the CD and the File options were both un-checked
>>in my IE Advanced Options Tab.
>>
>>I have now checked them both. Unfortunately the CD will still not
>>play, (I get exactly the same error message), and I still get the
>>error message when I use Office help too.
>>
>>Puzzling...
>>
>>When amending the IE options, does it make any difference whether IE
>>is actually set as the default browser? My default browser is Firefox.
>>
>>Cheers,
>>Robin McInnes
>>Cheshire, UK
>>
>>(Email address contains a spam-trap. Remove it to mail me.)
>>
>>
>
>Interesting problem. But I would try making IE your Default browser,
>and then run you CD and Office help, and see if the problem persists.
>
I made IE my default browser and tested the problems. No change; CD
still wouldn't play and the error message still gets thrown up in Office
help.

Just to be sure I'd defaulted IE, I did a re-boot with IE as the
default, but there was still no change whatever.

There is an allow/deny ActiveX option in my Firewall, (Kerio), and
although that was already un-checked (to allow ActiveX) I disabled the
firewall completely and tried once more. Exactly the same result.

Noting the recommendation to David C regarding the scripting host, (and
the similarity of his error message), I also downloaded and installed
that from the link. Still no change: CD won't play and the error message
in Office help is unchanged.

I can't understand where this alleged security setting which is
preventing ActiveX is sitting on my machine at all.

Cheers,
Robin McInnes
Cheshire, UK

(Email address contains a spam-trap. Remove it to mail me.)
Anonymous
June 25, 2005 2:39:03 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I have tried all the suggestions to correct this error - but so far without
success. I have tried to think back to what might have caused this and I have
been wondering if Microsoft anti-spyware has removed something it shouldn't?
Has anyone else with is problem used Microsoft anti-spyware?

I have also wondered about using the system restore - but how far do I go
back?

David C


"Robin McInnes" wrote:

> kurttrail wrote:
>
> >>>
> >>>
> >>>
> >>Sharon & Kurt,
> >>
> >>Thanks for that. Both the CD and the File options were both un-checked
> >>in my IE Advanced Options Tab.
> >>
> >>I have now checked them both. Unfortunately the CD will still not
> >>play, (I get exactly the same error message), and I still get the
> >>error message when I use Office help too.
> >>
> >>Puzzling...
> >>
> >>When amending the IE options, does it make any difference whether IE
> >>is actually set as the default browser? My default browser is Firefox.
> >>
> >>Cheers,
> >>Robin McInnes
> >>Cheshire, UK
> >>
> >>(Email address contains a spam-trap. Remove it to mail me.)
> >>
> >>
> >
> >Interesting problem. But I would try making IE your Default browser,
> >and then run you CD and Office help, and see if the problem persists.
> >
> I made IE my default browser and tested the problems. No change; CD
> still wouldn't play and the error message still gets thrown up in Office
> help.
>
> Just to be sure I'd defaulted IE, I did a re-boot with IE as the
> default, but there was still no change whatever.
>
> There is an allow/deny ActiveX option in my Firewall, (Kerio), and
> although that was already un-checked (to allow ActiveX) I disabled the
> firewall completely and tried once more. Exactly the same result.
>
> Noting the recommendation to David C regarding the scripting host, (and
> the similarity of his error message), I also downloaded and installed
> that from the link. Still no change: CD won't play and the error message
> in Office help is unchanged.
>
> I can't understand where this alleged security setting which is
> preventing ActiveX is sitting on my machine at all.
>
> Cheers,
> Robin McInnes
> Cheshire, UK
>
> (Email address contains a spam-trap. Remove it to mail me.)
>
Anonymous
June 25, 2005 3:11:06 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

On Fri, 24 Jun 2005 22:39:03 -0700, David C wrote:

> I have tried all the suggestions to correct this error - but so far without
> success. I have tried to think back to what might have caused this and I have
> been wondering if Microsoft anti-spyware has removed something it shouldn't?
> Has anyone else with is problem used Microsoft anti-spyware?
>
> I have also wondered about using the system restore - but how far do I go
> back?

Somewhat related as ActiveX in HTML help files, in programs with html-type
interfaces and autoplay cd's with html type menus/navigation are effected
by changes due to security updates:

Certain HTML Help features may not work on some Web sites after you install
security update MS05-026 or security update MS05-001
http://support.microsoft.com/default.aspx?scid=kb;en-us;892675

This doesn't help to resolve your problem. Possibly you could hammer out a
solution but at least it will give you a better idea of what is happening
behind the scenes.

--
Sharon F
MS-MVP ~ Windows Shell/User
!