Sign in with
Sign up | Sign in
Your question

PC Hangs After Standby

Last response: in Windows 7
Share
March 8, 2010 10:30:58 AM

Hello!

I've got a new computer with Windows OS 7 and the following HW:

Intel CPU i5,
Gigabyte GA-P55M-UD2,
Radeon 5750 graphics,
1 TB Seagate Barracuda 7200.12.

My problem is that the computer hangs when it goes out of standby. The computers come out of standby and everything is displayed on the screen immediately. I can move the mouse, and even switch between the windows are open, but I can not do anything active in the open applications - actually I can do a few actions before the OS hangs, open a web page in Firefox is an example. There is apparently no programs that use the CPU, since the general CPU meter gadget show 0%. This state persists for about 2 minutes then the computer works normally.

I have just reinstalled Windows 7, updated everything through Windows Update, installed the ATI display driver, Firefox, and Dropbox. The problem is still there. I tried to uninstall Dropbox, but that did not change anything.

I have searched something on Google about the problem but have not encountered someone describing the problem or its solution.

I hope that some in this forum can help me! Ask if there are some more information of interest.

More about : hangs standby

a b $ Windows 7
March 8, 2010 11:22:19 AM

I know that I had issues with trying to come out of sleep/standby mode and it was because of hardware that didn't support sleep mode, which turned out to be my network card. When I would come out of sleep mode, my network connection would not resume without a reboot.

I had to go to device manager and configure the network card by unchecking the box that says "allow computer to turn off this device to save power" or something like that. Once I did that, I had no issues waking up from sleep mode.

I would suggest setting all your hardware to this setting and then enable each piece one-by-one, set your PC to go into sleep mode and then wake it up again to see if the problem persists. Hopefully, you'll find what is causing the problem.

You might want to also check your BIOS and make sure you have all the proper settings set for sleep mode (usually in the Power Management Setup section of your BIOS).
m
0
l
March 15, 2010 8:32:29 AM

This does not help me. It also seems like my problem has a different character; everything is working, but the system just hangs after start up. What is a little funny is that if I go to system hibernation, then I don't have the problem. Also if I use S1 standby instead of S3, the problem is not occurring. But with S1, only cutting 10-20 % of the wattage, I am not going to use that.
I have updated every driver, and the BIOS with no effect.
m
0
l
Related resources
March 22, 2010 5:57:09 AM

I had a similar problem a little while ago, except the computer wouldn't even respond coming out of sleep (aside from LED's lighting up), and I actually had to unplug the thing and leave it for 10 minutes to get it to even start up again. Shutting down and restarting, just restarting, hibernate and S1 suspend all worked fine, but S3 would would sink it for a while. Long story short, one of the RAM sticks wasn't seated properly. Your problem doesn't sound hardware related, but it's just a thought.

If you can, something else you might try is partitioning your HD to install Ubuntu (20 GB will more than do the trick) and playing with its standby mode. That might tell you if it's a Windows problem, Windows driver problem, or something with the BIOS or the hardware.

Also, did you build this machine? Are you using the Windows drivers or the drivers that came with the motherboard and graphics card? What PSU are you using? And just to be clear, you don't have to reset your system when it comes out of standby, you just have to wait a couple of mintues (while it gets the sleep out of its eyes, so to speak), right?

I hope this helps, and please let us know how it turns out.
m
0
l
August 16, 2012 2:20:17 AM

As steppenwolff mentioned, I had a similar problem this week.

Origen AE S21T
Cooler Master Real Power M700
Asus P6T Deluxe, Intel X58, Sok 1366 - BIOS 2209
Intel i7 920, Socket 1366 (B), Nehalem, 2.66GHz
Noctua NH-C12P Top-Down CPU Heatpipe Heatsink with NF-P12 Fan
(6x2GB) Corsair Dominator DDR3, PC3-12800 (1600), 240 Pin, Non-ECC Unbuffered, CAS 8, DHX, EPP - TR3X6G1600C8D
Asus 9600 GT 512MB, PCI-E 2.0(x16), Mem 1800MHz GDDR3, GPU 650MHz
Asus Xonar Hdav 1.3 \ Deluxe True HDMI Soundcard
RAID 2x 300 GB Western Digital WD3000GLFS VelociRaptor
LG GGW-H20L Super Multi Blu-Ray Writer & HD ROM
Windows 7 x64 Ultimate

The computer would go to sleep properly, but wouldn't even respond coming out of sleep (aside from LED's lighting up, the fans rotating, harddisks spinning but no screen output and no usb hub lights or devices worked).
In my case, I had to hold the power button until it shut down. When I tried to switch back on, again, aside from LED's lighting up, the fans rotating, harddisks spinning there was no screen output and no usb hub lights or devices worked. I then shut it down a second time and this time the familiar BIOS screen would come up showing that the computer started.

As with steppenwolff, shutting down and restarting, or just restarting, or hibernate or S1 suspend all worked fine. S3 however would make the computer hang on resuming from S3.

Long story LONG in my case.
At first I thought it was a software issue. I used msconfig to turn off all services and startup items.
It worked... I begun putting services back to normal and still worked. Then I begun putting startup items back to normal and about an hour into the experiment, it stopped! At this point I had almost all startup items back to normal. So I went ahead to disable the last batch of items which I previously enabled to see which one was the culprit. NOTHING. I ended up disabling EVERYTHING including services, ending up where I started from more than an hour ago! NOTHING!
This was such a waste of time, but led me to believe that it was not the software but something more sinister.
So I started concentrating my efforts on the BIOS. The reason was because I recenlty upgraded to the latest BIOS from ASUS 2209 for the P6T x58 slot 1366. I had to downgrade back to 1904 which was the BIOS I had since it came out and I was 100% sure S3 used to work with it since 2009 when I built the computer.
I downgraded and tried to remember the settings I had before. NOTHING. Played around with the settings for hours. I upgraded the firmware of a Marvel onboard controller, NOTHING. I upgraded the drivers for my Intel Rapid Storage (I am running RAID), NOTHING.
Played around with msconfig, played around with BIOS settings and I started getting pissed off.
As I am running a dual monitor system, I was also moving back and forth between using the first screen,
or the second screen. At some point, when connected to my HDMI screen only, it started working, but when I connected both screens, it stopped. Then it would not worked with either one of them!
It was really getting on my nerves by now and we are talking days of testing and thousands of restarts!
This erratic behaviour though told me that it was something to do with power.
I got my computer down to its guts and sat it on a bench with only one screen and a keyboard and started testing some more. I unplugged what was not necessary, replaced all wires with new ones and after many hours of testing, around 7am, I wanted to throw it out the window. As a sign of desperation,
I then decided to change the power cable positions. I have a modular power supply from Cooler Master the Real Power M700 which allows you to connect power cables to different slots on 2 separate rails. I thought that maybe I was drawing too much power on a single rail. What I had plugged in at the time was the Asus P6T Deluxe motherboard, a EN9600GT graphics card, 2 WD velociraptors and my internal 12'' display. I just moved my display cable from the rail where the velociraptors were to the EN9600GT rail. BANG! it worked, and it worked for about an hour and I was thanking God for relieving me of this terrible torture I was now enduring for a few days.
I decided to put everything back together, close the machine and take it back to its place under the TV - its a HTPC - Origen S21T case. There, I connected the usb devices, network cables and fired it up!
I then proceeded in restoring from backup a good image of my OS and left it while I went to sleep happy!
...did you guess it?
The next evening I was having the same problem again!
My girlfriend was by now openly stating that she felt sorry for me and she was describing the computer in words that cannot be repeated here! This was 2 days ago.
I new I had to open the thing up again and start all over again. I still was not sure where the problem was originating. I mean, EVERYTHING with the computer was perfect except this annoying issue with resume from S3.
Back on the bench I noticed that with BIOS 2209, and when my computer hang after resume from S3, at the next BIOS POST, my RAM would show up as 8GB instead of 12GB. I was losing 4GB.
I decided to investigate. The only way I could make the BIOS recognize the lost RAM was by clearing the RTC RAM. this is a jumper on the mother board. Then the BIOS would read all 12GB again. Also as I was watching the RAM capacity at POST, I also noticed that my RAM would be identified as DDR3 1066MHz instead of 1600MHz of the Corsair Dominators I have. I started thinking that my RAM was failing, even though in the past I run Memtest and the like. So I started removing my RAM and BANG! It worked with the first pair I stuck in there and it worked reboot after reboot and restart after restart.
I marked the pair and proceeded to the next pair. These too worked properly with S3 resume time after time. I then proceeded with the last pair. This time S3 resume failed.
Aha!!! it was the RAM I thought! I placed the last pair that worked and restarted. NOTHING! Then the first pair. Again NOTHING! It was like a CURSE really. A CURSE!
I googled P6T and Dominators and found indications on how to properly program the BIOS to work correctly with them. I did that and my machine would crash and burn before even getting to the log on screen. Something was seriously wrong.
I went back to the 1904 BIOS, with default settings and proceeded to remove windows 7 SP1 as some people were posting problems with SP1 and S3. NO CHANGE. Also the patch from Microsoft for Marvel controllers was already installed. Another dead end.
I was so tired and gutted by this behaviour I decided to call it a day.
It was probably NOT the RAM but I was not sure. The only things left untouched by now, were the motherboard, the graphics card, and the power supply. I had no other graphics card and no other motherboard to test with but I had a spare power supply in another PC. I did not want to go there but I knew that when I would wake up this is what I had to do. Really I did not believe that there would be something wrong with the power supply but I was having some indications by now. I was not drawing much power at all and I could not even recognize my RAM?
So today, I gutted my other PC got the power supply out a Nitrox SL-650 and plugged everything in. Powered up, went to the login screen, pressed the shutdown button and went to sleep. 10 seconds later, I pressed the button again and here it comes back up! mmmm could this be it?
Tried the same thing again and again and again rebooted, logged in tried again, restored services, startup items, tried again, resumed tried again and again and again. This could be it!
Went to the BIOS, set my RAM correctly, rebooted went to login screen with NO PROBLEMS.
Tried again and again and again..... WOW!!! Put all my RAM back in. Again and again without fail my computer could resume from S3 properly.

What a week... I am really happy now with the results, but so mentally tired and drained. I hope none of you go through this experience.
I have already packed the power supply and will be returning it tomorrow. It has a five year warranty and it is almost four years now. It is a beautful power supply with a clever and convenient modular design. I cannot believe it is failing already at less than 4 years. It was dusted regularly with a blower so it is not a heat issue and the capacitors inside look healthy. As far as capabilities are concerned, the m700 is clearly more powerful on spec except on 3.3v and 5v where it outputs 25A as opposed to 28A on the Nitrox. It is not a case of the extra 3A of the Nitrox. The M700 is certainly FAILING.

I hope this helps you in some way. If it does, let other people know of your experience.
m
0
l
!