Sign in with
Sign up | Sign in
Your question

HELP:Installed Linux and screwed everything up

Tags:
Last response: in Linux/Free BSD
Share
January 18, 2001 5:40:28 AM

Hey I just installed Linux Mandrake 7.2 on my computer. Everything is all screwed up now. Linux worked just fine. I have two hard drives. One 4 gig (master) and the other 1.5 gig (slave). They both only have one partition. So when I installed linux I opted to install it on /hdb, think that is the second drive, after all it was 1.5 gigs big. I tried to change my resolution and Linux crashed and the problems started.

/dev/hda1 (thats my C: drive right) would not mount. It said this while linux was loading:
"Wrong fs type, bad option, bad superblock on dev/hda1"

So I tried to use lilo to go back into windows and it said that it could understand the filesystem. Next I booted from a floppy into dos. The c drive is there and so are many of the files. I try to run windows and it says that it can't find the registry and everything freezes.

So, the questions are; can I save my data in windows? can i ever get back into windows? what happened?

Thank you so much for your help. If you cannot help, please at least direct me to the best linux forum discussion you know of.

Thanks again.
January 18, 2001 6:12:42 AM

Is it possible that Linux just doesn't understand FAT32. I never saw that anywhere in the installation. Anyways. I want to remove Lilo to see if windows would boot without it but then I could be stuck, not being able to get into either OS. Man would that suck.
Anonymous
January 18, 2001 9:46:31 AM

Sorry Pal,

but Linux has it's own filesystem.
Called something like "lfs".

Grtz,

Leywalker
Related resources
January 18, 2001 3:01:25 PM

I'm not that stupid (thats arguable). I know linux has their own file system but how can lilo work unless it can understancd some type of FAT partition.
January 18, 2001 3:32:49 PM

Boot into DOS and rebuild your master boot record by typing 'fdisk /mbr'. That will get rid of all the LILO references in the MBR and should allow you to boot into Windows again. Linux shouldn't have changed your Windows registry at all, the error is probably in the MBR.
January 18, 2001 3:55:34 PM

Thank you very much. I will try it as soon as I get home around 7pm and post if it works.
January 18, 2001 11:26:51 PM

I did what you said. It didn't work :( .
When i tried to reboot it said "stage 1 readerror". This must mean that it did not clean all of the lilo off, just enough to screw it up. So I have reinstalled linux by booting to the cdrom drive. I still cannot access windows though. Any other thoughts. Please Help. How can I completely get rid of lilo or at least get a new dual boot program that will work in linux. thanks
January 18, 2001 11:44:46 PM

I am going to go try again. I am also going to try and install anther bootloader to see if it works. May take me about 30 minutes to get back if it doesn't work. If anyone could suggest a more active linux forum that would be a big help also. Thanks again
January 19, 2001 2:42:50 AM

What I have like 6 of these post. Sorry. I quit and formatted my hard drive and reinstalled ME. It works now.
Anonymous
January 20, 2001 8:53:37 AM

It looks as though U don't have firm understanding of how lilo works or how exactly partitioning differs from windows. If you want to use lilo to dual boot I would strongly suggest Downloading and reading the README file that comes with it. the homepage is: <A HREF="http://www.ibiblio.org/pub/Linux/system/boot/lilo/lilo-..." target="_new">http://www.ibiblio.org/pub/Linux/system/boot/lilo/lilo-...;/A> It is kind of dry, long reading, but stick with it has good explenations and examples in it.
If you are not afraid of compiling from source, there is an alterative called GRUB that is working pretty well. you may want to check it out <A HREF="http://www.gnu.org/software/grub/" target="_new">here</A>

perhaps the easiest way for you will be to use loadlin. the way it works is you are allready booted into DOS, and then you boot right into linux. there is a mini-howto on the subject that looks good. check it out: <A HREF="http://www.linuxdoc.org/HOWTO/mini/Loadlin+Win95.html" target="_new">http://www.linuxdoc.org/HOWTO/mini/Loadlin+Win95.html&l...;/A>

I'm not sure if winME parses the autoexec.bat on startup. You may have to downgrade to win98SE. winME is a pile of crap anyways.

I have found it to be more helpfull to read howtos and man pages to get the basics. If I can't figure it out from there, I usually jump on IRC. I have yet to find a good forum on the web with real good answers anyways.

Real friendly people can be found around the linux from scratch project. I would suggest at least reading through the book and maybe even giving it a try, as the best way by far to learn is by doing.


~flake


--
U want to really *know* Linux?
<A HREF="http://www.linuxfromscratch.org/" target="_new">http://www.linuxfromscratch.org/&lt;/A>
Anonymous
January 24, 2001 5:05:01 AM

I use Linux Mandrake 7.2 too, but when i installed it uses Grub, not lilo. that was the default, what did you do to change it into lilo? Plus it should have no problem reading FAT, it uses Ext2 for linux, but you can mount and play with FAT32 all you want. I even use samba so that the other win9x computers can connect to the FAT32 drives that are mounted on it.

I have no idea what happened to your computer, i can only assume that something got messed up during your install of mandrake, can you tell us what options you selected?
January 24, 2001 10:44:07 PM

Problems all fixed now. I just did the defaults on everything. Lilo was the default for me( I didn't do anything in my knowledge to change it). The only thing I did different was to install everything on /hdb, my second hard drive. i have absolutely no idea why it even touched anything on my first hard drive and subsequently screwed up my windows partition. Got me, I just ended up formatting everything and for now I only use windows. I want to make a machine that runs Win ME, Win 2000, and Linux, but after this experience I may wait a while.
Anonymous
February 1, 2001 11:39:58 PM

well, it appears that everyone has forgotten the most important factor in this, you most likely reset the machine after it crashed by hitting reset or the power button? you prolly installed with the default ext2 filesystem, witch will die a horrible death if you do that! it does not have recovery options that FAT and other filesystems have. My opinion is that when you had your crash while adjusting your resolution, witch wasn't a system crash, but an Xserver incompatiblity with the settings and your hardware, you hit the reset button instead of just resetting the Xserver(alt-backspace or alt-f#, kill xserver process) and in the process destroyed the ext2fs partitions. This is why it wouldn't boot back into linux. the boot managers, either grub or lilo, will load into the mbr of the primary master harddrive. in this case, it's your windows drive. this is why it affected your windows boot settings. why your MS windows wouldn't boot after an fdisk /mbr is beyond me, but not unusual for MS windows. if you decide to do a triple boot system, install 9x first, nt/2k then linux or use a boot manager app like windows commander.

-The deadest star in the sky!-
!