Sign in with
Sign up | Sign in
Your question

LOST BOOT RECORD!!! PLEASE READ

Last response: in Linux/Free BSD
Share
June 10, 2002 3:21:33 AM

I was running a RAID 0 setup on my Asus A7V133 with two Maxtor 40 gigs running WINXP and I have another 40 gig IBM drive on the IDE bus. I went ahead and installed Redhat Linux 7.3 on the 40 gig IBM in hope of using LILO as the dual boot manager and whenever I boot the menu shows only Linux in the LILO menu.

Now I unplugged the IBM drive so I could just boot off my normal setup with my WINXP on the RAID config but when it goes to boot all it says is 'PRESS A KEY TO REBOOT' I have tried everything to get back into windows but i cant. nothing seems to recognize the drive! I loaded the WINXP disk to use the RESTORE feature but it says that no drives are installed. Now when the computer boots the RAID ARRAY shows up fine and it continues on as usual but instead of going into WINXP it just says "PRESS A KEY TO REBOOT' I have tried fdisk and it doesnt even see the partition. I have over 30 gigs of data on this drive that I need to save. Can someone PLEASE help me out here. I have been trying to fix this allll day and I can't seem to figure it out.

Any help would be appreciated

More about : lost boot record read

June 10, 2002 3:41:21 AM

Have you tried floppy boot for Linux ? If you need a boot disk, let me know. Messed mine up also and use one myself.

Dave
June 10, 2002 3:46:27 AM

Can you clarify which device was set to boot when you installed Linux? Also, did you use grub or LILO for the boot manager?

If it was set to default boot off the RAID, and LILO or grub got installed onto the RAID boot sector, but Linux was on the (non-default) IDE bus, the boot manager will be very confused when you unlpug the IDE drive.

If this was the case, take a look at the previous post and how to add another boot entry into the list. You might need to substitute sda for hdx as the windows boot device, because the BIOS thinks it's got a SCSI card attached.

I think your best bet would be to plug the 40GB back in, get Linux boot manager to see the drive, then boot to Windows and replace the boot sector.

<i>Giggling nervously in the face of oncoming traffic -- PB</i>
Related resources
June 10, 2002 5:47:59 AM

Poorboy it sounds like you know what ur doing. The RAID drive was default and I think the 40 gig was non-default... and I am using LILO and when i put both drives in only linux is seen in the LILO window. So with this info can you proceed to tell me how I get my drive back?

I really appreciate this!
June 10, 2002 6:18:52 AM

I was going to suggest setting up LILO to know about Windows, but to do that, you need to get the RAID drivers for your motherboard and things start getting more complicated... If you want to use both OS, you probably need to go this route.

An easier option might be to simply remove LILO, using:
lilo -u /dev/hda

Before doing that, can you post your /etc/lilo.conf file so I can be sure of what's set up already?

<i>Poking the Grim Reaper with a stick and then running away -- PB</i>
June 10, 2002 6:16:54 PM

How do i post my /etc/lolo.conf file? If I removed LILO how do I get into linux? does it boot directly to that. If so how do I go about getting my WINXP back?
June 11, 2002 8:07:46 AM

Open it in gedit or similar (any gui text editor should be ok) , then copy and paste the text into your browser. If none of that works, just tell me what the line that starts with "boot=" says. (and a root= line if it has one)

If LILO is removed, you don't get into Linux, just Windows. I'm thinking it's going to be easier to add a Linux entry to the Windows Boot Menu than the other way round (mostly because I've not multibooted with RAID before).

Firstly, make a boot floppy with: mkbootdisk
Next, make sure it works! Reboot the machine from the floppy and get back to Linux.
If that's ok, run: lilo -u /dev/hda
Hopefully, that'll restore a backup of the original boot sector, and you should be able to boot Windows. You can still boot Linux from the floppy.

The details of booting Linux fro the NT Loader menu are covered in the mini-howto at www.linuxdoc.org. More info and some useful stuff is at http://ourworld.compuserve.com/homepages/gvollant/bootp...
!