Sign in with
Sign up | Sign in
Your question

USRprbdA.exe - DLL Initialization Failed

Last response: in Windows XP
Share
Anonymous
June 14, 2005 12:33:21 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

OS Windows XP Home Service Pack 2


I have been getting the message "USRprbdA.exe - DLL Initialization
Failed : The application failed to initialize because the window station
is shutting down."

I searched all over the Internet and found many others having the same
problem, but none of the suggested fixes worked for me.

I opened the event viewer and clicked the link "For more information,
see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

The automated help system said "The program could not load a driver
because the program user doesn't have sufficient privileges to access
the driver or because the drive is missing or corrupt."

Searching the US Robotics web site didn't get me anything. So being
hard headed, as I often am, I spent some time to figure out what the
problem was and how to fix it. Here is what I came up with....

In reality the problem is that Windows is running what amounts to a
device driver on a user account, I think this is always a bad idea, but
nobody cares what I think. Because of this I realized the problem would
likely be fixed if I could force the driver to run on the System
account. So if you don't like my specific fix, perhaps you can find a
better way to change the account used by the driver.

1) Open the system registry (yes this is a little risky, be very
careful). Click Start Button> Run> Type "Regedit" click OK.

2) Open the registry key...
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
Of course I have deleted the subkey name and don't remember what it was
called, but you are looking for the key that has a string value of
"C:\WINDOWS\SYSTEM32\USRmlnkA.exe RunServices \Device\3cpipe-USRpdA"

3) Delete this entry.

4) Click Start Button>Run>Type CMD and Click OK.

5) In the command window type "cd \windows" and press enter

6) Type Edit and press enter

7) In the first line of the screen type C:\WINDOWS\SYSTEM32\USRmlnkA.exe
RunServices \Device\3cpipe-USRpdA

8) Press Alt then F then A

9) Type Modem.cmd and press enter.

10) Press Alt then F the X

11) Type Exit and press enter.

12) Click Start Button>All Programs>Accessories>System Tools>Scheduled Tasks

13) Click File>New>Schedule Task

14) Name it Modem Driver or whatever you want

15) Right Click the new task and Left Click Properties

16) Use the Browse Button to point the task at C:\Windows\Modem.cmd

17) In the "Run As" box, Type "System", here is where it may get a
little tricky, don't enter a password, just click OK, then Click Apply,
The user name will disappear, don't worry about it.

18) Click Schedule and select "At System Startup"

19) Click Settings and un-check all the boxes. Basically you do not
want the service to quit running until the PC is shutdown.

When you restart the computer, right click the task bar and left click
Task Manager. Click Processes, make sure "Show processes from all
users" is checked. You should find the following exe files running on
the system account. usrshuta.exe, usrmlnka.exe, usrmlnka.exe. If so
your modem should be working and the error message should go away. If
not, delete the scheduled task, remove you modem using the Device
Manager and let Windows re-install it.

Troy

That's it, re-start your computer.
Anonymous
June 14, 2005 1:44:53 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

See http://castlecops.com/postitle81583-0-0-.html
--
~Robear Dyer (PA Bear)
MS MVP-Windows (IE/OE) & Security

Troy Werner wrote:
> OS Windows XP Home Service Pack 2
>
>
> I have been getting the message "USRprbdA.exe - DLL Initialization
> Failed : The application failed to initialize because the window station
> is shutting down."
>
> I searched all over the Internet and found many others having the same
> problem, but none of the suggested fixes worked for me.
>
> I opened the event viewer and clicked the link "For more information,
> see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."
>
> The automated help system said "The program could not load a driver
> because the program user doesn't have sufficient privileges to access
> the driver or because the drive is missing or corrupt."
>
> Searching the US Robotics web site didn't get me anything. So being
> hard headed, as I often am, I spent some time to figure out what the
> problem was and how to fix it. Here is what I came up with....
>
> In reality the problem is that Windows is running what amounts to a
> device driver on a user account, I think this is always a bad idea, but
> nobody cares what I think. Because of this I realized the problem would
> likely be fixed if I could force the driver to run on the System
> account. So if you don't like my specific fix, perhaps you can find a
> better way to change the account used by the driver.
>
> 1) Open the system registry (yes this is a little risky, be very
> careful). Click Start Button> Run> Type "Regedit" click OK.
>
> 2) Open the registry key...
> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
> Of course I have deleted the subkey name and don't remember what it was
> called, but you are looking for the key that has a string value of
> "C:\WINDOWS\SYSTEM32\USRmlnkA.exe RunServices \Device\3cpipe-USRpdA"
>
> 3) Delete this entry.
>
> 4) Click Start Button>Run>Type CMD and Click OK.
>
> 5) In the command window type "cd \windows" and press enter
>
> 6) Type Edit and press enter
>
> 7) In the first line of the screen type C:\WINDOWS\SYSTEM32\USRmlnkA.exe
> RunServices \Device\3cpipe-USRpdA
>
> 8) Press Alt then F then A
>
> 9) Type Modem.cmd and press enter.
>
> 10) Press Alt then F the X
>
> 11) Type Exit and press enter.
>
> 12) Click Start Button>All Programs>Accessories>System Tools>Scheduled
> Tasks
>
> 13) Click File>New>Schedule Task
>
> 14) Name it Modem Driver or whatever you want
>
> 15) Right Click the new task and Left Click Properties
>
> 16) Use the Browse Button to point the task at C:\Windows\Modem.cmd
>
> 17) In the "Run As" box, Type "System", here is where it may get a
> little tricky, don't enter a password, just click OK, then Click Apply,
> The user name will disappear, don't worry about it.
>
> 18) Click Schedule and select "At System Startup"
>
> 19) Click Settings and un-check all the boxes. Basically you do not
> want the service to quit running until the PC is shutdown.
>
> When you restart the computer, right click the task bar and left click
> Task Manager. Click Processes, make sure "Show processes from all
> users" is checked. You should find the following exe files running on
> the system account. usrshuta.exe, usrmlnka.exe, usrmlnka.exe. If so
> your modem should be working and the error message should go away. If
> not, delete the scheduled task, remove you modem using the Device
> Manager and let Windows re-install it.
>
> Troy
>
> That's it, re-start your computer.
Anonymous
June 14, 2005 1:44:54 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I read through all of this ealier, none of the "fixes" suggested worked.
Thanks for the input.

To clarify, I think most people that have this error will find they are
running some kind of software that expects to "see" the modem even when
no one is log in. For example Fax software or a Dial up Server service.

Thanks again.

Troy


PA Bear wrote:
> See http://castlecops.com/postitle81583-0-0-.html
Related resources
Anonymous
June 14, 2005 11:16:16 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

If you have USR/3Com Modem, you probaly have a problem with the drivers.
Try uninstalling and reinstalling with the latest driver.

regards,
ssg
Troy Werner wrote:

> OS Windows XP Home Service Pack 2
>
>
> I have been getting the message "USRprbdA.exe - DLL Initialization
> Failed : The application failed to initialize because the window station
> is shutting down."
>
> I searched all over the Internet and found many others having the same
> problem, but none of the suggested fixes worked for me.
>
> I opened the event viewer and clicked the link "For more information,
> see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."
>
> The automated help system said "The program could not load a driver
> because the program user doesn't have sufficient privileges to access
> the driver or because the drive is missing or corrupt."
>
> Searching the US Robotics web site didn't get me anything. So being
> hard headed, as I often am, I spent some time to figure out what the
> problem was and how to fix it. Here is what I came up with....
>
> In reality the problem is that Windows is running what amounts to a
> device driver on a user account, I think this is always a bad idea, but
> nobody cares what I think. Because of this I realized the problem would
> likely be fixed if I could force the driver to run on the System
> account. So if you don't like my specific fix, perhaps you can find a
> better way to change the account used by the driver.
>
> 1) Open the system registry (yes this is a little risky, be very
> careful). Click Start Button> Run> Type "Regedit" click OK.
>
> 2) Open the registry key...
> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
> Of course I have deleted the subkey name and don't remember what it was
> called, but you are looking for the key that has a string value of
> "C:\WINDOWS\SYSTEM32\USRmlnkA.exe RunServices \Device\3cpipe-USRpdA"
>
> 3) Delete this entry.
>
> 4) Click Start Button>Run>Type CMD and Click OK.
>
> 5) In the command window type "cd \windows" and press enter
>
> 6) Type Edit and press enter
>
> 7) In the first line of the screen type C:\WINDOWS\SYSTEM32\USRmlnkA.exe
> RunServices \Device\3cpipe-USRpdA
>
> 8) Press Alt then F then A
>
> 9) Type Modem.cmd and press enter.
>
> 10) Press Alt then F the X
>
> 11) Type Exit and press enter.
>
> 12) Click Start Button>All Programs>Accessories>System Tools>Scheduled
> Tasks
>
> 13) Click File>New>Schedule Task
>
> 14) Name it Modem Driver or whatever you want
>
> 15) Right Click the new task and Left Click Properties
>
> 16) Use the Browse Button to point the task at C:\Windows\Modem.cmd
>
> 17) In the "Run As" box, Type "System", here is where it may get a
> little tricky, don't enter a password, just click OK, then Click Apply,
> The user name will disappear, don't worry about it.
>
> 18) Click Schedule and select "At System Startup"
>
> 19) Click Settings and un-check all the boxes. Basically you do not
> want the service to quit running until the PC is shutdown.
>
> When you restart the computer, right click the task bar and left click
> Task Manager. Click Processes, make sure "Show processes from all
> users" is checked. You should find the following exe files running on
> the system account. usrshuta.exe, usrmlnka.exe, usrmlnka.exe. If so
> your modem should be working and the error message should go away. If
> not, delete the scheduled task, remove you modem using the Device
> Manager and let Windows re-install it.
>
> Troy
>
> That's it, re-start your computer.
Anonymous
June 14, 2005 11:16:17 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Tried that,
It worked for about 3 or 4 reboots then back to the same old error
message. Thanks for the input.

Troy

S.Sengupta wrote:
>
> If you have USR/3Com Modem, you probaly have a problem with the drivers.
> Try uninstalling and reinstalling with the latest driver.
>
> regards,
> ssg
> Troy Werner wrote:
>
>> OS Windows XP Home Service Pack 2
>>
>>
>> I have been getting the message "USRprbdA.exe - DLL Initialization
>> Failed : The application failed to initialize because the window
>> station is shutting down."
>>
>> I searched all over the Internet and found many others having the same
>> problem, but none of the suggested fixes worked for me.
>>
>> I opened the event viewer and clicked the link "For more information,
>> see Help and Support Center at
>> http://go.microsoft.com/fwlink/events.asp."
>>
>> The automated help system said "The program could not load a driver
>> because the program user doesn't have sufficient privileges to access
>> the driver or because the drive is missing or corrupt."
>>
>> Searching the US Robotics web site didn't get me anything. So being
>> hard headed, as I often am, I spent some time to figure out what the
>> problem was and how to fix it. Here is what I came up with....
>>
>> In reality the problem is that Windows is running what amounts to a
>> device driver on a user account, I think this is always a bad idea,
>> but nobody cares what I think. Because of this I realized the problem
>> would likely be fixed if I could force the driver to run on the System
>> account. So if you don't like my specific fix, perhaps you can find a
>> better way to change the account used by the driver.
>>
>> 1) Open the system registry (yes this is a little risky, be very
>> careful). Click Start Button> Run> Type "Regedit" click OK.
>>
>> 2) Open the registry key...
>> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
>> Of course I have deleted the subkey name and don't remember what it
>> was called, but you are looking for the key that has a string value of
>> "C:\WINDOWS\SYSTEM32\USRmlnkA.exe RunServices \Device\3cpipe-USRpdA"
>>
>> 3) Delete this entry.
>>
>> 4) Click Start Button>Run>Type CMD and Click OK.
>>
>> 5) In the command window type "cd \windows" and press enter
>>
>> 6) Type Edit and press enter
>>
>> 7) In the first line of the screen type
>> C:\WINDOWS\SYSTEM32\USRmlnkA.exe RunServices \Device\3cpipe-USRpdA
>>
>> 8) Press Alt then F then A
>>
>> 9) Type Modem.cmd and press enter.
>>
>> 10) Press Alt then F the X
>>
>> 11) Type Exit and press enter.
>>
>> 12) Click Start Button>All Programs>Accessories>System Tools>Scheduled
>> Tasks
>>
>> 13) Click File>New>Schedule Task
>>
>> 14) Name it Modem Driver or whatever you want
>>
>> 15) Right Click the new task and Left Click Properties
>>
>> 16) Use the Browse Button to point the task at C:\Windows\Modem.cmd
>>
>> 17) In the "Run As" box, Type "System", here is where it may get a
>> little tricky, don't enter a password, just click OK, then Click
>> Apply, The user name will disappear, don't worry about it.
>>
>> 18) Click Schedule and select "At System Startup"
>>
>> 19) Click Settings and un-check all the boxes. Basically you do not
>> want the service to quit running until the PC is shutdown.
>>
>> When you restart the computer, right click the task bar and left click
>> Task Manager. Click Processes, make sure "Show processes from all
>> users" is checked. You should find the following exe files running on
>> the system account. usrshuta.exe, usrmlnka.exe, usrmlnka.exe. If so
>> your modem should be working and the error message should go away. If
>> not, delete the scheduled task, remove you modem using the Device
>> Manager and let Windows re-install it.
>>
>> Troy
>>
>> That's it, re-start your computer.
Anonymous
June 14, 2005 11:16:51 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

If you have USR/3Com Modem, you probaly have a problem with the drivers.
Try uninstalling and reinstalling with the latest driver.

regards,
ssg MS-MVP
Troy Werner wrote:

> OS Windows XP Home Service Pack 2
>
>
> I have been getting the message "USRprbdA.exe - DLL Initialization
> Failed : The application failed to initialize because the window station
> is shutting down."
>
> I searched all over the Internet and found many others having the same
> problem, but none of the suggested fixes worked for me.
>
> I opened the event viewer and clicked the link "For more information,
> see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."
>
> The automated help system said "The program could not load a driver
> because the program user doesn't have sufficient privileges to access
> the driver or because the drive is missing or corrupt."
>
> Searching the US Robotics web site didn't get me anything. So being
> hard headed, as I often am, I spent some time to figure out what the
> problem was and how to fix it. Here is what I came up with....
>
> In reality the problem is that Windows is running what amounts to a
> device driver on a user account, I think this is always a bad idea, but
> nobody cares what I think. Because of this I realized the problem would
> likely be fixed if I could force the driver to run on the System
> account. So if you don't like my specific fix, perhaps you can find a
> better way to change the account used by the driver.
>
> 1) Open the system registry (yes this is a little risky, be very
> careful). Click Start Button> Run> Type "Regedit" click OK.
>
> 2) Open the registry key...
> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
> Of course I have deleted the subkey name and don't remember what it was
> called, but you are looking for the key that has a string value of
> "C:\WINDOWS\SYSTEM32\USRmlnkA.exe RunServices \Device\3cpipe-USRpdA"
>
> 3) Delete this entry.
>
> 4) Click Start Button>Run>Type CMD and Click OK.
>
> 5) In the command window type "cd \windows" and press enter
>
> 6) Type Edit and press enter
>
> 7) In the first line of the screen type C:\WINDOWS\SYSTEM32\USRmlnkA.exe
> RunServices \Device\3cpipe-USRpdA
>
> 8) Press Alt then F then A
>
> 9) Type Modem.cmd and press enter.
>
> 10) Press Alt then F the X
>
> 11) Type Exit and press enter.
>
> 12) Click Start Button>All Programs>Accessories>System Tools>Scheduled
> Tasks
>
> 13) Click File>New>Schedule Task
>
> 14) Name it Modem Driver or whatever you want
>
> 15) Right Click the new task and Left Click Properties
>
> 16) Use the Browse Button to point the task at C:\Windows\Modem.cmd
>
> 17) In the "Run As" box, Type "System", here is where it may get a
> little tricky, don't enter a password, just click OK, then Click Apply,
> The user name will disappear, don't worry about it.
>
> 18) Click Schedule and select "At System Startup"
>
> 19) Click Settings and un-check all the boxes. Basically you do not
> want the service to quit running until the PC is shutdown.
>
> When you restart the computer, right click the task bar and left click
> Task Manager. Click Processes, make sure "Show processes from all
> users" is checked. You should find the following exe files running on
> the system account. usrshuta.exe, usrmlnka.exe, usrmlnka.exe. If so
> your modem should be working and the error message should go away. If
> not, delete the scheduled task, remove you modem using the Device
> Manager and let Windows re-install it.
>
> Troy
>
> That's it, re-start your computer.
!