Sign in with
Sign up | Sign in
Your question
Solved

Video Playback Lag

Last response: in Windows 7
Share
August 10, 2012 7:42:21 PM

Hi everyone,

it's been some time that I've been experiencing micro-lags during the playback of 720/1080p mkv movies (not all of them)
It can be best noticed in the parts of the movie when there's a lot of movement. If I stop the movie and play this part again, the lag is still there. It's not the file's fault because there are movies that I used to watch without any problems some time ago(the same file)

CPU: i7 920 2.6 @stock speed
GPU: HD6950 @ stock speed
RAM: 4GB DDR3 1333 (It used to be 6GB but one module broke)

K-Lite Mega Codec Pack + MPC

I'd like to know what could be causing this and how could I try to fix this annoying problem.

Thank you in advance,

Siq

More about : video playback lag

August 11, 2012 12:39:09 AM

Do you have a dual monitor set up? I find with my dual monitors I get a similar issue when I'm running two separate full screen applications (eg. a movie and a game).
m
0
l
August 11, 2012 12:53:41 AM

No, I'm using a single 32" 3D TV as monitor, and it also happens while I'm playing only the movie =x
m
0
l
Related resources

Best solution

a b $ Windows 7
August 11, 2012 1:25:34 AM

You should also install VLC (don't setup as default). If the problem still exists then it's a software issue somewhere else.

Most likely issue is the video player or linked decoding software.

*There are TWO main way to decode movies:
1) CPU (software) decoding
2) GPU (hardware) decoding

If the GPU is supported for that codec (i.e. H.264/AVC, MPE2 or VC1) and you also have the DXVA setup in your settings in the video player for hardware decoding it will use your graphics card.

You should try toggling this on and off.

You can tell if it's doing hardware decoding by right-clicking-> "filters" (MPC-HC). It will say "MPC Video decoder" (as opposed to something like "ffdshow video" for software decoding on the CPU.)

**Also, CCC for my last AMD card was enabling Advanced Video decoding (such as flesh tone) that really screwed up my video look (grainy etc). I disabled all the Advanced Video in the Catalyst Control Center.

Software decoding doesn't utilized the Advanced Video features.

SUMMARY:
- try VLC as well
- try toggling hardware acceleration ON and OFF
Share
August 21, 2012 1:45:43 AM

Best answer selected by Siq.
m
0
l
!