Sign in with
Sign up | Sign in
Your question

Major Problem with LG 1720P LCD Monitor

Last response: in Computer Peripherals
Share
December 9, 2005 1:48:23 AM

I have not seen anything like this on the internet, nor anyone with the same problem, BUT I HAVE IT! And I don't know what to do!

I have a LG L1720P 17" LCD monitor and I use an ATI RADEON 9800 Pro graphics card.

Now, the problem is that very often when playing games and even surfing the internet or even on the desktop, in dark areas, for example black, it is not black, is is green. However, it is not like the black has been replaced, you can see the black in between the green, and its like this green "tracking" is.....well I can hardly describe it!

I have installed all of the latest video drivers and monitor drivers too, and nothing changes. Someone told me it was the refresh rate, but after fiddling around with that slightly, I had no change!

I'm stuck! I do not have the slightest clue of how to fix this, or whether I can.

The best way to describe it is with a picture, this is a loading screen from the brand new game: Need For Speed Most Wanted.



This is a zoomed in picture of the opening menu screen in the same game


Notice how this tracking (as I call it) is not stationary, it is all over the image, depending on what the image IS.

Now what is also weird is that when I take a screenshot of the screen, this "tracking" does not appear in the screenshot, I had to physically take a picture with a camera to show the image.

Any suggestions or solutions would be greatly appreciated! Thank you!!
December 10, 2005 3:14:20 AM

I have an LG 1720, never had any problems with it.

actually correct that, just seen that it is actually an L1710B that I have, probably a world of difference between the 2!
December 10, 2005 3:43:07 PM

Does anyone have any clue?
Related resources
January 26, 2009 5:14:18 PM

i see this was way back at the end of 2005. Anyway i have the exact same problem with my 22" LG. its only about a year old, it started malfunctioning shortly after i got it. But the problem is intermittent. It has been working ok for about a week now its gone again.
January 27, 2009 8:34:04 PM

Connection is my first analysis, so check both end of the cable. One of the terminal may be loose.
!