Sign in with
Sign up | Sign in
Your question

Disappearing RAID

Tags:
  • Hard Drives
  • NAS / RAID
  • Storage
Last response: in Storage
Share
February 1, 2004 7:18:10 PM

For the second time my RAID array disappeared. That's right. It vanished into thin air. I was decoding a large file and suddenly my system got unstable and I got a BSOD. I rebooted and suddenly my RAID controller didn't recognize my array. This had happened several months ago. At that time I thought perhaps heat was the problem (these muthas get hot!) so I added a cooler to each HDD, reformatted and reinstalled WinXP. Well, like I stated, months went by and all was well so I didn't put much thought into it.

On this occasion I swapped out my Asus P4C800 Deluxe with an MSI Neo-LSR I had laying around, set up a RAID 0 configuration like I had before and attempted to install WinXP. Here's where it gets weird. I booted from the CD and my array was recognized. I formatted and when it rebooted, I got an invalid boot disk error. I did low level formats and attempted WinXP installation again but the same thing happens. I downloaded a diagnostic utility from Seagate and it doesn't recognize my drives as being from Seagate. Anyway, I disconnected 1 drive, reconfigured the RAID and WinXP loaded up with no problem. I did the same with the other drive and voila! No problems either? WTF?

Essentials:
2 Seagate 73GB 15k RPM Cheetahs
Adaptec 2120S SCSI 320 RAID
MSI Neo-LSR
1GB Kingston HyperX PC4000
P4 2.8

Okay, brain. You don't like me, and I don't like you, but let's get through this thing and then I can continue killing you with beer. -- Homer Simpson.

More about : disappearing raid

February 1, 2004 7:51:48 PM

So, your drives are good. And the motherboard is out of the question since the same thing happened on another mobo, right?
The only thing left then is the PSU, mem, CPU and RAID controller. I doubt that the problem is the PSU, mem or CPU. You could try running some sort of memory test.
I think the problem must be that there is something wrong with your RAID controller or perhaps the HD cables.

<i><b>Engineering is the fine art of making what you want from things you can get</b></i>
February 2, 2004 3:06:51 AM

This disappearing act happened twice on the the P4C800 Deluxe. So I figured I would swap mobos and I'm now using an MSI Neo-LSR. The PSU is a 530W Fortron and the memory is good. The last time it happened I think I had OCZ PC3500 which was also good. Anyhow, believe it or not I moved the Adaptec 2120S down 1 PCI slot to slot 4 and it seems to be okay now. Whodathunkit? Previously I had the cards in the following order:

AGP: Radeon 9700 Pro
PCI 1: Empty
PCI 2: Empty
PCI 3: Adaptec 2120S
PCI 4: Empty
PCI 5: Hercules GTXP

Before I moved the Adaptec 2120S down I tried to delete the 2 arrays I had on there and it froze. I figured what the hell, I'll move it down a slot and see what happens. If anyone has an explanation for this I'd love to hear it.

Okay, brain. You don't like me, and I don't like you, but let's get through this thing and then I can continue killing you with beer. -- Homer Simpson.
Related resources
February 2, 2004 6:02:18 AM

AFAIK, the only thing that changes by using another slot, is the IRQ. But I see no reason why one IRQ should work better or worse than another.

<i><b>Engineering is the fine art of making what you want from things you can get</b></i>
February 2, 2004 5:25:04 PM

I've been told by Promise tech support that sharing IRQ's with a raid card leads to bad things happening. That might be true of other raid cards, I don't know. The IRQ sharing can work in really strange ways that aren't obvious, like some slots are actually IRQ shared with your AGP card, and if a card has two IRQs then it uses the one from its slot and one from a slot next to it.

(Promise tech support has told me lots of other crazy things too, so maybe take that with a grain of salt... like don't use cables longer than 18inch, don't use cable select, don't use two drives on one channel and only one on the other, don't use rounded cables, don't use one channel at ATA100 and the other at ATA133, I half expect them to tell me what color shirt to wear to avoid it conflicting with my Raid card...)

It sounds like I might be having a similar problem with my Promise TX2000. When it reads certain files, the system just hard-locks. Those files are always ones that were transferred to the raid over a network, and when transferring to the card from a network, the system would sometimes crash also. It was also Raid-0. I never solved the problem. The only thing I couldn't explore was a possible incompatibility with my nForce2 mobo, Epox 8RDA+. When plugged into a Gateway2000 motherboard it still hard-locks on those files, but I haven't tested writing to the drive now that it's in a different pc. I'm just tossing that card and getting a different brand.
February 2, 2004 7:18:41 PM

Yeah, I've also heard this crap from Promise before as well. It's bull although I do recall having a Promise TX4 that would only work in PCI slot 4. So let me put it another way, it's Promise's way of telling you their drivers are dodgy and won't work with other hardware.

I currently don't use my Promise cards, my 3 Highpoint cards all share IRQs with other hardware in the same system without any problems.

<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
!