Right click the C: drive in Windows Explorer, do search, d..

Archived from groups: microsoft.public.windowsxp.general (More info?)

First, what does work. When I right click the "Windows" directory in
Windows Explorer and select "search" and do a search for "Hosts", the
search finds the "Hosts" file in the "C:\WINDOWS\system32\drivers\etc"
directory. All well and good because that's what I want and expect.

However, when I right click on the C: drive itself in Windows Explorer
and select "search" and do a search for "Hosts", the search fails to
find the Hosts file in the "...\drivers\etc." directory. It does find
hosts files elsewhere. For example it finds "Hosts.txt" and "Hosts"
files that I placed on my desktop.

When I right click a drive in Windows Explorer and select "search", I
damn well want to search the entire drive. Unfortunately, Windows has
apparently defaulted to some kind of limited search. How do I force
Windows search the entire drive?

Thanks,

David
11 answers Last reply
More about right click drive windows explorer search
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    HOW TO: Search For Hidden Or System Files In Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;302347

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:89q2b1dl5faqfpnr6smtlkcdhf0mcga55u@4ax.com,
    David <nomail@nomail.com> hunted and pecked:
    > First, what does work. When I right click the "Windows" directory in
    > Windows Explorer and select "search" and do a search for "Hosts", the
    > search finds the "Hosts" file in the "C:\WINDOWS\system32\drivers\etc"
    > directory. All well and good because that's what I want and expect.
    >
    > However, when I right click on the C: drive itself in Windows Explorer
    > and select "search" and do a search for "Hosts", the search fails to
    > find the Hosts file in the "...\drivers\etc." directory. It does find
    > hosts files elsewhere. For example it finds "Hosts.txt" and "Hosts"
    > files that I placed on my desktop.
    >
    > When I right click a drive in Windows Explorer and select "search", I
    > damn well want to search the entire drive. Unfortunately, Windows has
    > apparently defaulted to some kind of limited search. How do I force
    > Windows search the entire drive?
    >
    > Thanks,
    >
    > David
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Umm, More Advanced Options, put a check in the desired options.
    David wrote:

    >
    > First, what does work. When I right click the "Windows" directory in
    > Windows Explorer and select "search" and do a search for "Hosts", the
    > search finds the "Hosts" file in the "C:\WINDOWS\system32\drivers\etc"
    > directory. All well and good because that's what I want and expect.
    >
    > However, when I right click on the C: drive itself in Windows Explorer
    > and select "search" and do a search for "Hosts", the search fails to
    > find the Hosts file in the "...\drivers\etc." directory. It does find
    > hosts files elsewhere. For example it finds "Hosts.txt" and "Hosts"
    > files that I placed on my desktop.
    >
    > When I right click a drive in Windows Explorer and select "search", I
    > damn well want to search the entire drive. Unfortunately, Windows has
    > apparently defaulted to some kind of limited search. How do I force
    > Windows search the entire drive?
    >
    > Thanks,
    >
    > David
    >
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    David wrote:
    > First, what does work. When I right click the "Windows"
    > directory in Windows Explorer and select "search" and do a
    > search for "Hosts", the search finds the "Hosts" file in the
    > "C:\WINDOWS\system32\drivers\etc" directory. All well and
    > good because that's what I want and expect.
    >
    > However, when I right click on the C: drive itself in
    > Windows Explorer and select "search" and do a search for
    > "Hosts", the search fails to find the Hosts file in the
    > "...\drivers\etc." directory. It does find hosts files
    > elsewhere. For example it finds "Hosts.txt" and "Hosts"
    > files that I placed on my desktop.
    >
    > When I right click a drive in Windows Explorer and select
    > "search", I damn well want to search the entire drive.
    > Unfortunately, Windows has apparently defaulted to some kind
    > of limited search. How do I force Windows search the entire
    > drive?
    >
    > Thanks,
    >
    > David

    In the left hand column of Search, click on "More Advanced
    Options".
    Make sure there's a check mark next to "Search System Folders".
    The only way I could duplicate your results was to uncheck that
    option.

    Note: It looks like you've already enabled "Search subfolders".
    You might also want to make sure "Search hidden files and
    folders" is enabled.

    Nepatsfan
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Unless Windows folder is not hidden. This is not true in your case.

    Try repairing search assistant.

    Look for Srchasst.inf in C:\Windows\Inf folder, right click and select
    Install.

    --
    Jonybrv


    "David" wrote:

    >
    >
    > First, what does work. When I right click the "Windows" directory in
    > Windows Explorer and select "search" and do a search for "Hosts", the
    > search finds the "Hosts" file in the "C:\WINDOWS\system32\drivers\etc"
    > directory. All well and good because that's what I want and expect.
    >
    > However, when I right click on the C: drive itself in Windows Explorer
    > and select "search" and do a search for "Hosts", the search fails to
    > find the Hosts file in the "...\drivers\etc." directory. It does find
    > hosts files elsewhere. For example it finds "Hosts.txt" and "Hosts"
    > files that I placed on my desktop.
    >
    > When I right click a drive in Windows Explorer and select "search", I
    > damn well want to search the entire drive. Unfortunately, Windows has
    > apparently defaulted to some kind of limited search. How do I force
    > Windows search the entire drive?
    >
    > Thanks,
    >
    > David
    >
    >
    >
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Unless Windows folder is not hidden.

    Look for Srchasst.inf, right click and select Install.
    --
    Jonybrv


    "David" wrote:

    >
    >
    > First, what does work. When I right click the "Windows" directory in
    > Windows Explorer and select "search" and do a search for "Hosts", the
    > search finds the "Hosts" file in the "C:\WINDOWS\system32\drivers\etc"
    > directory. All well and good because that's what I want and expect.
    >
    > However, when I right click on the C: drive itself in Windows Explorer
    > and select "search" and do a search for "Hosts", the search fails to
    > find the Hosts file in the "...\drivers\etc." directory. It does find
    > hosts files elsewhere. For example it finds "Hosts.txt" and "Hosts"
    > files that I placed on my desktop.
    >
    > When I right click a drive in Windows Explorer and select "search", I
    > damn well want to search the entire drive. Unfortunately, Windows has
    > apparently defaulted to some kind of limited search. How do I force
    > Windows search the entire drive?
    >
    > Thanks,
    >
    > David
    >
    >
    >
    >
    >
  6. Archived from groups: microsoft.public.windowsxp.general (More info?)

    "Nepatsfan" <nepatsfan@SBXXXIX.com> wrote:

    >In the left hand column of Search, click on "More Advanced
    >Options".
    >Make sure there's a check mark next to "Search System Folders".
    >The only way I could duplicate your results was to uncheck that
    >option.
    >
    >Note: It looks like you've already enabled "Search subfolders".
    >You might also want to make sure "Search hidden files and
    >folders" is enabled.
    >
    >Nepatsfan

    Thanks. You and the others were right, I didn't have "Search System
    Folders" enabled in the advanced search options. Now another
    complaint. Apparently, "Search" doesn't remember this advanced
    option. Each time I want to search system folders I must first click
    on "Advanced Options". Yes, "Search System Folders" is still checked
    when I click on "Advanced Options", but unless I click "Advanced
    Options", the search skips the system folders. Is there a way to make
    the Search default to "Search System Folders" without me having to
    click on "Advanced Options"?

    Thanks

    David
  7. Archived from groups: microsoft.public.windowsxp.general (More info?)

    David wrote:
    > "Nepatsfan" <nepatsfan@SBXXXIX.com> wrote:
    >
    >> In the left hand column of Search, click on "More Advanced
    >> Options".
    >> Make sure there's a check mark next to "Search System
    >> Folders". The only way I could duplicate your results was
    >> to uncheck that option.
    >>
    >> Note: It looks like you've already enabled "Search
    >> subfolders". You might also want to make sure "Search
    >> hidden files and folders" is enabled.
    >>
    >> Nepatsfan
    >
    > Thanks. You and the others were right, I didn't have
    > "Search System Folders" enabled in the advanced search
    > options. Now another complaint. Apparently, "Search"
    > doesn't remember this advanced option. Each time I want to
    > search system folders I must first click on "Advanced
    > Options". Yes, "Search System Folders" is still checked
    > when I click on "Advanced Options", but unless I click
    > "Advanced Options", the search skips the system folders. Is
    > there a way to make the Search default to "Search System
    > Folders" without me having to click on "Advanced Options"?
    >
    > Thanks
    >
    > David

    Go to Start -> Run and enter regedit in the Open box. Click OK.
    Navigate to the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer

    In the right hand pane, make sure that SearchSystemDirs is set
    to 1.
    If it's 0 then right click on it and select Modify from the
    drop down menu.
    Change the Value data to 1.
    Click OK and close the registry editor.
    Restart the computer.
    Once the computer restarts, check to see if this issue has been
    resolved.

    If this doesn't solve the problem then you may have to
    reinstall the search assistant.
    Open the C:\Windows\Inf folder.
    Locate Srchasst.inf.
    Right click and select install.

    Good luck

    Nepatsfan
  8. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Thanks Nepatsfan (and all),

    The registry entry "SearchSysDir" was already set to DWORD 1 so I made
    no changes in the registry. Instead, I reinstalled search assistant
    as you suggested and rebooted. Unfortunately, this made no difference
    in the search behavior -- I still must click advanced options to
    reveal the already checked options for the search function to actually
    search the system directories. Any more suggestions?

    Thanks,

    David
  9. Archived from groups: microsoft.public.windowsxp.general (More info?)

    David wrote:
    > Thanks Nepatsfan (and all),
    >
    > The registry entry "SearchSysDir" was already set to DWORD 1
    > so I made no changes in the registry. Instead, I
    > reinstalled search assistant as you suggested and rebooted.
    > Unfortunately, this made no difference in the search
    > behavior -- I still must click advanced options to reveal
    > the already checked options for the search function to
    > actually search the system directories. Any more
    > suggestions?
    >
    > Thanks,
    >
    > David

    Here's the only other area of the registry I can think of that
    you might want to check:

    Start the Registry Editor.
    Navigate to this key:
    HKEY_CURRENT_USER\Software\Microsoft\Search Assistant
    In the right hand pane there should be a entry named
    "UseAdvancedSearchAlways" with data of 1.
    If it's not there right click an empty area in the right hand
    pane and select New -> Dword value.
    Enter UseAdvancedSearchAlways as the name.
    Right click and select Modify from the drop down menu.
    Enter 1 where it says Value data.
    Click OK and close the registry editor.

    Here's a workaround you might want to consider:
    Download Agent Ransack from this location:

    http://www.mythicsoft.com/agentransack/Page.aspx?page=download

    It is a freeware search tool that is often recommended in these
    forums as an alternative to the built-in Windows search. It has
    a similar look and feel including the ability to initiate a
    search by right clicking on a folder and selecting Agent
    Ransack from the drop down menu.

    One thing that hasn't been mentioned yet is the possibility
    that this problem is caused by some sort of virus or spyware.
    The reason I pose that idea is that a virus would not want to
    be easily found. It's a long shot but you might want to make
    sure your system is pest free.

    Nepatsfan
  10. Archived from groups: microsoft.public.windowsxp.general (More info?)

    "Nepatsfan" <nepatsfan@SBXXXIX.com> wrote:

    >Here's the only other area of the registry I can think of that
    >you might want to check:
    >
    >Start the Registry Editor.
    >Navigate to this key:
    >HKEY_CURRENT_USER\Software\Microsoft\Search Assistant
    >In the right hand pane there should be a entry named
    >"UseAdvancedSearchAlways" with data of 1.

    It wasn't there so I added it as per your suggestion. Unfortunately,
    no change in behavior. I then remembered about "TweakUI" and ran it
    to see if there was something I might change (or that I might have
    changed in the past). I unchecked "Use classic search", which I had
    indeed checked at some point in the past. That fixed the problem.

    Thank you very much, Nepatsfan, for your tips. I was about to give up
    but your persistence encouraged my persistence.

    Cheers,

    David
  11. Archived from groups: microsoft.public.windowsxp.general (More info?)

    > It wasn't there so I added it as per your suggestion.
    > Unfortunately, no change in behavior. I then remembered
    > about "TweakUI" and ran it to see if there was something I
    > might change (or that I might have changed in the past). I
    > unchecked "Use classic search", which I had indeed checked
    > at some point in the past. That fixed the problem.
    >
    > Thank you very much, Nepatsfan, for your tips. I was about
    > to give up but your persistence encouraged my persistence.
    >
    > Cheers,
    >
    > David

    Glad to see you got if fixed.

    Nepatsfan
Ask a new question

Read More

Windows Explorer Windows XP