Sign in with
Sign up | Sign in
Your question

HDD space recognition problem URGENT!

Last response: in Storage
Share
February 7, 2004 8:24:21 PM

Hey

I've got a maxtor 200GB hdd, unfortunatly windows only recognises it as 127, i've tried everything listed on the microsoft site regarding this, these being

Installing SP1
downloading an update for my atapi drivers
Running a program called Big_drive_enabler
Updating my Bios

The only thing all that fixed is my HDD is now recognised as it's full size by the bios but windows still won't see it. I'm running XP pro, If someone could please help I really need to fix this urgently

Thanx

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
February 7, 2004 10:56:37 PM

I can't be positive cause I don't have similar hardware software but sounds like there is a limit on the
size of a partition too?


Maybe u need two partitons or u may need other partitioning software to make a big partition.

The loving are the daring!<P ID="edit"><FONT SIZE=-1><EM>Edited by Flinx on 02/07/04 07:57 PM.</EM></FONT></P>
February 8, 2004 10:54:06 AM

i've tried looking in the disk manager and it doesn't think there is any extra space for another partition, otherwise that was my plan, create an extra one containing the remaining space...

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
Related resources
February 8, 2004 4:46:13 PM

Can you supply some specs (just in case). What is the motherboard? The BIOS level?

The loving are the daring!
February 8, 2004 7:08:18 PM

Well I do know that XP has problems recognizing drives over 200gb before SP1 is installed. If you're installing XP to this 200gb drive, partition it to have two 100gb drives instead of one 200. If you're just adding it so you can use the space, then it really ought to just work if you have all your windows updates installed and your bios can handle the size of the drive.

One thing that helped me get a drive online once, the drive was broken and I was recovering its heads, but hey this might work anyway:

Right click on 'my computer' and click Manage.
Click on Device Manager on the left
Go to the View menu, and select 'Devices by Connection'
Expand the items on the right to find your IDE controller, on my system this is the sequence:
ACPI PC --> ACPI Compliant System --> PCI Bus --> nVidia NForce IDE Controller

Now you see your IDE channels. Select the one that has the drive attached to it. Hopefully, it is NOT on the same IDE channel as your windows drive is on. If it is, you might want to move it to the other channel before trying this. It does divide the channel properties into Device0 and Device1, so maybe it will be fine, but I don't know for sure.

Right click the channel your drive is on, push Properties, go to the Advanced Settings tab. Change Transfer Mode on the device that matches your hard drive (Device 0 or 1). Doesn't matter if you change it from PIO to DMA or from DMA to PIO, I think it's just this change that makes windows look again for a drive. Push OK.

On my system, windows refused to see my broken drive at first, and then when I did this all of a sudden it was online and accessible through my recovery software.
February 9, 2004 5:38:15 AM

the motherboard is an ASUS A7V
The bios well....can't remember the exact number but I updated it about a couple of weeks ago, so it should be the latest availible

As I said my bios does recognise my HD as it's full size, it's when i get into windows that it's only recognised as the 127 that it always saw it as, I tried making it two partitions when i first installed the HD and windows but I hadn't updated the bios back then and it was seen as a 127 so that was the most space that could be gotten out of it. Now i've got the bios recognising it windows still sees a 127 there :( 

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
February 9, 2004 6:06:11 AM

Thanx for the reply

Nah when i first installed windows i tried two seperate partitions I still could only get a max of 127, this drive is the one being used to boot from too.

I tried what you suggested but to no luck unfortunatly, disk manager still see's it as a 127 with no unpartitioned space availible...

I'm running out of bloody ideas, maybe reinstalling windows again might do the trick... 4th time lucky ey! ^_^

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
February 9, 2004 2:59:52 PM

I'm not familiar with the ASUS 7v, but I had a similar problem recently.

1. The BIOS recognizes a disk > 127. But it may be neccessary to enable something like "support large disk drives". Also the drive type should be LBA *WARNING* changing this may cause the drive to be unreadable!

2. You need to have recent IDE drivers. These are supplied by Microsoft but are often also supplied by the IDE controller manufacturer. If for example your mobo uses the VIA chipset and your drive is connected to an onboard IDE port you need to install a recent version of the VIA Hyperion drivers. In my case this was the problem.

Hope this helps
February 10, 2004 2:41:48 AM

My bios does recognise the disk at it's full capacity it's windows that doesn't recognise it unfortunatly, I have updated the drivers from microsoft unfortunatly that did nothing :( 

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
February 13, 2004 9:05:02 PM

Maybe your partition software is unable to work correctly with drives over 127GB?

One possible fix would be to get a drive controller or Raid card. These tend to be pretty nice in general, because windows will accept up-to-date drivers for the card at install time (can't exactly tell XP to install service pack one during initial setup) and having a controller / raid card makes the card deal with the drive hardware instead of windows and bios, so you circumvent all those potential problem zones.
February 14, 2004 2:41:42 AM

yeah am considering that

just been trying to avoid spending money on the damn thing just to have my hd work properly, you'd think it should straight off, ahh well, not being left with much choice am i

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
February 14, 2004 3:41:18 PM

Your motherboard is probably simply too old. A7V's we're from A LONG time ago. If you bought a separate PCI sata/ide controller card, it would work.

------------
Apples are good.
February 15, 2004 10:08:35 AM

I used to have an A7V. It was a good mobo, apart from being of the doomed and unfortunate Slot-A variety. I'm hoping the family members I gave two of those boards to will upgrade and return them so I can use them for rendering.
February 15, 2004 10:28:09 AM

I thought it wouldn't be a hardware problem because the bios recognises it at it's full capacity

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
February 15, 2004 7:50:51 PM

Somebody said it earlier, but download service pack 1. After that you should be able to resize the partition.
February 16, 2004 10:05:48 AM

have done unfortunatly it did nothing, also dl'd an update to atapi drivers and a thing called Big Disk Enabler from maxtor, all did nothing :( 

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
Douglas Noel Adams 1952-2002
February 16, 2004 12:52:56 PM

I'm curious, what does FDisk report the drive size (primary partition, extended partition and and logical drives) as? If the BIOS recognises the correct size, I would have thought FDisk would too. Would be the first thing I'd check with. Could be that Windows (for some bizarre reason) has created the primary/extended partition maxxed out at 127gb, yet FDisk may see the space.
February 16, 2004 8:13:56 PM

If you initially used Windows to create your partition, before it had SP1 installed, then that disk will need to be reformatted. Other than that, it sounds like you have gremlins in your system.
February 23, 2004 2:05:08 AM

I am assuming you have a socket A A7V. I have one too. The drive(s) on this board are controlled by a Promise ATA-100 chip onboard. This was kind of a RAID-lite set-up. Really buggy with the VIA bridge chips too. The original bios was 1004C, and would NOT work out of the box with the promise controller. You had to load the board and the drivers off of the ATA-66 bus before you switched the drive(s) to the ATA-100 bus. You needed the 1004D bios to accomplish this.
I had enough trouble with this witches brew set-up that I switched back to the ATA-66 bus when I switched to XP Home. I have not had one crash in two years since I did this. If you are having big-disk problems, look for new Promise drivers. There were no drives over 120mb when your board was built. Otherwise, switch everything to the 66 bus and try all the suggestions here. If it works, the Promise is your problem. I'm waiting to upgrade myself until we get some 64 bit software and some decent chipsets to decipher it.

Asus A7V
1.3ghz T-bird
384MB PC-133
IBM Deskstar 30gb-7200
Maxtor 30gb-7200
Sony DRU510a
ATI Radeon 7200-32mb ddr
Creative Labs SB Live-64 w/Cambridge SW
Toshiba Cable modem
Linksys 54G
February 23, 2004 2:14:16 AM

That is not true. I have done it. It just needs to be resized afterwards.
February 25, 2004 3:14:26 PM

check the microsoft knowledge base for articles 305098 and 303013; appearently Windows only supports 48-bits LBA mode when installed on a >137MB drive. Check the regsitry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\parameters for key EnableBigLBA, it should have the value '1'.
!