Sign-in / Sign-up
Your question

Registry hive error???

Tags:
  • Registry
  • Windows
Last response: in Windows 2000/NT
Anonymous
January 18, 2001 2:19:26 PM

Has anybody out there run into this error?

******************************************
Stop (c0000218) Regestry file failure
The regestry cannot load the hive file
SystemRoot\System32\Config\SOFTWARE
or its log or alternate
It is corrupt, absent, or not writable
**************************************

This error occurs just after the Win2K splash screen. The starting up progress bar reaches 100%, and then it goes to the blue screen w/ the registry hive error. The system then reboots itself.

-----------------------
Here's my system setup:
Mainboard: Abit BE6-II
CPU: PII 450
Memory: 128mb Micron PC133 SDRAM
Hard Disk: Seagate ATA - connected to Ultra DMA66 primary controller.
Video Card: Diamond Viper II TNT2
Case/Power Supply: Enlight midtower - 250 Watt power supply

------------------------------------------------------------
The interesting thing about this problem is that it only seems to happen when I leave the system powered down for a while (this last time it was down for about a week). The last time I received this error I just re-installed Win2K, thinking it was a problem w/ the installation. After re-installing Win2K the system worked perfectly, until I left it powered down. Any ideas????

Any and all help is greatly appreciated.
Thanks, Dave

More about : registry hive error

January 20, 2001 7:42:03 PM

I had the same problem, but it was only powered down for a couple of hours. When I restarted I got that error. I tried everything possible to restore the file or even go to a dos prompt. The only solution was to re-image the partition with norton ghost ( god I love that program) and i haven't had a prob with it since. I know this doesn't help, but I just wanted you to know others havhad the same prob. I do suggest low level formating your drive because the only reason I could think of is a bad cluster or something like that. Good Luck, Diemos
February 7, 2001 12:43:07 AM

Also saw others with this prob. like STOP!!!

Maybe! I've had that same problem. And it always happened just when all looked ok and I started putting more critical software on the machine.

*** Bet the hard disk Write cache is enabled!!!!

Hives are really stored segments of registry values and settings saved on disk... The basic problem is that the machine powers down before the disk cache has written all your settings at shutdown. Oops - on next startup you have corrupted settings to load... You can see the problem develope as you add more software to the box and the registry,profiles, and security settings get larger. Wow, mine powers down almost immediately as the Saving your settings msgbox closes - A write cache disk just doesn't have enought time as the settings get larger... Hive files are indeed corupted and don't have valid EOF mark - just dribblings...

I've tried two soultions, and they both work.
1. Turn off(uncheck) "write cache enabled" in system, hardware, device manager, hard disk, properties tab.
That fixed it... the side effect is it slowes the disk preformance down some...
2. Set APM ( automated power management) not to power off off machine. Don't remember exactly what I changed but I kept messing with CMOS and APM setting till the machine didnt power down - just stopped at the old "It is now safe to shut you machine off". Then I turned "write cache enabled" and got my speed back... Have never had the problem again...

Its a noted problem in MSDN online.. and only happens on some machines and some hard drives...

I have the problem on an ABIT BE6-II with the HighPoint UDMA/66 controller and a 20Gig 5200RPM Western Digital. The HPT66 disguises the IDE as a SCSI and shuts down the cashed WD too fast! Oops...

I also have another Win200O box with a WD with Write cache enabled and it's never had the problem...

Have heard Big EIDE Maxtor's with write cached enabled and non-inboard UDMA controllers will do it also...

Go figure, but its a real problem...

And like you I have BE6-II. It runs pretty smooth - but for only about 6-7 months. Then Fried MOBO - total lights out.. have replaced it twice in 15 months... Just happens again!!! PII450's in this board just runs too hot...

How long have you had yours???
How do you keep yours runnung??? OC'ed?
And Whats your health status CPU temp???

Get intouch: Bob - rplewis@mindspring.com
Get in touch