Sign-in / Sign-up
Your question

Laptop does not start without AC adaptor?

Tags:
  • Battery
  • Laptops
Last response: in Laptop General Discussion
March 4, 2008 9:11:29 AM

I have an old Acer travelmate 620 which does not start without the AC adaptor.

If I have the AC adaptor in while I press the start up button it starts normally even if i pull the plug right after I press the start up button.

I thought it was the battery which was old so I got a new battery and the problem remains.

If I have it plugged in to the AC and press the start up button then I can remove the plug right away and the laptop will start normally and last for around 3 hours with the new battery.


NOTE: If I try to start up the laptop only with the battery, it does 4 short beeps which according to the service manual it means "Battery Critical Low" but this is not the case since the new battery lasts for a good 3 hours. Even the old battery last around 40 minutes.

I have tried everything I could find online like remove all removable hardware, memory but no change same problem same conditions.
The only change to the matter happens only when I remove the memory module and the the laptop starts up without the beeping signals but does not boot. It just stays there with black screen, I can hear the fans working but the laptop does nothing more.

Is there a chance that "Battery Critical Low" message refers to the RTC battery?
On the other hand the time always stays on time but I don't know.

Could it be some kind of sensor gone bad and during start up reports that there is no battery charge?


Any ideas, knowledge or info are very welcomed because simply I have no clue anymore.

More about : laptop start adaptor

March 5, 2008 11:46:59 AM

Perhaps something in your laptop is causing it to draw too much power during start up for the battery to cope and that's why it's only working when you've got the AC adaptor connected.
March 6, 2008 12:12:26 AM

I don't know really.

Maybe something draws to much power during boot, but if it did shouldn't the thing that draws to much power get burned or something?
Related resources
March 7, 2008 4:05:54 PM

sounds like a sensor
March 8, 2008 9:35:00 AM

Indeed sound like a sensor. I wish I knew more info to fix it.
March 10, 2008 10:53:53 PM

did you try changing the power management for the laptop? that could help. if not better get it checked.
March 11, 2008 8:29:29 AM

You mean the power profiles?

I don't think that should have anything to do with it but I already tried it anyway just in case but it didn't help.
March 11, 2008 11:18:41 AM

this is just a think, i don't know exactly if it's correct or not, don't bash on me, i'm not really familiar with laptop yet.

Maybe it's the CMOS battery are dead, how old are your laptop ?
Try to go into BIOS and check the power management section (if exists), maybe there's an option for AC only or battery (or similar like that).
March 24, 2008 9:48:43 AM

No, the CMOS battery is the same with the RTS battery and the laptop does not show any signs of dead RTS/CMOS battery.

It should be a hardware problem or bios gone wrong.
April 5, 2008 9:36:41 PM

groo said:
does it recover from sleep or hibernate? if so just set it to go to one of those modes instead of powering down.

you could look for a bad capacitor or burnt conection around the powmanagament area.

you could send it to these guys.
http://cgi.ebay.com/ACER-TRAVELMATE-620-C110-C200-C210-...

or get this:
http://cgi.ebay.com/ACER-TRAVELMATE-620-FACTORY-SERVICE...


Haven't tried sleep and hibernation to be honest, that might be a good idea!

I would love to send it to them, they are quite cheap but I am in Sweden unfortunately and I already have the service manual but it doesn't give any info except the basic. I have to take it apart and hope If I clean the battery connectors to the motherboard it will work.