Sign in with
Sign up | Sign in
Your question

DELL E6410 SATA OPERATION "RAID ON" not working

Tags:
  • Drivers
  • NAS / RAID
  • Dell
  • SATA
  • Windows 7
Last response: in Windows 7
Share
August 14, 2012 4:14:02 PM

Hi All,'

I have DELL E6410 laptop with Windows7.
By default, bias is having setting of SATA OPERATION as "ATA. In case I change the setting from "ATA" to"RAID ON" I am getting some blue screen with error that Windows in not able to boot.

Do i need to install any driver etc to work with "RAID ON" mode?

Thanks in advance.

More about : dell e6410 sata operation raid working

a b \ Driver
a b $ Windows 7
August 14, 2012 4:32:41 PM

What are you trying to accomplish with turning "RAID ON"?
m
0
l
August 14, 2012 4:45:37 PM

You will almost certainly need an AHCI driver installed, and possibly the full Intel Rapid Storage Technology driver/software package, as this is normally what the chipsets use for their software RAID implementation, but I'm not sure how easy that is to do without the hardware being turned on in the first place.

Do you have a good reason for needing AHCI mode (such as wanting to install an SSD)? Otherwise, I'd advise you to leave it well alone. There are performance and power-usage benefits but they're probably not worth the trouble.

(You could try running Startup Repair from your Windows 7 recovery disc - that might be able to add in the necessary driver as Win7 does have an AHCI driver "out of the box".)

Stephen
m
0
l
Related resources
August 14, 2012 5:58:47 PM

YOu will see a performance improvement by enabling the option in bios. Essentially it will use AHCI but you will need to make some tweaks to the OS first.

1. Startup "Regedit
2. Open HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlset / Services
3. Open msahci
4. In the right field left click on "start" and go to Modify
5. In the value Data field enter "0" and click "ok"
6. exit "Regedit"
7. Reboot Rig and enter BIOS (hold "Delete" key while Booting

Make sure you backup your registry.
m
0
l
August 15, 2012 3:25:46 AM

ss202sl said:
What are you trying to accomplish with turning "RAID ON"?


With ATA, I am not able to connect external SATA drive using eSATA port. I am using SATA to eSATA cable for connection.
m
0
l
August 15, 2012 3:33:38 AM

deathengine said:
YOu will see a performance improvement by enabling the option in bios. Essentially it will use AHCI but you will need to make some tweaks to the OS first.

1. Startup "Regedit
2. Open HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlset / Services
3. Open msahci
4. In the right field left click on "start" and go to Modify
5. In the value Data field enter "0" and click "ok"
6. exit "Regedit"
7. Reboot Rig and enter BIOS (hold "Delete" key while Booting

Make sure you backup your registry.


Thanks for your reply. I tried this but still when I change SATA operation mode to RAID on, i am getting same blue screen with some error while booting up Windows7.
m
0
l
November 8, 2012 2:42:10 AM

The reason that you are getting the blue screen is because when you change from ata to raid on or hdcp it changes the windows version that you are using. In order to correct this, you have to reinstall your windows system to correlate with the change. Even though you are changing the system bios to something new, the windows install is still being read as the old ata instead. I personally do not know how you would change this without having to reinstall windows, but this is the issue that is causing the problem. Windows is being read as ata even though you are changing your bios system.
m
0
l
!