Razr Maxx connects to wifi-N, but no internet

My father just upgraded from his droid incredible to the Razr Maxx, but has a very odd issue with his wifi connection.

When he is at home on his wifi network (router: netgear wnr2000v1) his razr maxx will connect to the network, but acts like it has no internet access. I helped him trouble shoot and figured out that when his router is set to 54 mbps (G) he can connect without issue. When the router is set to 145 or 300 mbps (N) the phone acts like it has no internet, despite showing being connected to the network.

What we have tried:
enable ssid broadcast has no effect
changing the channel from auto to a specific one (any) has no effect
enabling/changing security settings has no effect
disabling WMM has no effect
rebooting the router has no effect
the router has up to date firmware
the phone software is up to date (Gingerbread 2.3.6)
static IP assigned through router has no effect

Is this just a router incompatibility, or this there an underlying issue that we haven't addressed, or is the Razr Maxx wifi radio just crap?

He is going to try to connect to his wifi at work tomorrow, so we don't know if it is just his netowrk, or all N networks.

Any thought or help would be appreciated. Thanks.
5 answers Last reply
More about razr maxx connects wifi internet
  1. aebome said:
    My father just upgraded from his droid incredible to the Razr Maxx, but has a very odd issue with his wifi connection.

    When he is at home on his wifi network (router: netgear wnr2000v1) his razr maxx will connect to the network, but acts like it has no internet access. I helped him trouble shoot and figured out that when his router is set to 54 mbps (G) he can connect without issue. When the router is set to 145 or 300 mbps (N) the phone acts like it has no internet, despite showing being connected to the network.

    What we have tried:
    enable ssid broadcast has no effect
    changing the channel from auto to a specific one (any) has no effect
    enabling/changing security settings has no effect
    disabling WMM has no effect
    rebooting the router has no effect
    the router has up to date firmware
    the phone software is up to date (Gingerbread 2.3.6)
    static IP assigned through router has no effect

    Is this just a router incompatibility, or this there an underlying issue that we haven't addressed, or is the Razr Maxx wifi radio just crap?

    He is going to try to connect to his wifi at work tomorrow, so we don't know if it is just his netowrk, or all N networks.

    Any thought or help would be appreciated. Thanks.
  2. I had the same thing happen yesterday...I don't know if this was the cause, but here's what I tried. I went into Settings and scrolled down to Accessibility....I noticed that this was "unchecked".....so, I "checked it, and now it seems to work...I'm going to check at the Verizon Store, because this seems kind of strange as I never did anything to "uncheck" it in the first place.
  3. Interesting, I will pass that along for him to try. Not sure why that would make a difference, but we'll see if it does anything. Thanks for the suggestion.
  4. I know it's been just over 6 months since this post, but I thought I'd chime in I've had the very same (or at least very similar) issue.

    Sharing some links here to show that others have experienced it too:

    http://www.razrforums.com/forum/droid-razr-maxx/914-wifi-slow.html

    http://www.droidforums.net/forum/droid-razr-support/203351-wifi-very-slow.html

    http://www.droid-life.com/2012/12/27/verizon-may-replace-your-droid-razr-if-you-are-experiencing-issues-after-the-jelly-bean-update/

    http://forums.androidcentral.com/droid-razr-maxx/173554-bad-wifi-performance.html

    http://www.razrforums.com/forum/droid-razr-general-discussions/1146-new-razr-not-running-wifi.html

    So definitely not a unique issue. Seems like Verizon and Motorola have been VERY slow to acknowledge and address the issue. Seems like half the people say "I don't have a problem with Wi-Fi", while the other half has a similar issue. Maybe a number of the Razrs just have hardware issues.
  5. aebome said:
    My father just upgraded from his droid incredible to the Razr Maxx, but has a very odd issue with his wifi connection.

    When he is at home on his wifi network (router: netgear wnr2000v1) his razr maxx will connect to the network, but acts like it has no internet access. I helped him trouble shoot and figured out that when his router is set to 54 mbps (G) he can connect without issue. When the router is set to 145 or 300 mbps (N) the phone acts like it has no internet, despite showing being connected to the network.

    What we have tried:
    enable ssid broadcast has no effect
    changing the channel from auto to a specific one (any) has no effect
    enabling/changing security settings has no effect
    disabling WMM has no effect
    rebooting the router has no effect
    the router has up to date firmware
    the phone software is up to date (Gingerbread 2.3.6)
    static IP assigned through router has no effect

    Is this just a router incompatibility, or this there an underlying issue that we haven't addressed, or is the Razr Maxx wifi radio just crap?

    He is going to try to connect to his wifi at work tomorrow, so we don't know if it is just his netowrk, or all N networks.

    Any thought or help would be appreciated. Thanks.


    If you're on the Jelly Bean update, that's the problem. They screwed up the WiFi. Drops all the time for me.
Ask a new question

Read More

Motorola Routers Connection WiFi