Sign in with
Sign up | Sign in
Your question
Closed

Right speaker doesnt work with Windows 7

Last response: in Windows 7
Share
August 15, 2012 12:32:57 AM

I just installed Windows 7 on my home computer. When I plug in my old speakers (Creative Intrigue 2.1s) whatever speaker is plugged into the right jack BARELY gets any sound. I did some research and it seems this is a semi common problem. I tried messing with all the balance levels and hooked up an old set of speakers which work fine. I also tried switching speakers and whichever is in the right audio jack barely works while the other works fine.

The only other thing I was able to find was someone said they got a "new" cord and it fixed their problem. Is there a cord that would work with Windows Vista but wouldnt work with Windows 7?

Its an old Dell Inspiron 530 with stock motherboard etc, etc. Thankyou for all help in advance.
a b $ Windows 7
August 15, 2012 12:34:41 AM

Hi :) 

Its the SPEAKER thats faulty...

Think about it....

OLD set of speakers BOTH work fine....

Creative speakers ONE speaker not working...

I repeat..its got to be the speaker...

All the best Brett :) 
Score
0
August 15, 2012 12:38:13 AM

Brett928S2 said:
Hi :) 

Its the SPEAKER thats faulty...

Think about it....

OLD set of speakers BOTH work fine....

Creative speakers ONE speaker not working...

I repeat..its got to be the speaker...

All the best Brett :) 

I apologize if I didnt make this clear in my first both but BOTH speakers worked great with Windows Vista and both speakers work if theyre plugged into the left speaker jack. It could be the speaker jack that isnt working but I find it hard to believe it became faulty in the few hours I was installing Windows 7 thankyou though
Score
0
Related resources
August 15, 2012 12:39:44 AM

@Brett I think you misunderstood.

@OP, try to install win7 drivers if possible.
Score
0
August 15, 2012 12:43:22 AM

doron said:
@Brett I think you misunderstood.

@OP, try to install win7 drivers if possible.

All drivers are up to date, I did notice NVidia (my graphics card) has audio drivers installed as well, should I try disabling/messing all of them?
Score
0
August 15, 2012 12:44:32 AM

The same thing happened to me with my speakers i switched the 3.5 mm cable and it worked
I got a cheap one from ebay 0.99$
-Adam Ericson
Score
0
August 15, 2012 12:50:15 AM

adamdbz said:
The same thing happened to me with my speakers i switched the 3.5 mm cable and it worked
I got a cheap one from ebay 0.99$
-Adam Ericson

Someone else mentioned this as fixing their problem. Seems like a weird fix but I suppose I will try the same

I downloaded the real tek audio manager because my old computer had it but still having the same issue
Score
0

Best solution

August 15, 2012 12:54:20 AM

good luck
Share
August 15, 2012 1:04:57 AM

Now something different is happening. Still no sound out of my right speaker but when I go to test the right speaker the sound comes out of both the left and right semi equally from what I can tell.
Score
0
August 15, 2012 3:58:55 AM

New speaker wire worked perfectly. Weirdest fix Ive ever seen. Thanks for the help.
Score
0
August 15, 2012 3:59:13 AM

Best answer selected by TheAntiEggroll.
Score
0
!