boot.ini / boot prompt / 2nd install

Archived from groups: microsoft.public.windowsxp.general (More info?)

A customer gave me an xp laptop that was horribly ridden with viruses
spyware etc. Apparently, she had tried to fix it herself with the
restore disk. I see two instances of xp at the boot prompt and one of
the installs ask for activation. She must have chose the "install
windows on the existing installation" option.

I cleaned out the original install, updated it, and it runs fine now. I
figured I would just let the second install sit where it is and edit the
boot.ini to allow just the original instance of the os at the boot
prompt. However, rather than just presenting one option, it presents
"Windows XP" and "windows default" options. Certainly I didn't put
windows default in the ini file. I suspect the windows written mbr is
picking up on the second install.

I have checked control-panel/system and all that, but nothing gets rid
of this windows default option. Any simple suggestions that won't
jeopardize the original os? Thanks.
6 answers Last reply
More about boot boot prompt install
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows
    XP" /fastdetect /NoExecute=OptIn

    Are you saying that there are two systems listed under [operating systems] ?
    The default= line above [operating systems] has to be there.
    --
    Ron Sommer

    "shawn modersohn" <smmodersohn@hotmail.com> wrote in message
    news:u7ce9nIdFHA.3488@tk2msftngp13.phx.gbl...
    >A customer gave me an xp laptop that was horribly ridden with viruses
    >spyware etc. Apparently, she had tried to fix it herself with the restore
    >disk. I see two instances of xp at the boot prompt and one of the installs
    >ask for activation. She must have chose the "install windows on the
    >existing installation" option.
    >
    > I cleaned out the original install, updated it, and it runs fine now. I
    > figured I would just let the second install sit where it is and edit the
    > boot.ini to allow just the original instance of the os at the boot prompt.
    > However, rather than just presenting one option, it presents "Windows XP"
    > and "windows default" options. Certainly I didn't put windows default in
    > the ini file. I suspect the windows written mbr is picking up on the
    > second install.
    >
    > I have checked control-panel/system and all that, but nothing gets rid of
    > this windows default option. Any simple suggestions that won't jeopardize
    > the original os? Thanks.
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    How about setting Default = XP u want 2 boot &
    timeout=0? User will never see the options.

    HTH-Larry

    On Sat, 18 Jun 2005 23:47:20 -0500, shawn modersohn
    <smmodersohn@hotmail.com> wrote:

    |A customer gave me an xp laptop that was horribly ridden with viruses
    |spyware etc. Apparently, she had tried to fix it herself with the
    |restore disk. I see two instances of xp at the boot prompt and one of
    |the installs ask for activation. She must have chose the "install
    |windows on the existing installation" option.
    |
    |I cleaned out the original install, updated it, and it runs fine now. I
    |figured I would just let the second install sit where it is and edit the
    |boot.ini to allow just the original instance of the os at the boot
    |prompt. However, rather than just presenting one option, it presents
    |"Windows XP" and "windows default" options. Certainly I didn't put
    |windows default in the ini file. I suspect the windows written mbr is
    |picking up on the second install.
    |
    |I have checked control-panel/system and all that, but nothing gets rid
    |of this windows default option. Any simple suggestions that won't
    |jeopardize the original os? Thanks.

    Any advise is my attempt to contribute more than I have received but I can only assure you that it works on my PC. GOOD LUCK.
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Check All Boot Paths

    Start | Run | Type: msconfig | OK |
    Boot.ini tab | Check All Boot Paths button |
    A dialog box will open detailing the location of any invalid operating
    system locations | Confirm you want to remove the entry and reboot

    [[Check All Boot Paths - This button will check the boot paths for all
    operating systems listed in the BOOT.INI to ensure they point to a valid
    operating system. ]]

    Msconfig image
    http://www.winnetmag.com/Files/16/20784/msconfig.gif

    If there is only one you will get:
    It appears that all BOOT.INI lines for Microsoft operating systems are OK.

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:u7ce9nIdFHA.3488@tk2msftngp13.phx.gbl,
    shawn modersohn <smmodersohn@hotmail.com> hunted and pecked:
    > A customer gave me an xp laptop that was horribly ridden with viruses
    > spyware etc. Apparently, she had tried to fix it herself with the
    > restore disk. I see two instances of xp at the boot prompt and one of
    > the installs ask for activation. She must have chose the "install
    > windows on the existing installation" option.
    >
    > I cleaned out the original install, updated it, and it runs fine now. I
    > figured I would just let the second install sit where it is and edit the
    > boot.ini to allow just the original instance of the os at the boot
    > prompt. However, rather than just presenting one option, it presents
    > "Windows XP" and "windows default" options. Certainly I didn't put
    > windows default in the ini file. I suspect the windows written mbr is
    > picking up on the second install.
    >
    > I have checked control-panel/system and all that, but nothing gets rid
    > of this windows default option. Any simple suggestions that won't
    > jeopardize the original os? Thanks.
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Thanks for the help. I still don't know where the default windows option
    came from, it was never explicitly in the .ini file. But anyway, I tried the
    0 timeout option. Apparently the order from the system/gui interface does
    not necessarily reflect the order in the .ini file. So, unfortunately the
    descriptions were identical and I selected the default as the unregistered
    OS. After being horrified for a second at the lack of a usable OS, I
    remembered the recovery console and was able to replace the modified
    boot.ini with the original boot.ini that I saved previous to tampering.
    Saving a copy was really fortunate as I learned the recovery console has no
    text editor. At any rate, by not touching the .ini file directly, using the
    system interface, and process of elimination, I got it how I wanted. The
    windows boot process is a strange beast. Thanks again for all the help in
    here.

    "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    news:uiTMK6OdFHA.3492@TK2MSFTNGP14.phx.gbl...
    > Check All Boot Paths
    >
    > Start | Run | Type: msconfig | OK |
    > Boot.ini tab | Check All Boot Paths button |
    > A dialog box will open detailing the location of any invalid operating
    > system locations | Confirm you want to remove the entry and reboot
    >
    > [[Check All Boot Paths - This button will check the boot paths for all
    > operating systems listed in the BOOT.INI to ensure they point to a valid
    > operating system. ]]
    >
    > Msconfig image
    > http://www.winnetmag.com/Files/16/20784/msconfig.gif
    >
    > If there is only one you will get:
    > It appears that all BOOT.INI lines for Microsoft operating systems are OK.
    >
    > --
    > Hope this helps. Let us know.
    >
    > Wes
    > MS-MVP Windows Shell/User
    >
    > In news:u7ce9nIdFHA.3488@tk2msftngp13.phx.gbl,
    > shawn modersohn <smmodersohn@hotmail.com> hunted and pecked:
    >> A customer gave me an xp laptop that was horribly ridden with viruses
    >> spyware etc. Apparently, she had tried to fix it herself with the
    >> restore disk. I see two instances of xp at the boot prompt and one of
    >> the installs ask for activation. She must have chose the "install
    >> windows on the existing installation" option.
    >>
    >> I cleaned out the original install, updated it, and it runs fine now. I
    >> figured I would just let the second install sit where it is and edit the
    >> boot.ini to allow just the original instance of the os at the boot
    >> prompt. However, rather than just presenting one option, it presents
    >> "Windows XP" and "windows default" options. Certainly I didn't put
    >> windows default in the ini file. I suspect the windows written mbr is
    >> picking up on the second install.
    >>
    >> I have checked control-panel/system and all that, but nothing gets rid
    >> of this windows default option. Any simple suggestions that won't
    >> jeopardize the original os? Thanks.
  5. Archived from groups: microsoft.public.windowsxp.general (More info?)

    "shawn modersohn" <smmodersohn@hotmail.com> wrote in message
    news:u7ce9nIdFHA.3488@tk2msftngp13.phx.gbl...
    > A customer gave me an xp laptop that was horribly ridden with viruses
    > spyware etc. Apparently, she had tried to fix it herself with the
    > restore disk. I see two instances of xp at the boot prompt and one of
    > the installs ask for activation. She must have chose the "install
    > windows on the existing installation" option.
    >
    > I cleaned out the original install, updated it, and it runs fine now. I
    > figured I would just let the second install sit where it is and edit the
    > boot.ini to allow just the original instance of the os at the boot
    > prompt. However, rather than just presenting one option, it presents
    > "Windows XP" and "windows default" options. Certainly I didn't put
    > windows default in the ini file. I suspect the windows written mbr is
    > picking up on the second install.
    >
    > I have checked control-panel/system and all that, but nothing gets rid
    > of this windows default option. Any simple suggestions that won't
    > jeopardize the original os? Thanks.

    Let's have a look at your boot.ini!
  6. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Hello Shawn,
    Usually you will only see Default listed when the entries in the boot.ini
    for default do not match the entry below that section so in essence there
    isn't a match for the default entry in the boot.ini. The System will still
    boot if one of the other sections are correct or if Windows is installed to
    the first driver first partition to the default \windows folder.
    Thanks,
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    --------------------
    <From: "Shawn Modersohn" <smmodersohn@hotmail.com>
    <References: <u7ce9nIdFHA.3488@tk2msftngp13.phx.gbl>
    <uiTMK6OdFHA.3492@TK2MSFTNGP14.phx.gbl>
    <Subject: Re: boot.ini / boot prompt / 2nd install
    <Date: Sun, 19 Jun 2005 13:10:42 -0500
    <Lines: 60
    <X-Priority: 3
    <X-MSMail-Priority: Normal
    <X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    <X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    <X-RFC2646: Format=Flowed; Original
    <Message-ID: <#S5oxoPdFHA.2664@TK2MSFTNGP15.phx.gbl>
    <Newsgroups: microsoft.public.windowsxp.general
    <NNTP-Posting-Host: 144.89.97.217
    <Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP15.phx.gbl
    <Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windowsxp.general:410236
    <X-Tomcat-NG: microsoft.public.windowsxp.general
    <
    <Thanks for the help. I still don't know where the default windows option
    <came from, it was never explicitly in the .ini file. But anyway, I tried
    the
    <0 timeout option. Apparently the order from the system/gui interface does
    <not necessarily reflect the order in the .ini file. So, unfortunately the
    <descriptions were identical and I selected the default as the unregistered
    <OS. After being horrified for a second at the lack of a usable OS, I
    <remembered the recovery console and was able to replace the modified
    <boot.ini with the original boot.ini that I saved previous to tampering.
    <Saving a copy was really fortunate as I learned the recovery console has
    no
    <text editor. At any rate, by not touching the .ini file directly, using
    the
    <system interface, and process of elimination, I got it how I wanted. The
    <windows boot process is a strange beast. Thanks again for all the help in
    <here.
    <
    <"Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    <news:uiTMK6OdFHA.3492@TK2MSFTNGP14.phx.gbl...
    <> Check All Boot Paths
    <>
    <> Start | Run | Type: msconfig | OK |
    <> Boot.ini tab | Check All Boot Paths button |
    <> A dialog box will open detailing the location of any invalid operating
    <> system locations | Confirm you want to remove the entry and reboot
    <>
    <> [[Check All Boot Paths - This button will check the boot paths for all
    <> operating systems listed in the BOOT.INI to ensure they point to a valid
    <> operating system. ]]
    <>
    <> Msconfig image
    <> http://www.winnetmag.com/Files/16/20784/msconfig.gif
    <>
    <> If there is only one you will get:
    <> It appears that all BOOT.INI lines for Microsoft operating systems are
    OK.
    <>
    <> --
    <> Hope this helps. Let us know.
    <>
    <> Wes
    <> MS-MVP Windows Shell/User
    <>
    <> In news:u7ce9nIdFHA.3488@tk2msftngp13.phx.gbl,
    <> shawn modersohn <smmodersohn@hotmail.com> hunted and pecked:
    <>> A customer gave me an xp laptop that was horribly ridden with viruses
    <>> spyware etc. Apparently, she had tried to fix it herself with the
    <>> restore disk. I see two instances of xp at the boot prompt and one of
    <>> the installs ask for activation. She must have chose the "install
    <>> windows on the existing installation" option.
    <>>
    <>> I cleaned out the original install, updated it, and it runs fine now. I
    <>> figured I would just let the second install sit where it is and edit the
    <>> boot.ini to allow just the original instance of the os at the boot
    <>> prompt. However, rather than just presenting one option, it presents
    <>> "Windows XP" and "windows default" options. Certainly I didn't put
    <>> windows default in the ini file. I suspect the windows written mbr is
    <>> picking up on the second install.
    <>>
    <>> I have checked control-panel/system and all that, but nothing gets rid
    <>> of this windows default option. Any simple suggestions that won't
    <>> jeopardize the original os? Thanks.
    <
    <
    <
Ask a new question

Read More

Boot Windows XP