Sign in with
Sign up | Sign in
Your question

help!

Last response: in Laptop General Discussion
Share
July 14, 2008 3:10:38 AM

Hi,

I own a Toshiba Satellite a105-S4051 and due to a terrible virus, I recently had to restore the computer to factory default. Well, I followed the instructions - in fact I have done the same thing several time. Toshiba Support has been no help whatsoever, they tell me something different each time.

My problem is under the device manager, the items listed as "Other Devices" have a (!) at their side. They include the following: Ethernet Controller, Mass Storage Controller, Network Controller, SMBus Controller, Video Controller, Videao Controller (VGA). I downloaded several drivers from the Toshiba website, and they fixed the Ethernet as well as the Video Controllers. However, the others still remain and it prevents me from accessing the internet.

These all worked before the system reset, even with the virus. Please help! It would be much appreciated.

More about : question

July 14, 2008 3:19:05 AM

Have you tried right clicking on those and un-installing them. Then after reboot the OS should find the hardware and re-install it.
July 14, 2008 3:23:34 AM

I will try that, thank you. The one thing I must mention is that at startup, my computer will bring up the 'found new hardware' wizard, and list all those things, but whenever I try to install them it won't.
Related resources
July 14, 2008 3:38:02 AM

Unfortunately, that didn't work. After rebooting, my computer did the same 'found new hardware' but never could install them. It asked me to connect to the internet to find what I needed, but because I don't have a network controller, I can't.
July 14, 2008 4:31:06 AM

try chipset drivers. you should be able to find them on the manufacturer website for your model.
July 14, 2008 9:56:33 PM

Well, I went to toshiba's website and they did not have any compatible chipset drivers for my computer. I know for certain that I probably need an ATI chipset, but which one I don't know.

After installing a few things, now all that needs to be done is Network Controller and Mass Storage Device... What drivers are needed for these?
July 14, 2008 10:52:43 PM

Sorry that you're still having trouble with your Toshiba Satellite a105-S4051. There is a forum that Toshiba is sponsoring called Answers from Laptop Experts, you might consider checking that out at laptopexperts.federatedmedia.net. It's serving as an extension of their customer support.
I hope this helps!
July 15, 2008 12:08:08 AM
July 15, 2008 2:09:45 AM

I currently have the Intel Chipset software, it solved all problems other then the Network Controller and Mass Storage Controller, but when I load my computer, it seems to want to load something ATI. It says something about the ATI Control Panel not being able to load... I just net help now with finding the correct hardware for the Mass Storage Controller and Network Controller as thanks to you all, I have gotten the rest fixed....

& Thanks CaroonM80, I posted there... Hopefully they can come up with something :]
!