Closed Solved

"You require permission from ***** to make changes to this folder"

I recently brought back an old image of my machine to a folder on the desktop. I had to rebuild the hard drive and wanted to salvage some files from the backup image. Anyway, I'm done with the major moving and have transferred a copy to an external drive to pick through later, but now when I try to delete some of the folders I get the error:

You need permission to perform this action.
You require permission from [old computer name and username] to make changes to this folder.

Consequently, there are a bunch of folders I cannot delete. I attempted deleting them from a command prompt but it was only able to delete the files that don't receive this error. So is there a way to get rid of these, or will I need to download some sort of file shredder? If so, which one is the recommended one these days?

Thanks!
9 answers Last reply Best Answer
More about require permission make folder
  1. Make sure you are logged in with an adminisrator account. Right click on the folder or file an goto properties/security. Set write access for your user account there.
  2. No go. Still getting the same error. (full permissions granted to my account)
  3. Best answer
    you ned to take ownership of them... if it still wont allow you to change them after that then you need to create the named account and grant full privs to it.
    http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/ use this to create a right click shortcut and it should make things easier. install it and then reboot. the option should then appear in the right click menu.
    http://www.blogsdna.com/2159/how-to-take-ownership-grant-permissions-to-access-files-folder-in-windows-7.htm or do it manually for each instance.
  4. Well, I kept the same name and user name of the old computer (exactly, capitals and everything). I checked ownership, have tried changing permissions, inherited permissions, etc, and nothing will allow me to delete even one folder.

    EDIT: Correction. Just after posting this message, it occurred to me to go down a few more folder levels and try a root file. There I found an "Everyone" group under Security. I could add full control to that and delete the file, then the folders came with it. However, it's not working on the next folder set.
  5. Had to step away for a while, but just tried the registry hack in your first link. It did the charm! Thanks!
  6. Best answer selected by Dresgeve.
  7. HEXiT said:
    you ned to take ownership of them... if it still wont allow you to change them after that then you need to create the named account and grant full privs to it.
    http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/ use this to create a right click shortcut and it should make things easier. install it and then reboot. the option should then appear in the right click menu.
    http://www.blogsdna.com/2159/how-to-take-ownership-grant-permissions-to-access-files-folder-in-windows-7.htm or do it manually for each instance.

    EPIC THANK YOU
  8. np. its what i do...
  9. Thanks HEXiT...Finally I am over this crap!! ;)
Ask a new question

Read More

Windows 7