Sign in with
Sign up | Sign in
Your question
Closed

Can't boost microphone Steelseries Siberia v2 (non usb)

Last response: in Windows 7
Share
August 19, 2012 9:00:25 PM

I recently reformatted, but before I did there was an option in my control panel > sound > microphone for a microphone boost. Now there that option is gone. My microphone is at 100% but people still cannot hear me very well. How can I boost my mic

Running windows 7. I looked for siberia drivers but I don't believe they have any for the non-usb, and i dont recall it coming with any.

A 3rd party program that boosts microphones would be an acceptable solution as well.

Thanks for any help! :hello: 
August 20, 2012 12:45:03 AM

help me folks!
Score
0

Best solution

August 20, 2012 4:36:47 PM

clik said:
I recently reformatted, but before I did there was an option in my control panel > sound > microphone for a microphone boost. Now there that option is gone. My microphone is at 100% but people still cannot hear me very well. How can I boost my mic

Running windows 7. I looked for siberia drivers but I don't believe they have any for the non-usb, and i dont recall it coming with any.

A 3rd party program that boosts microphones would be an acceptable solution as well.

Thanks for any help! :hello: 


Hey Clik,

I'd recommend updating your Motherboard chipset drivers & audio drivers. To do that, just visit your motherboard manufacturer's website and find your motherboard or OEM PC model (if you have an OEM computer such as DELL, HP - go to their site).

There should be downloads available - get the Chipset drivers and audio drivers.

Also, make sure you do all of your Windows updates as that may have the specific driver update you need.

Regards,
Mike S
SteelSeries Support
Share
Related resources
August 20, 2012 8:02:28 PM

Best answer selected by clik.
Score
0
August 20, 2012 8:04:09 PM

That did the trick! Thanks for the help mike.
Score
0
a b \ Driver
a c 395 $ Windows 7
August 20, 2012 8:05:01 PM

This topic has been closed by Area51reopened
Score
0
!