Sign in with
Sign up | Sign in
Your question

Win2K Server Won't Boot Without Setup CD!

Last response: in Windows 2000/NT
Share
June 23, 2002 5:37:06 PM

Hello all! I have a weird problem here. I have a moderate machine serving a small office space that is running Win2K Server. However, shortly after installing it and configuring for the network, somethign peculiar started happening. The system will no longer boot into Win2K without the bootable setup CD inserted. If you try to boot straight off the hard disk, it says that NTLDR can't be started. If you put the setup CD in and wait for the "PRess any key to boot from CD..." message to go by, it switches to the hard disk and loads fine. I have done tons of research on this and have tried running a Repair on the installation and can't seem to solve this. NTLDR and NTDETECT.COM are present in the root folder of the hard disk. My client will not accept it being left this way and I will be forced to reload and reconfigure the whole thing again from scratch if this can't be solved which of course I really don't want to do. Does anyone know how this problem can be corrected without blowing away the drive? Thanks all!

Parallax Abstraction,
Owner of Quarter Mile Solutions, Inc.
Ottawa, Ontario, Canada
June 23, 2002 8:42:31 PM

sounds like your server install is not set as a primary boot. check your bios, make sure it detects your drive which has the os installed on. make sure the drive is set as master if you are running more than one drive on same ide channel.

<P ID="edit"><FONT SIZE=-1><EM>Edited by lordicon72 on 06/23/02 08:46 PM.</EM></FONT></P>
June 24, 2002 6:46:59 AM

One thing to add to lordicon72's idea...

Sounds to me like the boot.ini file has an incorrect reference to the partition where the Windows installation is. If the installation is on the primary IDE channel as a Master, then boot.ini should have a line (or two) referencing:

multi(0)disk(0)rdisk(0)partition(1)\WINNT

...or something similar. Try editing it.

Oh, I just found the Knowledge Base page about boot.ini:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q99743

Read up on it, and maybe you can figure out what's wrong.
Related resources
June 24, 2002 4:01:46 PM

yes, good point mark
June 24, 2002 10:21:15 PM

That's actually not a bad idea, but the BOOT.INI file is setup the way you mentioned. The thing that's weird is that the error I'm getting is showing that NTLDR is not available which indicates to me that it's not even getting to the point of reading BOOT.INI. I'm assuming that the setup CD has NTLDR on it which is why it doesn't complain when the CD is in. Like I said, weird. :)  Any other potentials?

Parallax Abstraction,
Owner of Quarter Mile Solutions, Inc.
Ottawa, Ontario, Canada
June 24, 2002 11:17:32 PM

In that case it sounds to me like there's something wrong with the MBR. Did you install any other operating systems after Win2k? Installing Linux or Win9x afterwards might cause this.

Did you run the Repair tool from the Win2k Boot disks/CD? I believe it should repair any problems with the boot sector, but I'm not 100% sure.
June 27, 2002 9:33:13 PM

The same problem has happened to me running W2K Pro. I have to use the CD and wait also. This first began after installing System Recovery (shareware) because I was too cheap to by something of reputable origin. It booted into a Linux bootloader and began reading the sector by sector of my system/boot partition, reporting a time of 18 hours would be required to complete an image of this partition. Not wanting to wait that long I gave the 3 finger salute and BANG. I have tried all the suggestions offered by the others who have replied to this post, and yet nothing has worked. If I do find a solution I will be sure to pass along the good news and how-to. Good luck and may the computer gods smile on you. I have chosen for myself to give it some more research and effort, and if a couple of weeks have past with no results simply blow the partition and start over with a clean install. Based on my experience I know what happened to me occurred after the initial install. Try thinking what point in time you began having these problems and maybe you will find the culprit.
June 27, 2002 9:59:00 PM

Hey there! Well, the weird thing is that the problem started happening pretty much right away. I don't really remember doing anything with the machine before this happened other than just the installation. Well, I will most definitely psot the solution as well should I manage to figure it out. Hoepfully one of us will get it because re-installing this server from scratch is really NOT something I want to do. :)  Thanks guy!

Parallax Abstraction,
Owner of Quarter Mile Solutions, Inc.
Ottawa, Ontario, Canada
June 28, 2002 2:47:44 AM

It can't hurt to look at this article, I suppose:

<A HREF="http://support.microsoft.com/default.aspx?scid=kb;en-us;Q228004" target="_new">Changing Active Partition Can Make Your System Unbootable (Q228004)</A>

Toejam31

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
__________________________________________________________

<font color=purple>"Some push the envelope. Some just lick it. And some can't find the flap."</font color=purple>
!