Sign in with
Sign up | Sign in
Your question

SSL Error Windows 7

Last response: in Windows 7
Share
August 24, 2012 12:55:45 AM

I just built a new desktop and installed Windows 7 home premium OEM copy to my ssd and ever since i've been getting SSL Error on my browser for specific sites such as facebook, google, and youtube. I've searched for a solution to this problem for hours and i haven't found a single helpful thing and I'm still not even sure I know what's wrong.

I'm using google chrome but i've tried on IE and Firefox whenever i get the ssl error for a site and it does it for all. the weird thing is, when i get an SSL Error, it will be blocked or deny me for a certain amount of time (it's been anywhere from 5 minutes to 2 hours) and then it will work again.

I'm guessing it has something to do with the windows root certificates or some such and the only fixes i can find are for XP. I've even tried updating my root certs with the XP rootsupd file from windows download center that everyone suggests and that some say works on windows 7 for them. Nothing has worked. It is only localized to my desktop as my laptop and every other device on the network has no issues.

windows is completely updated. i'm out of ideas and im tired of searching only to go in circles and find nothing useful. when it happens again, i'll take a screenshot and post it if that will help.

More about : ssl error windows

a b $ Windows 7
August 24, 2012 8:18:56 AM

This happens when your clock isn't synchronized properly. Check your timezone and/or DST.
m
0
l
Related resources
August 24, 2012 8:39:27 AM

Pinhedd said:
This happens when your clock isn't synchronized properly. Check your timezone and/or DST.


every time i get the ssl error i check and it's always synced.
m
0
l
a b $ Windows 7
August 24, 2012 8:40:52 AM

sirbob77 said:
every time i get the ssl error i check and it's always synced.


It has nothing to do with the root certificates and everything to do with the system time and the network path. If you have an ISP which insists on injecting data into the HTTP response then that will cause an error.

Where do you live and what is your ISP?

EDIT: Is the disk you're using to install Windows one from Microsoft or one from an OEM? I don't mean the license terms but where the physical disk came from.

You can get the official, unbastardized installer here

http://en.community.dell.com/support-forums/software-os...
m
0
l
August 24, 2012 8:45:43 AM

I'm the only computer on a network of 7 that has this issue but i live in arizona (phoenix) and use Cox
m
0
l
a b $ Windows 7
August 24, 2012 8:56:42 AM

What's the exact error message? You can drill down on that in every browser and at least firefox will tell you what the problem with the certificate is (outdated, wrong or no root certificate,...)
m
0
l
a b $ Windows 7
August 24, 2012 8:58:25 AM

sirbob77 said:
I'm the only computer on a network of 7 that has this issue but i live in arizona (phoenix) and use Cox


Check to make sure that your clock has the right year on it. This is particularly common and easy to overlook
m
0
l
August 24, 2012 9:00:14 AM

Pinhedd said:
Check to make sure that your clock has the right year on it. This is particularly common and easy to overlook

the year is correct
m
0
l
August 25, 2012 7:38:01 AM

it's doing it yet again for facebook...why??
m
0
l
a b $ Windows 7
August 25, 2012 7:43:43 AM

sirbob77 said:
it's doing it yet again for facebook...why??


Perhaps it's trying to do you a favor :p 

Try rebooting into the BIOS/EFI setup and check the time there.

This is almost always a time issue

Check to make sure that your timezone is correct, not just the absolute time. If you have the timezone set incorrectly and are compensating via an offset that would cause an issue
m
0
l
August 25, 2012 8:01:00 AM

Pinhedd said:
Perhaps it's trying to do you a favor :p 

Try rebooting into the BIOS/EFI setup and check the time there.

This is almost always a time issue

Check to make sure that your timezone is correct, not just the absolute time. If you have the timezone set incorrectly and are compensating via an offset that would cause an issue


lol. so i rebooted and hopped in bios and saw the time itself is right but didn't see anywhere related to the timezone.
m
0
l
a b $ Windows 7
August 25, 2012 8:17:36 AM

We are still missing the exact error message. The browser tells you, what's wrong with the certificate if you click on the details.
m
0
l
August 25, 2012 8:18:57 AM

noidea_77 said:
We are still missing the exact error message. The browser tells you, what's wrong with the certificate if you click on the details.


i will post that next time it happens
m
0
l
August 26, 2012 1:16:07 PM

noidea_77 said:
We are still missing the exact error message. The browser tells you, what's wrong with the certificate if you click on the details.


I get this first one and then if i click continue i get the 2nd


m
0
l
a b $ Windows 7
August 26, 2012 1:54:35 PM

Details are alway helpful! :)  A quick search broad up this: http://answers.microsoft.com/en-us/ie/forum/ie8-windows...
There are two possible solutions. Either it something in your hosts file or the browser option for mixed content. If neither works for you please com back an tell us.
m
0
l
August 27, 2012 12:51:45 AM

noidea_77 said:
Details are alway helpful! :)  A quick search broad up this: http://answers.microsoft.com/en-us/ie/forum/ie8-windows...
There are two possible solutions. Either it something in your hosts file or the browser option for mixed content. If neither works for you please com back an tell us.


ok, i updated my host file but im not sure i did it correctly so we'll see! im not seeing any mixed content option in chrome but under the HTTPS/SSL there's a check box that i have checked labeled "Check for server certificate revocation".
m
0
l
a b $ Windows 7
August 27, 2012 9:28:17 AM

Yes, the hosts file is a bit strange for windows users like us.
"Check for server certificate revocation": some month ago a virus came with a valid Microsoft certificate. This certificate was then marked as invalid by the issuer, but if the certificate is already installed on your PC, your browser checks that only if this option is set.
m
0
l
November 3, 2012 5:41:32 PM

Thanks for the solution. The time of my PC was set to 2007. I changed the time to 2012 and the actual date and it started to work. Thanks alot :wahoo: 

Regards,
Avinash Bhageloe
m
0
l
!