Sign in with
Sign up | Sign in
Your question

Setting page file drive

Last response: in Windows 2000/NT
Share
June 24, 2002 1:26:22 AM

i partitioned an 80gb drive into 3 partitions. 10gb for apps, 69gb for storage etc and 1gb for a swap file. i keep trying to se the swap file to 1gb on the swap file drive (x) but windows keeps reverting to a 20mb swap file on drive c when i reboot. whats going on? i know ive asked this before but im still having the same problem. very frustrating. it is happening on 3 different machines. i remove the swap on "c", i select the "x" drive, i type the size, hit the "set" button and nothing.

....the birds seemed to be calling him, thought caw....
June 24, 2002 2:35:38 PM

Try typing in zero (0) for the minimum and maximum size for the paging file on the system partition (C:)  and click Set. Then type in the new size of the paging file on the partition created for this purpose, and click Set again.

You might also try creating a paging file that is slightly smaller than the actual size of the partition you've created for his purpose, such as a minimum of 512 or 768 and a maximum of 1024. Be sure that you run a full surface scan of the partition before moving the paging file, in case there is an error in the file system.

Might I ask why you need such a large paging file? Are you low on physical memory? And is the paging file partition on a separate disk, or is this all on just one hard drive? With one drive, you'd be better off leaving the paging file set as default and kept in the system partition, or Windows will be unable to write debugging information to the disk if a STOP error occurs.

And while I'm thinking about it, you might wish to make a Registry change, if your system has at least 128MB of RAM.

Got to Start\Run, and type in REGEDIT.EXE. Browse to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management. Change the DWORD value of DisablePagingExecutive to a hexadecimal value of 1, to disable it. Win2K pages out some of its own kernel code and drivers to the hard drive, and changing this value to 1 will stop the paging. If you have more than 128MB of RAM, you'll probably see a performance boost, as well.

I don't know if this will help, but it's worth a shot.

Toejam31

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
__________________________________________________________

<font color=purple>"Some push the envelope. Some just lick it. And some can't find the flap."</font color=purple>
June 24, 2002 4:59:05 PM

whew.... nice answers toejam. i will try everything when i get home. the swap file is on the same disk.... i just put three partitions... i guess thats not a good idea? i think the problem was that i was just clearing the fields and not typing (0) for my "c" drive. as far as why so big.... i just thought i was supposed to double the size of physical ram.... the system has 512mb.... am i wrong? anyway, excellent info..... thanks very much. i will post again tonight.

....the birds seemed to be calling him, thought caw....
Related resources
June 26, 2002 12:31:17 AM

well, stil wont let me put the swap file on that other partition instead of "c". three systems with the same problem.

....the birds seemed to be calling him, thought caw....
June 26, 2002 1:34:00 AM

This can't possibly be happening on three different systems unless you are doing something wrong ... and I've never seen this happen before. No offense intended, as I'm sure that you know. I just can't picture three systems having the same strange problem for no particular reason. I've never encountered a bug in the OS of this kind, not in a couple of hundred installations.

I could be wrong, but my gut doesn't think so.

If you leave the paging file on the system partion (C:) , clear the check box for System Managed Size, change the size, click Set, and then reboot, does the paging file again return to the 20MB size after Windows reloads?

In your previous attempts, after changing the size and location, has Windows prompted you to reboot?

For 512MB of RAM, the default size for the paging file should be 768MB minimum and 1536MB maximum. That's 1.5 x the size of the physical RAM, and then the upper limit is double the minimum setting.

I wouldn't attempt to move the paging file to another partition until you figure out why you can't change the size of the file in the first place. And with one disk, it's not necessary to isolate the file on a separate partition ... placing it on a partition that is farther away from the top of the disk will only slow down the system when it needs to read/write to the file.

With 512MB of RAM, the file isn't going to accessed frequently, in any case.

One one hand, there isn't really any need to move the file to a separate partition unless you have two hard disks, and are running NTFS. The paging file doesn't tend to get fragmented in FAT32, even if you move it.

On the other hand, I have two paging files. One is 2MB, and is in the system partition. The second is 766MB minimum and 1536MB maximum, and in the first partition at the top of the slaved drive. But this really isn't for performance ... it's to eliminate having the file on the system partition when I make an image of it when backing up the computer. A 768MB paging file adds an entire CD-R to the image (and a little more), which I'd rather avoid. But as for performance, it really doesn't make enough of a difference to matter.

Note. The reason I have a 2MB paging file in the system partition is because this is what Windows requires to boot, without getting error messages ... or refusing to boot at all. If the second hard drive failed, I could still get into Windows and manually change the file size.

Toejam31

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
__________________________________________________________

<font color=purple>"Some push the envelope. Some just lick it. And some can't find the flap."</font color=purple>
June 26, 2002 4:22:13 AM

If you leave the paging file on the system partion (C:) , clear the check box for System Managed Size, change the size, click Set, and then reboot, does the paging file again return to the 20MB size after Windows reloads?


thats exactly what happens. maybe its b/c im doing this on the same disk? i know what you're saying.... its very strange. i guess if there isnt any reason to have a partition set aside, i might as well leave it on "c". for 512mb, shouldnt i set both at ~1gb?

btw, i appreciate your thorough answers.... very helpful.

....the birds seemed to be calling him, thought caw....
!