Sign in with
Sign up | Sign in
Your question

Busted 3 HD out of 4HD 0+1 array. How to fix?

Last response: in Storage
Share
May 13, 2004 8:22:25 PM

Hi,

Somehow my 3 HD simultaneously broke from 4 HD 0+1 array system (both stripe and mirror). I use Abit KR7A-133 motherboard, and it gives me the chance to rebuild mirror array and add/remove spare disks through the bios.

Well, the problem is, since only 1 HD survives, the bios keeps saying that there is not enough device for selection whenever I wanna add spare disk or rebuild mirror array. BTW, these 3 HD actually still work and can be reused. They just happen to brake the array system.

The RAID controller (built-in motherboard) is also in goodshape.

So is there anyway to rebuilt the 0+1 array back, with all the files still intact?

If not, is there any good but affordable software, service, or device out there that retrieve the files from this broken array system? Anyone has experience retrieving RAID datas? Recommendation? Tips?

Thanks

More about : busted 4hd array fix

May 13, 2004 8:47:50 PM

It's not entirely clear what you mean. You mean your RAID array is broken but the hard disks themselves are fine? Does this mean in the RAID software you see one disk in the array and the other 3 disks are no longer part of the array? If this is the case, you can simply delete the entire array and rebuild it using exactly the same disks in the same order with the same stripe size as before. It will say "Warning all data will be lost" but no data is actually lost, just the partition table. Then you can use Active Partition Recovery to scan the rebuilt array, find the deleted partition and restore the partition table.

Alternatively programs like File Scavenger can work separated striped drives to recover file but that's really a last resort.

<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
May 13, 2004 9:55:58 PM

What happened was that I boot up my computer, and when it's doing its routine (memory check, cpu check, device scanning etc.), suddenly the PC just stopped the process and basically says "3 array drives are broken, please go to bios menu." So I went to the bios menu and found out that:

primary disk #1(master): broken (RAID-wise)
primary disk #2(slave): broken (RAID-wise)
secondary disk #1(master): good
secondary disk #2(slave): broken (RAID-wise)

I kept rebooting the system and same result occurs. So that means this problem is definitely "real."

Fortunately, the fact that these 3 HDs are still scannable on the system means that they still work. I've had experience in the past (using non-RAID PCs) when HDs were just undetectable during booting/rebooting because they completely ceased to work.

These are the options on bios menu:

1)Create RAID
2)Delete RAID
3)Rebuild *Mirror* Array
4)Add Spare Disk
5)Remove Spare Disk
6)Set Disk Mode
7)Set Boot Disk

So far I've tried Add Spare Disk and Rebuild Mirror Array options without luck. Each of those 2 options allows the user to select source disk and target disk before confirming the process. But the bios doesn't allow me to choose any device and basically says there's not enough device selection. I did not take the risk of choosing the other options (Create RAID, Delete Raid, Remove Spare Disk etc.) until I know exactly what the results are going to be.

I have yet to format or mess around further, so I know the data is still in the partition. Any suggestion? advices? tips? That would be so helpful.

And how to get to Active Partition Recovery? Is it on Windows 2000?

Thank you
Related resources
May 15, 2004 12:13:12 AM

It sounds like it should be easy to fix. First you get hold of Active Partition Recovery or some other software that will enable you to recover partitions although I don't know any. Then you simply delete the current RAID array, reboot and it should say no array defined. Then you create a new 0+1 array with the drives in the same order as in the old array so the stripe sets remain the same. There is no need to sychronize the drives. Then reboot, it should see a pristine RAID0+1 array but of course it will see it as unformated. Then you run Active Partition Recovery, which scans the array, finds the old partition and rewrites the parition table. Reboot and your array should be as good as new. Don't worry about the messages saying all data will be lost etc. You can't actually loose data from a drive without writing over the old data, and neither changing the array setup or even formating does that.

<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
May 15, 2004 7:28:45 PM

Wow it works!!!

Thank you. You're my life savior :-)

I bought the software, and it's worth every penny. Especially after I found out that it costs approx. 2000 bucks to have it retrieved professionally.
May 16, 2004 12:42:39 AM

Oops,

Eventhough I recovered the data, now the problem is that the RAID refuses to boot up after DMA update (during initial booting process). It just sits there forever, while normally it would go to Windows 2000 booting screen then to desktop screen.

So then I repaired Win2000 using Win2000 installation CD (without losing the datas inside the HD). It says that it copies all the files necessary then tells me to reboot the computer for further installation. So I did exactly what is told.

Well, it still happens. After DMA pooling / update, it just sits there forever again. Then I went back to win2000 installation CD and it says that it already copied the repair datas on the (RAID) HD and it only needs reboot to get the whole installation done.

I kept repeating this for a whole day without any result.

Is there any solution on this problem? I'd like to get the RAID working again. If it's not possible, then at least I'd like to backup all the files to different HD. Is it feasible to do that while the RAID is still in this state?

Thanks
May 17, 2004 2:19:39 AM

How do you know that you have successfully recovered the data? Can you access the array in DOS mode? If you boot from the Win2K disk and go into recovery console can you access the disk? It sounds like a hardware problem not a software error because otherwise it would at least start the boot process. If you can get in with DOS or by booting from another disk then it might be possible to recover the data that way.

<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
May 21, 2004 8:31:37 PM

Hi,

The harddrives definitely work, because when I boot up using Active Partition Recovery, it shows all the existing data.

I just figured out why it refuses to boot up. The MBR is corrupted when the RAID configuration broke, so what I did:

-boot up using win2000 installation CD (plus Highpoint RAID driver)
-chose Repair win2000 (instead of installing a fresh new one)
-chose repair using console (instead of emergency disk)
-type "fixmbr c:" (c: is the RAID)

It fixes the partition and then the RAID boots up normally.

Thanks for your help. I learned a lot with all the feedback :) 
<P ID="edit"><FONT SIZE=-1><EM>Edited by mxflow on 05/21/04 04:34 PM.</EM></FONT></P>
!