Sign in with
Sign up | Sign in
Your question

Toshiba Bios update trashed my laptop

Last response: in Laptops & Notebooks
Share
December 2, 2008 4:36:12 PM

I revieced a laptop from my grandmother she had in a closet for alittle over a year. This thing was still in the box and had not been used due to her lack of computer knowledge and or want to use one. I planned to use the computer for school and went right in to update drivers and what not. I saw a bulliton on toshiba's wesite stating that a bios update was needed, . So I downloaded , this is not my first bios update, I know the drill. After selecting load from windows. the laptop promted to shut down. While shutting dow a screen came up saying that there was an error in the bios update and to restore defualt by clicking F1. I pressed F1 and the computer shut off. Now the computer will not come back up, The monitor, usb and dvd drive get no power. The power botton lights up and the speakers make a poping noise ever second but thats it. I contacted Toshiba support and esculated to a case manager who told me that they can't do anything outside of warranty. This just doesn't seem right, it was thier bios update that was so badly needed to keep the laptop working that cuased a laptop that has less than 2 hours of on time, to no longer work.
December 2, 2008 5:17:01 PM

Which Toshiba did you have? And what did you download, exactly?
a b D Laptop
December 2, 2008 7:46:32 PM

BIOS update utilities these days usually have failsafes in them that prevent users from using incorrect updates on hardware that isn't supported. That BIOS file may have been corrupted (or bogus). Like dwellman said - what did you download? And do you have a copy of the bulletin?
Related resources
June 21, 2009 1:54:26 AM

This just happened to my husband! He's had nothing but troubles with his Toshiba A200 since he purchased it November 2007. He had sent it back while in warranty due to HD failure and still has had nothing but issues. It keeps shutting off on him so he found where a BIOS update may help so he started that and the thing shut off and now has no lights or anything and can't get it to come back on. UGH!!!

TOSHIBA PRODUCES NOTHING BUT PIECES OF *** AND WONT STAND BEHIND THEIR PRODUCTS.

IF THEY GO OUT OF WARRANTY, THE ARE CHARGING $500+ TO TRY AND FIX!!
November 7, 2009 7:16:48 PM

It happened also to me, with my Toshiba's Satellite L355-S7812!
I got a message from toshiba's software management system that several SWs were out of date - including the BIOS.
so I downloaded them FROM TOSHIBA'S WEBSITE and as I tryied to install the BIOS update, it blocked my Laptop completelly! It's dead!!!
I also can't agree that Toshiba is not responsible for that, just because the warranty had expired 2 month before!!!
THEY CAUSED THE PROBLEM!! They shall assume their error with this BIOS update.
I was a real Toshiba-laptop's fan, but after that... I had to replace it urgently and bought a.... HP instead!
Awfull Toshiba's service...
February 15, 2010 6:46:57 PM

It happened to me ! I upgraded the BIOS to my notebook A300 1N0 from 1.6 version to 2.10 , the version reccomended by Toshiba site. I download the correct version of the BIOS from Toshiba, I install it, and now my touchpad isn't working anymore. Toshiba service is worst in the world, nothing compares with HP service. This is my last Toshiba, for sure, I don't reccomend it to anyone. Be smart, by a HP if you buy a notebook.
February 2, 2011 11:59:56 PM

I just had a similar experience with a Toshiba Satellite T135D-S1324 (it is my wife's, and a refurb, so there is no warranty). I installed the BIOS update described here. The computer worked fine for 6 months before updating the BIOS. The update was supposed to respond to an overheating problem. But there was no overheating. Within a few hours - presumably when the newly-installed BIOS detected overheating - the computer stopped working. Since it is out of warranty, Toshiba tells me to take it to Best Buy or some such thing, since it'll be cheaper than getting Toshiba to fix it. Seems to be that there could be a class action suit in there somewhere. Looks like I'm stuck buying a new computer because I installed a "critical" update.
March 19, 2011 8:04:36 AM

My laptop is Toshiba Satellite L40-14B (Catalog Number: PSL4CE-004005G3) SN Y7092933R

I downgraded my Laptop to WinXP (from Vista) and I wanted to update BIOS with Toshiba version for XP (5.50-WIN). I did all right but … even 2 seconds after clicking the .bat file to launch the process, Windows has interfered with a critical message and restart my computer.

It restarted, (***) entered "BIOS ROM Utility V1.16 Crisis Recovery", a progress bar indicated that old bios was erased; after that another progress bar indicating the flash process stopped after 2 seconds (1cm); “flash error” message appeared; the “utility” tried again to erase BIOS (first progress bar again); “erase error” message has appeared. “The POST will continue” or something like that is displayed, and all is blocked and disabled. After a long time of useless praying I removed the battery from my laptop and go ahead again (power on). And everything is happening identical (again and again) from the mark above (***).

It was somewhat strange, especially since, after rebooting I could access BIOS. Without hard disk the laptop shut down in 3 seconds.

I analyzed the content of hard drive and discovered a new file, named T20.BIN (1M - probably with the BIOS image) in C:\.

I think that when laptop is powered on he does not find the BIOS, it search for BIOS image file in the root of active partition on hard drive, load it (T20.BIN), starts "BIOS ROM Utility V1.16 Crisis Recovery" and you know the rest …

After loading the BIOS from the HDD and start rewriting, everything freeze and I can not do anything: "BIOS ROM Utility V1.16 Crisis Recovery" occurs during POST and POST freeze before ending, so I can’t reach the point where I can boot.

Meanwhile I changed the T20.BIN file with the other bios (given by Toshiba Site for Vista) and everything happens the same (with the difference that now the BIOS loaded from hard drive is showing another version number).

I know the some laptops have a service procedure so you can rewrite BIOS after crush. I tried different methods indicated on forums for others L series but nothing works.

Any idea?

****************************
A service engineer suggested me to replace the T20.BIN file on hard drive with a “light” version of BIOS (maybe an older version for this model). It seems to be the last chance of success in order to avoid an external, brutal, risky and very expensive rewrites procedure. The problem is that I can find only the last version of BIOS on Toshiba sites and nobody (a really mean nobody) could give me another version
October 15, 2011 6:43:46 PM

The same thing just happened to me. I have a Toshiba Satellite A665-S6050. The warranty expired a few months ago. I recently noticed that there was a new BIOS update, which I went to install (no problems before the update). It wouldn't install the first couple of times. Had to restart the computer and it then worked. After the install, it kept going to the BIOS menu screen instead of starting up Windows 7. Couldn't figure out what the problem was. Called Toshiba Support. They went through everything I had already done and said to take it to a technician and that they would probably need to reset the BIOS by taking out the BIOS battery. Took it to a tech and it was working normally again (go figure). Brought it back home and it started acting up again. I finally realized that it was my external keyboard being plugged in that was causing the problem. Tried uninstalling the keyboard and reinstalling it, but still having the same problem.

Anyone have any suggestions on how to fix this??
January 23, 2012 11:38:12 PM

listen just thought I would let you guys know when you download your bios updates you might want to connect computer to a hard line so the wifi does not corrupt the file during download
February 1, 2012 3:49:44 AM

I just had the same problem. Computer working great but the Toshiba Advisor kept telling me I had to update the BIOS. Again, not a newbie here....I downloaded their file and tried to install following their instructions to the letter but it failed three times. I decided to just leave the laptop alone until the morning since I was doing this at 4 am. Somehow the power cord was pulled out and the battery died. Now, no matter what I do, I cannot get the screen to come up. I can see the files if I use an easy transfer cord so I called Toshiba Tech who said the Motherboard is dead which seems odd if the USB ports, DVD, and hard drive are all working how would the Motherboard be dead all of a sudden from a failed BIOS update. I cannot get into the BIOS. Any ideas?
!