Sign in with
Sign up | Sign in
Your question

How to Disable Append DNS Suffixes Windows 7?

Last response: in Windows 7
Share
August 27, 2012 8:37:15 PM

Hello,

I have a situation where a remote user was given an imaged laptop. When the laptop was setup in house everything was working fine. They are having issues with it at home though. When I remoted in I noticed the DNS APpend these DNS suffixes was checked and two of our domains are listed. I'm thinking this is the root of the issues but the options are grayed out and I cannot change them. I tried looking through other forum posts that suggest changing settings in gpedit under Computer/Administrative Templates/Network/DNS Client (Allow DNS Suffix APpending to Unqualified Multi-Label Name Queries and Primary DNS Suffix Devolution both to enabled) and then rebooted but there was no change. Is there something else I need to do in order to changes this setting?

Thanks,
a b D Laptop
a b $ Windows 7
August 27, 2012 8:47:10 PM

If an added domain suffix is causing the problem, it might be better to eliminate the root cause and use only full qualified DNS names in all applications & settings.
August 27, 2012 9:15:52 PM

Thanks for the reply but not exactly sure what you mean here. A group policy is in place which pushes those suffixes to all machines. I imaged this laptop inside the domain so it received this group policy. The user is working from home and can get to the internet but I can see issues with the softphone application. When using nslookup it shows one of the internal domains. I was hoping just to be able to change that setting remotely without having to have her bring it back in. Are you saying this is caused by a deeper problem? What steps can I take to fix the current issue?

Thanks,
Related resources
August 28, 2012 12:32:11 AM

Maybe you've already tried this but does the user account have local admin rights?

Scratch that. Does the user have VPN access? You can use something like Hamachi to do a quick VPN and then see if you can update the GPO that way.
a b D Laptop
a b $ Windows 7
August 28, 2012 11:32:48 AM

I dont get your exact problem so far but the appended suffixes are only used for incomplete DNS names. Lets say you are searching for a computer "laptop0001" in your LAN. Then Windows appends the suffix ".company.net" to get a full qualified domain name. That is convenient for the user, but it would be better to use the full name in the first place. It's a common problem with company LANs though. It works in you office, but if you are on the internet it doesn't, because the domain company.net is not reachable over the internet.
a b D Laptop
a c 228 $ Windows 7
August 28, 2012 12:01:46 PM

Did you check the network settings? Possibly switching it from a "work network" to a "home network" will ungray the DNS option. Also, I'm assuming you already switched it to a workgroup computer instead of domain computer.
!