Sign in with
Sign up | Sign in
Your question

Sata Hard Drive issues please help!

Tags:
  • Hard Drives
  • SATA
  • Raptor
  • Storage
Last response: in Storage
Share
June 19, 2004 4:09:27 AM

Just got done building my new system and can not figure out how to make windows recognize my 74 gig raptor. Its installed correctly and when i put in the xp disc it says that it cannot find an ide hard drive (duh) so how do i make it find its sata mate?Thanks in advance.
BTW this is the setup.
Athlon 64 3400+
74 gig Raptor
K8V SE Deluxe Mobo



Propagator

<P ID="edit"><FONT SIZE=-1><EM>Edited by Propagator on 06/19/04 01:21 AM.</EM></FONT></P>

More about : sata hard drive issues

June 19, 2004 7:51:15 AM

First you need to make sure that the SATA controller is enabled and sees the drive, then you'll need a driver floppy for that SATA controller. You'll find the files for the driver floppy on the CD, which means you'll need access to a separate system to copy the files. Then when booting from the CD, you'll see a brief instruction to strike the F6 key to load the driver, do that and put the floppy in.

<font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
<font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
June 19, 2004 9:35:58 AM

Could someone write a sticky explaining how to install SATA drives, because this question is getting asked all the time.

<font color=blue>P4c 2.6@3.25
512Mb PC4000
2x120Gb 7200.7 in RAID0
Waterchill KT12-L30
Abit AI7
Radeon 9800Pro
</font color=blue>
June 19, 2004 4:53:53 PM

Ok i tried that, im just really having issues (grrr). Here is what happens. This is my first SATA system. I have my Raptor connected to SATA 1 on my motherboard. When I start the system I will get an error no hard drive detected, then a blanck screen with a flashing cursor comes up and does nothing. Now if i hook the Raptor up to SATA 1 RAID on my mobo. I still get the error but i am allowed to insert a bootable cd. So then i put in windows xp disc. It will load up and I press F6 to install my floppy drivers that i copied from Asus website. I press S to specify, then install the one option i have for drivers.

Everything goes fine. Then it goes to a screen and asks me if i would like to install windows xp. I press enter to continue and then i get an error that i have no harddrive and my computer will restart in 15 secs. I am so frustrated right now, any help is appreciated! Thanks in advance.

Propagator
June 19, 2004 10:05:49 PM

I think your board has two SATA controllers that use separate drivers, and when you connect the drive to SATA 1 your computer is trying to boot from it first. Intead you should have the CD in the drive when you start the computer, and have the computer set to boot off CD FIRST in BIOS. Try that with the drive on SATA1 and then do the F6 thing if successful to that point.

<font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
<font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
June 21, 2004 3:52:32 AM

Make sure first boot is CDROM drive, Second Boot SCSI, also make sure boot other device is enabled, as Crash already told you have the drivers for the SATA controller on floppy ready to load when XP starts to boot, and that the boot sequence is set for SATA 1&2 or SATA 3&4, which ever one your HDD is hooked to, Make sure if you have a M/B with 2 separate controller chipsets that you're loading the right drivers for the right chipset, usually one controller controls 1&2 and the other 3&4, but your whole problem could be that you don't have boot other device enabled.


Note: Make sure that when you copied the controller files to the floppy disk, you had enabled the (Show All Files) feature in your folder options, because theres hidden necessary files that have to be written to the floppy disk, or it will not work.

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=25..." target="_new">My Rig</A>
June 21, 2004 5:10:46 AM

I downloaded your manual to see what differences your bios had than mine and they were quite different.

In your BIOS setup utility

Under the Advanced Tab
Make sure;
OnChip SATA Boot ROM is (Enabled)
Onboard Promise Controller (Enabled)
Operating Mode (Raid)

Check your M/B manual and if you're only running 1 SATA Hdd, hook to Primary SATA which should be controlled by the Promise drivers, your manual clearly shows you which one it is. Also make sure the jumpers are properly set if your HDD has any to Master, some SATA HDDs don't have jumpers, my Seagate doesn't.


In Your BIOS setup Utility

Under the Boot Tab

Make sure your;

Boot Sector Virus Protection is (Disabled)


Try this and see what happens, I'll be glad to work with you to get this resolved, PM me if you need to. Ryan

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=25..." target="_new">My Rig</A>
!