Sign in with
Sign up | Sign in
Your question

Lenovo T60 not detecting USB joystick

Last response: in Laptops & Notebooks
Share
January 29, 2009 2:37:41 AM

Hi All,

My laptop isn't detecting my USB Joystick (CH Combatstick 568). I went into game controllers and the profile isn't there. I tried to add the profile manually and it gives me an error "Your Gameport or Gameport drivers are not properly configured. Please consult device manager."

Some info to keep in mind:
--The USB ports work (I verified w/mouse, USB drive etc.)
--There is no manufacturers driver for this joystick as it should be supported by Windows.
--The joystick is in perfect working order (it works on my custom build desktop which runs XP Pro)
--I have a 2nd laptop, the exact same model that has Vista Home and it doesn't work on there either.

Specs:
Lenovo T60
8743-CTO
Windows XP Pro

I read on a forum somewhere that sometimes manufacturers disable game controllers if the mobo has integrated audio. Not sure if this has anything to do with my problem.

Anyone got any ideas on what's wrong and/or how I could fix?

Any help greatly appreciated.
January 30, 2009 3:39:26 AM

The version of XP on the desktop and laptop exactly the same in terms of service packs installed?
January 30, 2009 12:29:50 PM

The message you are getting is because you have not configured the controller....

Install the CONTROL MANAGER from the CD that came with the unit or download it from the manufacturer (CH Products). Configure the joystick and then plug it into your usb port.....
Related resources
January 30, 2009 4:45:52 PM

cfvh600, desktop has SP2 and laptop has SP3.

shabaa, I never needed too use control manager on the desktop. I just installed it on the laptop to see of that would work but I still get the same error from game contollers.

From the looks of it, even though it's a USB joystick, it might have to have gameport enabled. I'm reading around on this error, some are saying to enable gameport through device manager or BIOS (under audio devices).

I can't find any audio devices in my BIOS and in Device Manager -> Sound, video & game controllers, I only have the following":
-Audio codecs
-Legacy audio drivers
-Legacy video capture devices
-Media control devices
-SoundMAX Integrated Digital HD Audio
-Video codecs

No where can I see enable gameport....

Anonymous
a b D Laptop
September 30, 2009 9:22:29 PM

Ive got the same problem here. Just wondering if this was ever resolved.



-"As for Apu-D2 I can go either way"
!