Sign in with
Sign up | Sign in
Your question

PSC1400 Installation Problem

Last response: in Computer Peripherals
Share
November 10, 2006 5:00:11 PM

This problem has been driving my sister in Hull mad to the point where I took it home with me and then tried to install it afresh on my PC at home.

My Sisters PC is a custom built XPC with Sempron 3000+, 1GB of RAM and Win XP PRO SP2 and my PC is a custom made one with AXP 3200+ 2GB of RAM and Win XP MCE 2005.

On my sisters PC the printer refused to install once it got to the stage of connecting it up. It got to stage 1/8 and the add new hardware box came up with USB Composite Device - I click next and it sat there for ages eventually reporting a failed installation, be that as it may I continued to install the software. I then tried doing the typical install where things got a little rosier - it decided to present me with the USB composite device and PSC 1400 series add new hardware boxes - clicking next and letting them install solved the problem. I then had an add new hardware box about USB printing support which carried a grey diamond shaped icon. This failed to install saying something about missing something in the INF file or missing the INF file. No matter what I tried, it wouldn't connect or install because of this problem with USB Print Support - what the hell is this about?!?!

Once I arrived from Hull I set up the software on the MCE 2005 PC, only having to take a trip out to the store to get the cable. On my return I was offered updates to take so I took them, restarted the PC after every update installed and once they were all complete I put the CD in and went through the stage of adding a new device - on this PC amazingly it was seamless.

So.....what the hell is the problem with my sisters PC? Is it her copy of XP (which is a 2 month old installation which hasn't been subjected to spyware or crap, it has been starved of an internet connection except for getting Norton AV and Windows Updates lol), Is it her printer cable, or issit some other driver issue? Why can't I install the PSC1400 on the PC and why the hell does it ask for a USB Composite Device or USB Print support yet fail to find it!?! Whereas on my MCE PC after installing the updates and stuff it made the installation seamless!! HP's Technical Support is too baffling to try and make sense of so I'm reaching out for help from fellow PSC 1400 owners!

H E L P!!
November 14, 2006 4:38:43 PM

Your sister may have connected the printer before the software told her to. This can have bad effects with the way HP loads its drivers. Try completely uninstalling the drivers from her computer, then rebooting - then run the install program again, connecting the printer only when the software says to.

It would also be a good idea to go online and install any Windows/driver updates on her machine as you did with yours.

If all else fails, you might try using your new USB cable on her computer, as well as plugging it into a different USB port - your problem sounds more of a driver (not hardware) issue, but it wouldn't hurt to try this.

EDIT: You may also want to disable Norton AV when you install the printer - sometimes AV programs get in the way when installing drivers - just make sure to re-enable it when you go online for updates.
November 14, 2006 9:17:38 PM

I did the whole installation in my usual professional way. I am adamant that I did not connect any of the printers before HP asked me to connect it. Also I tried uninstalling the software and reinstalling but to no avail. Thanks to my sister's campus internet connecting to the internet is pretty complicated - i.e. it requires a username and password to connect to the server. Otherwise i have tried all of your suggestions bar disabling Norton AV - then again Norton AV didn't cause any problems on my home MCE PC and the previous two XP Pro builds that I installed PSCs onto - those installed without a hitch.

The main problem is that it doesn't install because it tries to install "hardware" sometimes called USB Printing Support, USB Composite Device or something to do with USB (its a device with a grey diamond icon) and then it reports back saying that it cannot install hardware because something is missing from the INF. It does this and consequently causes the hardware installation phase to stall at step 7/8 or sometimes 4/8 before finally deciding that after 10 minutes of pissing around the device cannot be detected! So I have no choice but to skip the detection and then move onto installing the software!

Does this sound like my system files have been damaged? If so, can I send a copy of these system files from a Windows XP PC which had EXACTLY the same printer installed on it so that my sister can overwrite her INF file with one that works.
Related resources
December 19, 2006 9:59:34 PM

Problem fixed!! I had to install an HP 1215 using the driver CD that came with the new 1402 printer

Followed the advice from HP, except this time I searched for the USBPRINT.IN_ file from the SP2 disc, copied it to the hard disk and extracted it. First time round it went wrong saying the printer could not be detected. I followed HP's advice at this point, unplugged it and replugged it and after two replugs it came back to that same error message where I directed it to the newly extracted files. The other subsequent hardware entries were then installed one after the other.

PSC 1215 works fine now even under the new software but the fact that such a crucial system file should get left out mistifies me completely.
June 6, 2009 4:15:35 PM

Ilost the CD for HP psc1400
I need to uninstalling the software
!