Sign in with
Sign up | Sign in
Your question

DirectX 8.1 experiences?

Last response: in Windows 2000/NT
Share
June 29, 2002 4:54:04 AM

Need opinions on Directx 8.1 with win2k pro and an athlonXP system.

im using 8.0a, but certain things reccomend an update to 8.1. a good or bad idea to update?

namely, im trying to remove the pops i hear playing mp3's while i use the scroll wheel on my usb mouse

xp1800+
kt333 (epox 8k3a+)
512 DDR
sb live
geforce2pro
intel explorer3 usb optimouse
win2k pro + sp2 + security patch + via4in1's 4.38 + detonators 28.90.


<font color=green>Proud member of THG's</font color=green> <font color=blue>Den Of Thieves</font color=blue> :lol: 

More about : directx experiences

June 29, 2002 5:37:00 AM

Your guestbook entry's funny, man. :smile:

I think you should update to 8.1. Besides, don't you have Drive Image or Norton Ghost to fall back on, just in case?

Where's Toey??? :lol: 

Bryan

<font color=red><Signature></font color=red>
<b><A HREF="http://www.btvillarin.com" target="_new">btvillarin.com</A></b>
My personal website, chock full of tips and other computer stuff. No ads, banners, or catches. It's currently based on Windows XP, but Windows 2000 stuff to come.
<b><A HREF="http://www.btvillarin.com/staff/bryan_villarin.html" target="_new">My System Rig</A></b>
<font color=red></Signature></font color=red>
June 29, 2002 6:04:47 AM

ive got drive image i think. came as part of my mobo package, but ive never been able to get it workin properly.

will a win2k backup suffice?

and come to think of it... how do i actually restore a backup should my computer crash critically?

(backup is on different drive)

<font color=green>Proud member of THG's</font color=green> <font color=blue>Den Of Thieves</font color=blue> :lol: 
Related resources
June 29, 2002 7:54:21 AM

What's kind of Windows 2000 backup? Image or just data backup?

Drive Image can be installed onto two floppy disks, so that you can boot up with them in case you can't get into Windows.

Anyways, when you make an image, you either save it to another hard drive, partition, or CDR/CDRW. Then, if you choke and screw up your system, you boot with the floppies, choose "Restore Image", and find the image where you saved it. The restoring time depends on the size of the Windows installation you imaged.

Is that a good enough explanation? I hope so.

Bryan

P.S. I won't post back until maybe tomorrow afternoon, so maybe Toey will come to your aid. :smile:

<font color=red><Signature></font color=red>
<b><A HREF="http://www.btvillarin.com" target="_new">btvillarin.com</A></b>
My personal website, chock full of tips and other computer stuff. No ads, banners, or catches. It's currently based on Windows XP, but Windows 2000 stuff to come.
<b><A HREF="http://www.btvillarin.com/staff/bryan_villarin.html" target="_new">My System Rig</A></b>
<font color=red></Signature></font color=red>
June 29, 2002 11:13:28 AM

no... just the built in windows2000 backup feature with the create 4 emergency bootdisk options.

<font color=green>Proud member of THG's</font color=green> <font color=blue>Den Of Thieves</font color=blue> :lol: 
June 29, 2002 2:16:06 PM

This is Toey's clone ... Toey is frantically writing email to the other 468 people who wrote him last night and threatened to throw their (*&^! computers out the window. Then Toey must run and do some outdoor maintenance before the neighbors start complaining about the field growing in front of his house. Me, I'm just going to sit here and drink up all his beer. :wink:

Hopefully, Bryan will fill in for both of us this afternoon while helping jiffy prepare a small bomb and a suicide note for his system.

You shouldn't have any problems installing DirectX 8.1 in Win2K, although you may need to reinstall the chipset drivers and the video card drivers afterwards for the best results. In Win2K, the latest version of DirectX is usually the very first thing I install, although I don't run any diagnostics with DXDIAG until the video card drivers are installed.

Whether it will get rid of the pops when playing Mp3 files ... well, I doubt it. The solution for that is either attempting to upgrade the sound card drivers (and/or moving the card to another slot), or tossing the card out into a busy city street directly under a fast moving bus. Personally, I favor the latter option, and suggest that you buy a sound card that actually works with Windows, has less latency issues, and comes with drivers that are compatible with the operating system.

Once you get past Win9x, I believe in being Creative-free, and that includes the optical drives, which are right up there with Pine in terms of compatibility with other devices. It simplifies a few things, and with many other cards, you won't need 100MB of bloatware taking up space on the drive.

You might also try buying a powered USB hub and running the mouse off of that. This will eliminate having to share the onboard ports with anything else in the system, and could rid you of the problem. It's a thought.

Or you could upgrade to WinXP, and install nothing but the newest drivers for the sound card ... no LiveWare! software. Surprisingly enough, this has worked for many users who were unable to stop the popping and cracking with the Creative cards in other operating systems.

No, backup, huh? My man, you like to live dangerously, don't you? LOL!

I'll send you a PM after posting this with a little information about the latest version of Drive Image. All in all, Bryan's description on how the program functions is correct, although I don't recommend burning an image directly to a CD-R ... on some systems, this can cause the image to be corrupted. It's always better to burn an image to a separate partition on a drive, and then burn to disk from that point.

Toey's Clone

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
__________________________________________________________

<font color=purple>"Some push the envelope. Some just lick it. And some can't find the flap."</font color=purple>
June 29, 2002 10:51:34 PM

Sweet...Toey's got a clone!!! :lol: 

In response to imaging a HD/partition, I always do it to a partition first, while verifying the image as well. Then, when back in Windows, I burn that image to a CDR. Again, I verify the image on the CD to make sure that it'll be okay. Oops...Toey's clone said that. I was just saying that cuz I know that that's a better way of doing it. (That's actually how you <b>should</b> do it. Sometimes I get lazy, but don't we all?) :wink:

Hey Toey-clone, what reason do you have for running diagnostics with DXDIAG after the video card drivers are installed? I'd like to know, so I can add it to the steps for the closest thing to a flawless setup.

I totally agree about trying to get another sound card.

Since you just got Windows XP (hehe), if you can't get another sound card, install XP so that you don't need to install additional sound drivers.

Hey poobah, does your mobo need the 4-in-1 drivers? <A HREF="http://www.viaarena.com/?PageID=2" target="_new">v4.40(a)P3</A> came out a couple of days ago, but I'm not sure if it'll help. :eek: 

<font color=green>Small not-so-important question</font color=green>
Toey Clone, should I run my MS Intellipoint Optical on USB instead of PS2? It won't work if I use Drive Image in DOS, although with DI2002, you don't even need to use it in DOS. It runs in Windows, reboots, images the Windows partition, then reboots back into Windows. If I can't get into Windows, then I'll have to switch my mouse to PS/2. What do you think is better??? Thanks...

Bryan

<font color=red><Short Signature></font color=red>
<b><A HREF="http://www.btvillarin.com" target="_new">btvillarin.com</A></b>
My personal website, chock full of tips and other computer stuff. No ads, banners, or catches. It's currently based on Windows XP, but Windows 2000 stuff to come.
<b><A HREF="http://www.btvillarin.com/staff/bryan_villarin.html" target="_new">My System Rig</A></b>
<font color=red></Short Signature></font color=red>
June 29, 2002 11:56:08 PM

I wish that were true ... it's hard to be in two places at once. If I really had a clone, I'd be on a date right now!

I hadn't tried the latest version of Drive Image, although I have it tucked away in a ZIP file for safekeeping. I didn't see any need to update, since the last version was working so well. The old "If it ain't broke, don't fix it" attitude.

I mentioned to LHGPooBaa in a private message that he would need to keep a cheapy PS/2 mouse around, just for reinstalling images, since DOS has no support for USB.

What you are saying is that DOS is eliminated in the 2002 version? How about when reinstalling an image? Does the new version still have rescue disks?

I prefer running a mouse on a USB port, and I have mine on a powered hub. The mouse is more responsive, due to the higher refresh rate, which is 125Hz for a USB port. The only problem with this setup is that my UPS only has two plugs to draw current directly from the battery, so if the power goes out, I have to resort to using the keyboard to navigate out of Windows, or add the PS/2 mouse very quickly, which might not be possible if the ports are disabled in the BIOS. The solution to this is for me to upgrade the UPS, of course, but that's an expensive proposition.

Regardless of that, I still prefer the mouse on the powered hub, to limit IRQ sharing with other devices.

I think I should also mention that in my experience, VIA mainboards with onboard USB ports don't respond well to having a low powered and a high power USB device on the same passive hub ... this often results in BSOD's. (One passive hub ... two ports.) Interestingly enough, this doesn't seem to happen to boards with Intel chipsets, which will often accommodate two devices that exceed the 500mA limit of a passive hub. (A low powered and high powered device together can pull 600mA.)

Just thought I'd pass that along.

Oh, and the DirectX diagnostics. Using this can tell you, very quickly, if the video card drivers are functioning correctly on the system, as well as allowing you to check the versions of the files. And if AGP Texture Acceleration is disabled, then this means the card is running in PCI mode. Normally, this tells you two things ... either the mode in the BIOS is set to PCI, or the AGP port drivers are not functional, either because they are missing, or corrupted. I noticed this the last time I set up a VIA board, because the 4in1 drivers didn't install a functional AGP driver, despite information to the contrary in the Device Manager. Installing the latest version of the AGP driver separately took care of the problem.

While in the diagnostics program, you can also check several other items, such as if a game controller is correctly installed, if the sound card's hardware acceleration is enabled and functioning, and if the DirectPlay TCP/IP stack Internet connection is running correctly (for games that use this option.) I also normally go to the More Help/Override setting for the DirectDraw refresh rate, and manually put in my preferred rate for the resolution I use for playing games. Mine is currently set at 90Hz, which is the highest refresh rate allowed by the DirectX Properties applet I installed in the Control Panel. Of course, I am aware that my monitor can easily support this refresh rate and resolution, and any user who adjusts this should also be familiar with their monitor's specifications.

See, I'm not drunk. (Hic) :lol: 

Toey

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
__________________________________________________________

<font color=purple>"Some push the envelope. Some just lick it. And some can't find the flap."</font color=purple>
June 30, 2002 12:31:38 AM

Dang, I'm so gullible. ROFL :lol: 

For the mouse, I can just stick the PS2 adapter on mine if I needed it for PS2. I'm gonna try switching it to USB, though. Maybe Counter-Strike will be a little better. (My skills are a whole other issue...)

DOS isn't eliminated in DI2002, it's just easier to create images without using the floppy disks. Of course, the rescue disks are still available, in the inoperability of Windows. Plus, it's just a simpler interface.

What do you suggest with me and my 1 yr. old A7V133? Should I try USB? I guess it couldn't hurt, especially with an image close by, but what do you think, though?

Thanks for the explanation on how dxdiag can help out. I'm gonna print that out somewhere and save it on my computer for future reference. Very nice... :smile:

Bryan

<font color=red><Signature></font color=red>
<b><A HREF="http://www.btvillarin.com" target="_new">btvillarin.com</A></b>
My personal website, chock full of tips and other computer stuff. No ads, banners, or catches. It's currently based on Windows XP, but Windows 2000 stuff to come.
<b><A HREF="http://www.btvillarin.com/staff/bryan_villarin.html" target="_new"><font color=green>Villarin's Velocity Virus Machine</font color=green></A></b> - How's that???
<font color=red></ Signature></font color=red>
July 8, 2002 2:39:37 AM

been doing some more investigations with my poppy SB live card

changing all the drives made it a bit better, but ive found that it seems to be only scrolling the wheel in an Internet Explorer (5.5) windows that produces the worst effects, even a loading page can cauz my moozic to jump, and thats NOT cauz of the click noises that IE normally makes.

most strange.

So I fixed my BIG PC problem by pressing the reset button. I'm not a moron am i? :lol: 
July 8, 2002 2:55:05 AM

Maybe you can try reducing the Audio Playback Hardware Acceleration in the Control Panel one notch to the left and see if that helps. Some people have claimed that this made a difference, especially when gaming.

There's some stuff on the subject I found on this <A HREF="http://www.3dsoundsurge.com/ubb/Forum1/HTML/001056-2.ht..." target="_new">page</A> you might want to check out.

Maybe all this crap will get fixed when LiveWare! 4 gets released. But I'm not holding my breath ...

Toey

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
__________________________________________________________

<font color=purple>"Some push the envelope. Some just lick it. And some can't find the flap."</font color=purple>
July 8, 2002 3:13:22 AM

nods. gotcha. can try that.
ive also hear (probably from you at some point lol) that reducing the PCI delay/latency in the bios can also help (default 32 on my mobo)

course i blame it all on the wonderful soundbullcraper live card :smile:


So I fixed my BIG PC problem by pressing the reset button. I'm not a moron am i? :lol: 
July 8, 2002 8:05:31 AM

hmmm.... seems lowering the PCI latency down to 12 has done the trick pretty much.

i THINK audio acceleration down a bit helps too, hard to tell.

So I fixed my BIG PC problem by pressing the reset button. I'm not a moron am i? :lol: 
!