Sign in with
Sign up | Sign in
Your question

Pointer speed resets on reboot

Last response: in Computer Peripherals
Share
November 28, 2006 3:14:41 PM

I got an Asus A8Js laptop a couple weeks ago. So far so good except for one annoying issue. Everytime I restart the machine my mouse pointer gets reset to it's default slow speed. Specifically, in the Mouse control panel, Pointer Options tab, I move the Pointer Speed slider all the way to the right/fastest (I've tried other poitions while troubleshooting, but it doesn't seem to matter) and I also turn on Enhance Pointer Precision (tried it on and off, doesn't help the problem) and all is well until I restart. Then the slider goes back to the middle which is way to slow for me, and Enhance Pointer Precision unchecks itself. I haven't noticed any other settings getting changed.

I've tried two versions of the Logitech mouse driver and two versions of the Synaptics driver to no avail. I had this problem with the machine as I received it, and still since I've formatted and reinstalled. Also, it began long before I ever connected an external mouse so I don't suspect a conflict there. It makes it through sleep cycles with no problem, but not reboots. Any thoughts?
December 11, 2006 9:39:41 PM

Funny thing, Zero.

I just got a A8Js last week and am having the same darn problem. Everything about it is perfect, but for this pointer speed reset BS. For mine, it doesn't matter if I use the touchpad or a usb mouse, still resets everytime. Seems like it'd be an XP issue, but you're the 3rd AJ8s user wit hthis issue I've heard about - and no users with other brands/models.

If you ever find a fix to this please let me know. I'll do likewise.
December 12, 2006 4:26:53 PM

Actually I think I have found a fix, or at least a work-around. I was looking through my startup items in MSCONFIG and looking up the ones I didn't recognize. One of them was "KHALMNPR". It seems that this is a part of the logitech keyboard/mouse drivers and it's main function is to reset the Windows mouse sensitivity to default on reboot.

The idea is that both Windows and Setpoint have seperate sensitivity sliders and the end result is a combination of the two so by keeping the Windows one at default you only have to worry about adjusting the Setpoint slider. This works fine with my external mouse but my trackpad only seems to use the Windows slider so this resetting was a real pain. Anyway, I disabled it from startup and it seems that the problem is gone now, no more resetting.

It did put itself back into startup with a new entry shortly after I did this but since I've disabled that one as well it hasn't shown up again. Also, some people say this file is needed to make extra buttons or scrolling work on the mouse but so far I haven't noticed any loss of functionality.

Hopefully this works for you and whoever else comes across this thread.
Related resources
January 7, 2007 6:36:56 PM

It does! It works! Yay!

I bought a new USB mouse the other week and installed SetPoint so I could program its scroller/rocker wheel, and immediately found myself plagued with the same problem--my trackpad's pointer speed kept resetting to slow-as-molasses every reboot.

I found this thread because I got fed up with it and went googling after a solution.

Disabling KHALMNPR (both of them) from msconfig's Startup options seems to have done the trick! Without disabling my mouse scroller/rocker wheel settings that only work when SetPoint is running, too.

Thank you thank you thank you!
April 18, 2008 1:17:52 AM

One more big thank you on this one! I bought an HP Compaq 6910p laptop with XP and had this problem after installing a Logitech VX Revolution USB mouse. Both HP and Logitech kept telling me to download new drivers. BS. This fix took care of it right away! So far, none of the button functions on the Logitech mouse are affected. As Nicole said, Thank you thank you thank you!
April 22, 2008 6:01:19 AM

You should be able to control this issue at the software level.
This fix applies to Logitech Setpoint Control Center Version 4.24.99.

Click the Logitech Mouse and Keyboard Settings icon.
Select the "My Mouse Tab"
Select the castle icon, this brings you to the Mouse Gaming Settings.
Select the radio button "OS implementation"
Select "Apply" and "Ok"
Reboot your computer.

Hope this helps!!
June 5, 2008 3:30:25 PM

I am having this same issue with a Microsoft mouse. My "Pointer Speed" and "Enhanced pointer precision" options reset whenever I startup my machine. Oddly enough, my "Snap To" setting sticks!!

I'm running Win XP on an HP latptop with a Microsoft Wireless IntelliMouse Explorer 2.0 running Microsoft's Intellipoint Mouse software/driver version 6.1. I've seen several postings regarding Logitech's driver, but haven't seen anyone mention Micorsoft's. Anyone run into this issue and know how to solve it? I have tried uninstalling and reinstalling the Intellipoint software, but that obviously hasn't worked.
May 27, 2009 6:20:18 PM

mvchucky said:
One more big thank you on this one! I bought an HP Compaq 6910p laptop with XP and had this problem after installing a Logitech VX Revolution USB mouse. Both HP and Logitech kept telling me to download new drivers. BS. This fix took care of it right away! So far, none of the button functions on the Logitech mouse are affected. As Nicole said, Thank you thank you thank you!


I have the exact laptop with the same problem. I've unchecked the KHALMNPR.EXE and will see if it works after a reboot. I occasionally have issues with this laptops wireless... is this something you've dealt with as well?
December 3, 2009 2:04:09 AM

You guys rock! I too have an HP laptop with same problem, and IT guys didn't know how to resolve the issue.
December 10, 2009 8:04:59 AM

disabling KHALMNPR.EXE also resets all the special button assignments to default. Not per-application, but global assignments.
February 3, 2010 5:55:40 PM

EDIT: suggested controlpanelfix works fine, just remember to plug in your mouse for the options to become available /bonk
Rune
March 10, 2011 5:13:18 PM

Came across this thread having same issue, I found a solution that doesn't involve disabling the setpoint software though. Setpoint conflicts with the enhanced pointer precision so it resets windows settings to default after reboot or any changes are made in setpoint itself. My solution was to enable mouse acceleration in setpoint and lower the pointer speed very low, mines at second lowest setting with acceleration on low. This allowed me to move across the screen quickly but retain precision clicking like before I installed the setpoint software.

Hope this helps! Worked wonders for me.
Link to thread I found that helped me: http://www.sevenforums.com/hardware-devices/119748-mous...
August 25, 2011 10:26:31 AM

[BUMP] sorry guys :/  :pfff: 
Thought this might help many GAMERS as well! if you have got the WoW-Cataclysm gaming mouse, it 'll reset the windows pointer speed as well
if you download it 's program off the interwebz, you can open it and look for mouse settings tab on the left.
just change "win-pointer speed" to maximum (also x and y speed to max?)
sorry again for bumping
just thought this might help some ppl. :D  ;) 
January 22, 2012 12:28:49 PM

I bought a HP wireless mouse and it's setting were always being reset on startup also. I was able to keep settings permanent by editing it's xml configuration file below.

C:\Documents and Settings\All Users\Application Data\HP Mouse Suite Config\function.xml

Remember to keep a backup of original file just in case there's a problem. If you don't know xml, as a friend who does.
Anonymous
February 3, 2012 11:00:52 AM

Unless you really need to change a button function or desire a feature the mouse software has. I would skip installing software for the mouse. It has been known for a long time to cause issues. I bought a travel mouse for my Dell laptop and made the error of installing the SetPoint software. It messed up my TouchPad settings so bad I had to un install it.
!