File Types, can't change application

Archived from groups: microsoft.public.windowsxp.general (More info?)

On my Windows XP/SP2 PC, non-admin users can not change application to
handle given file type. In the Folder Options >> File Types >> the
"Change" and "Advanced" buttons are greyed out. How can I enables this
change for all users?

Vinod
5 answers Last reply
More about file types change application
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    NoFileAssociate

    Automated edit...
    http://www.kellys-korner-xp.com/xp_tweaks.htm

    Read the instructions at the top
    314. File Associations are Greyed Out
    -----

    NoFileAssociate
    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

    Data type Range Default value
    REG_DWORD 0 | 1 1 (Terminal Services systems)
    0 (All other Windows 2000 systems)

    Description
    Disables the buttons on the File Types tab. As a result, users can view file
    type associations, but they cannot add, delete, or change them.

    The File Types tab shows which programs open when a type of file is
    double-clicked. The file types are represented by their file name extension.

    Value Meaning
    0 Users can add, delete, and change file type associations.
    1 Users cannot add, delete, or change file type associations.

    By disabling this tab, you can prevent malicious users from creating an
    association that starts a risky or destructive program. Also, users cannot
    create less productive associations, such as associating the .doc file type
    with Wordpad instead of Microsoft Word. This is a particular risk on
    multi-user systems, such as Terminal Services clients.

    Note
    Although this entry is located in the Policies\Explorer subkey, it is not
    associated with a Group Policy included in Windows 2000. You can create a
    policy by adding this entry to an Administrative Templates file.

    This entry applies to all users of the computer. To set this entry for
    particular users, use NoFileAssociate in the HKCU subtree. If the settings
    of these entries conflict, the setting in HKCU takes precedence over the
    setting in HKLM.

    Windows 2000 does not add this entry to the registry. You can add it by
    editing the registry or by using a program that edits the registry.

    Tip
    To see the File Types tab, in My Computer, from the Tools menu, click Folder
    Options, and then click the File Types tab. ]]
    http://www.microsoft.com/resources/documentation/Windows/2000/server/reskit/en-us/Default.asp?url=/resources/documentation/Windows/2000/server/reskit/en-us/regentry/94215.asp


    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:1120334515.547379.204620@g47g2000cwa.googlegroups.com,
    vinod <vrak58@yahoo.com> hunted and pecked:
    > On my Windows XP/SP2 PC, non-admin users can not change application to
    > handle given file type. In the Folder Options >> File Types >> the
    > "Change" and "Advanced" buttons are greyed out. How can I enables this
    > change for all users?
    >
    > Vinod
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    vinod wrote:
    > On my Windows XP/SP2 PC, non-admin users can not change application to
    > handle given file type. In the Folder Options >> File Types >> the
    > "Change" and "Advanced" buttons are greyed out. How can I enables this
    > change for all users?
    >
    > Vinod
    >
    If you click start, run, type console1.msc, press enter, click
    add/remove snap-in, select group policy and click finish.

    In the left hand pane you should now see local computer policy, double
    click that followed by computer setting then administrative templates.

    Somewhere in there is an option to enable the tabs your after.

    Have you tried booting in safe mode, logging in as administrator then
    double clicking my computer and folder options?

    If not try this before the above method, let me know if the options are
    still greyed out.

    If you can access these tabs by logging in as administrator in safe
    mode, the permissions on your standard user account don't allow you to
    access these tabs.

    If this is the case and you need help changing the permissions on your
    account, just let me know, I'll gladly help you.
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    I searched the whole registry but could not find NoFileAssociate key
    defined any where. So, I guess the file association is not controlled
    by this reg key.

    Vinod
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Having the thread or at least the last post attached would have helped.

    --

    All the Best,
    Kelly (MS-MVP)

    Troubleshooting Windows XP
    http://www.kellys-korner-xp.com


    "vinod" <vrak58@yahoo.com> wrote in message
    news:1120543451.679426.146960@z14g2000cwz.googlegroups.com...
    >I searched the whole registry but could not find NoFileAssociate key
    > defined any where. So, I guess the file association is not controlled
    > by this reg key.
    >
    > Vinod
    >
  5. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Original Post.........

    On my Windows XP/SP2 PC, non-admin users can not change application to
    handle given file type. In the Folder Options >> File Types >> the
    "Change" and "Advanced" buttons are greyed out. How can I enables this
    change for all users?

    Vinod

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:exi1BhSgFHA.1948@TK2MSFTNGP12.phx.gbl,
    Kelly <kelly@mvps.org> hunted and pecked:
    > Having the thread or at least the last post attached would have helped.
    >
    > --
    >
    > All the Best,
    > Kelly (MS-MVP)
    >
    > Troubleshooting Windows XP
    > http://www.kellys-korner-xp.com
    >
    >
    >
    > "vinod" <vrak58@yahoo.com> wrote in message
    > news:1120543451.679426.146960@z14g2000cwz.googlegroups.com...
    >> I searched the whole registry but could not find NoFileAssociate key
    >> defined any where. So, I guess the file association is not controlled
    >> by this reg key.
    >>
    >> Vinod
Ask a new question

Read More

Windows XP Microsoft File Type