Sign in with
Sign up | Sign in
Your question

SATA WD Raptor and Asus P4PE -- cannot setup

Last response: in Storage
Share
August 19, 2004 6:26:19 AM

I am a little flustered.

I just got a WD SATA Raptor (74GB). I have spent the entire evening trying to install it with no luck. I disconnected my Maxtor HD (ATA) and plugged the SATA Raptor in.

There is no option in the Bios to boot from it and the manual and Asus site have nothing I can find on how to set it up.

After many hours of frustration and browsing the net for solutions I tried entering fasttrack (their Raid software) and it can see the Raptor... I even tried setting up a Raid 0 on the single drive and Windows install could still not see it. Below is a link to my MB overview:

http://usa.asus.com/products/mb/socket478/p4pe/overview...

I have the most recent bios (p4pe1007.awd). The system runs fine, I just cannot get Windows to install on the drive. I get to the point where it asks what drive and it says there is none.

Help appreciated :) 
August 19, 2004 9:32:17 AM

Here is the deal so far:

The drive needed to be set to a raid array.

And before that can work on an install I needed to make a floppy of the Promise driver.

NO WHERE in ANY of the documentation does it every indicate you need to setup the SATA drive in RAID!!

Even more, info about installing the Promise controller (which is not endorsed by MS!) was on the CD in a small Text file. Of course neither the manual or website have any clues on any of this >:( 

Utterly rediculous. I have always really been supportive of Asus, but in this case the hoops I had to jump through were rediculous--and things are not perfect either.

Stupid setup did not let me choose the drive letter and now my main drive is F: grrr

If anyone has any good news (like how to set this up not in raid, or how to change my drive to C: w/o having to start all over, let me know! Thanks :) 
August 19, 2004 11:58:10 AM

You can change any drive partition letter to another (that isn't already assigned) by:

Start>Control Panel>Administrative Tools>Computer Management>Disk Management r.click partition>change drive letter and paths

[Edit: It's assumed you're using WinXp.]

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=27..." target="_new">My Rigs</A><P ID="edit"><FONT SIZE=-1><EM>Edited by arkus on 08/19/04 08:01 AM.</EM></FONT></P>
Related resources
August 19, 2004 4:19:11 PM

Thanks... getting closer...

I got this message:

"Windows cannot modify the drive letter of your system volume or boot drive"

Any way around this? I am not to happy with this drive being labeled F:... already have probs with some programs wanting to be on C:. The setup did not give me a choice of what to call it...

Any suggestions?
August 19, 2004 4:40:31 PM

You'll probably need to start all over. Important boot files always end up on C: so if your OS is on F: and and IDE drive is C: then removing the C: drive will cause your OS not to boot any more.

It should be possible to fix though. Remove all other IDE drives and just have your SATA drive in there. Run windows setup (with the right driver) but go into the recovery console. Run FIXBOOT and this should copy the correct boot files to the SATA drive.

Watch out for when you reinstall your IDE drive though, if you have HD0 in the boot order it will boot from the IDE drive again so make sure you only have SCSI in the boot order. You can prevent it from booting from the IDE drive ever again by removing the hidden system files (ntldr, NTDETECT.COM, boot.ini) from the root of your IDE drive.

<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
August 19, 2004 6:00:45 PM

So it looks like I am stuck using the driver for the Raid Controller to use the SATA drive :/ 

If I reformat, any suggestions on the stripe size? I left the default (64), but since it is a single drive, what should I do?

I had removed the IDE drive when installing and have disabled the EIDE from the boot sequence.

Thanks for all your help and suggestions guys :)  Just frustrating... like jumping through hoops. I am not a complete idiot (I was able to get the drive to work), but I think the solution is rediculous.
August 19, 2004 8:36:05 PM

Quote:
So it looks like I am stuck using the driver for the Raid Controller to use the SATA drive

The SATA ports are on the RAID controller, so yes, but it doesn't make any difference

Quote:
If I reformat, any suggestions on the stripe size?

You can't stripe a single drive, just ignore it and set up one drive.

Quote:
I had removed the IDE drive when installing and have disabled the EIDE from the boot sequence

Then in Windows Install you should see the SATA drive assigned the drive letter C:

Quote:
I think the solution is rediculous

Computers often are :) 

<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
August 19, 2004 10:55:00 PM

Thanks for the reply :)  When I try again tonight I will see if it will let me use it w/o making it a Raid disk (it would not last night) but I will mess with it some more. Right now it says it is a Single Disk on Raid O... :/ 
August 20, 2004 12:32:23 AM

Having to make a floppy with the drivers is a very well known SATA thing. It's not ASUS's fault at all. Windows XP just doesn't recognize SATA drives by default. That's the problem. Search the boards and there are plenty of instructions on how to install windows on a SATA drive by hitting F6 during the install and providing the drivers.

You should set the boot order to SATA or SCSI (depending on what your bios says) and enable your SATA chip.

s signature has been formatted to fit your scr
August 22, 2004 2:01:19 AM

Yes, Windows XP CD doesn't recognize most SATA controllers. Intel gets around that problem by making your SATA drive appear to XP as mounted to the standard PATA controller.

<font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
<font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
August 28, 2004 6:47:17 PM

Still having issues with this.

I had used the Promise drivers to get it to work to begin with (but in Raid 0). I also have the 'SCSI/Onboard ATA Boot Device" selected in the boot sequence of the Bios.

Yet when I go to install WinXP, hit F6, it comes up with a menu that says there is no drive (i.e. 0 drives, 0 drive size, etc...) If I try the repartition or other options I get a fatal error.

I know th drive works. Oddly, the fastbuild array builder sees it, even if I don't build an array. I get something like this:

Under drive assignments: 1:Mas WDC WD740GB-00FLA1
Capacity 74355 Asignment FREE Mode U5

Asus answered my first ticket on this issue by (1) not answering my quesiton, and (2) telling me to DL the 378 drivers. Well, there is no 378 drivers, they are 376! I told them I had the 376 drivers, but the 378 did not come with my CD nor were they on the site, so I asked for a link. Of course they sent me to the 376 drivers that were no already working.

Now they wont respond at all to me.

So, I am stuck with a drive that will only (right now) work in Raid! But obviously I do not want a Raid Array on a single drive.

(1) Asus wont help (probably last time I will buy anything from them... documentation is lacking an no support... this plus a bad MB in the past they refused to replace is about as much as I can take), so any suggestions? How can I get WinXP to detect this drive without setting up an array?

(2) If I have to setup a single drive array, how big should I make the stripe?

Thanks for your time and help.
August 28, 2004 7:04:51 PM

It is Asus fault for not documenting the need to use a floppy disk to install the driver. This is not mentioned in the Manual in the Raid or SATA sections. Not everyone is going to go looking on technical forums hoping to get help. The company who makes/advertizes/sells the product should support it and give proper documentation. I can understand WinXP not supporting it (I remember when Win95 did not support USB and I had to manually install that), but having no documentation in the manual on proper setup is unacceptable.

As it stands, they had no documentation (thus I still think it was rediculous to expect me to have to figure this out by myself), and then they sent me wrong driver information when I presented the problem. Now I am getting no help at all from them. That is rediculous.


As for the fastbuild... I cannot ignore the 'stripe' option without going into 'mirror'. I can either go Mirror mode (with Gigabyte boundary on or off) or Stripe mode (w/ 16,32,64,128,256 KB stripe blocks).

And yes, I did have the SCSI/Onboard ATA drive option selected in the Bios.

Any other suggestions? It is beginning to appear that this board/chip wont allow the SATA drive to work unless it is in Raid... since I did not find anything on the boards to remedy this, maybe one of you can make a new contribution to help solve this :) 

Also, if I am stuck using the stripe, what size would be best for performance/stability?
August 28, 2004 9:22:24 PM

Btw, I am sorry if my posts seem testy or frustrated... I am, but not at any of you. So I hope there is no hard feelings :) 
August 28, 2004 10:10:59 PM

Quote:
How can I get WinXP to detect this drive without setting up an array?


You can't, you are totally stressing about nothing. There is nothing wrong with putting a single drive in a RAID array, in fact that's what you are obliged to do if you want to use a single drive on a RAID controller. It will just work as a normal drive, what else can it do? You can't have 'redundant' disks when you only have one disk attached!

ASUS won't help when it's just some dumb kid unable to understand how to setup a RAID BIOS, and I don't blame them, how can they be responsible for how you configure their hardware. They just make the stuff, it's up to you to configure it properly. If you don't think you're up to the task, buy a Dell.



<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
August 29, 2004 12:29:48 AM

Hey sjonnie,

"Kid"
"Dumb"
"buy a Dell"

Please stop the flaming and troll in some other forum. I am sorry you felt the urge to needlessly insult others who are seeking assistance on a technical forum. I am sorry to say this (because I have appreciated your help) but it is totally and utterly childish.

Calling people "kids" and "dumb" is not effective communication, and really does not solve the problem at hand. I wish you had a desire to assist me with the issue in a friendly manner.

As for Asus, all I can say is their current reputation for support and documentation speaks for itself (it is not very good, check the BBB if you do not believe me). In my situation:

(a) Asus has absolutely *no* information in their manual or site on how to setup a SATA drive on this MB.
(b) The Asus tech's solution to my problem was to install a ficticious file.
(c) The Asus tech must be as confused as I am. In his step-by-step instructions he told me to use the driver and it will detect the drive. He did not say to setup an array, he said using the driver would resolve my issue. I KNOW for a fact that this DOES resolve the issue for certain controllers that support SATA and RAID (i.e. there is no need to setup RAID).

Thus, when you said, "There is nothing wrong with putting a single drive in a RAID array, in fact that's what you are obliged to do if you want to use a single drive on a RAID controller" you were incorrect. There are RAID/SATA HDD controllers that do not require any such setup. I cannot read Asus' mind, and I am not going to just "assume" how it should be setup. There is a right way to do it, and I would like to do that.

Also, when did I indicate I was looking for redundancy (RAID 0 is not for redundancy), let alone redundancy on one drive? Again, you are just pulling things out of the air. I did say I did not wish to run it in RAID--mainly because of any potential overhead and/or issues created by the controller striping a single drive. I think this is a valid concern. You may not think so and you could have simply stated that running in RAID 0 is not a problem and don't stress about it. I would have appreciated that :) 

Anyhow, they make it, they advertize it, and they sell it. It cost about $200 and one of the key selling points being SATA support. If I had listened to Asus it still would not work at all (I decided to mess around with the RAID controller on my own).

You seem to miss this point in your attack on me to defend Asus: They have no documentation on how to set this up. They are responsible for providing instructions on how to properly use their equipment (you may not be aware of this, but most companies wont help you if you do not set it up *their* way).

You are the first to mention running RAID on a single drive is ok, and that striping wont cause any issues. THANK YOU :)  I wish you had stated this earlier... I will now try to verify your claim and get this setup.

sjonnie, I am sorry you felt the need to insult me in trying to help. I DO appreciate your assistance though. Please leave the childish behavior out of the posts in the future though.

Thanks for replying though :) 
August 29, 2004 12:43:47 AM

It's not their fault for not documenting that. It's purely a windows thing. The hardware works fine. They have to document how to set the hardware up, not how to install software on it. Should they include OS install instructions for every linux distro + windows + OSX?

Don't hit F6 when installing windows. Just proceed normally. It will say it didn't detect a disk. It will then ask if you have any extra hardware, select yes. It will then ask for a driver, put in the floppy. I have an asus board (silicon image chipset for SATA) and a WD740 drive and had no problems installing it.

s signature has been formatted to fit your scr
August 30, 2004 11:31:16 PM

I too have the P4PE board. I added a drive to the controller months after installing the OS. As I recall the manual is not very clear whether you can install the drivers after the OS is install...but I found out you can. I then set the disk up as a single disk RAID, (I don't think stripe size matters with just the one disk.)

If you have any more ASUS board specific questions you might try these guys:
<A HREF="http://www.asusforums.org/" target="_new">http://www.asusforums.org/&lt;/A>

....WW (5.0)
!