Sign in with
Sign up | Sign in
Your question

Microsoft/Razer Habu problems

Last response: in Computer Peripherals
Share
January 19, 2007 9:53:28 PM

I purchased a Microsoft Habu recently, and i love it! I personally think it's way better than the Copperhead, mainly because it fits the contour of your hand. Very comfortable. But I have one problem: the drivers.

I did everything it told me to do:
Install the software before plugging in the mouse.
Restart the computer.
Plug in the mouse.

But yet the software still says that it found no Habu. I went to the device manager, and under Mice and Other Pointing Devices, it said HID-compliant mouse. I assumed that the default drivers were being used, and not the Razer drivers.

Is there any way of installing the correct drivers for the Habu?

Thanks in advance.
January 29, 2007 4:04:12 AM

I know with my computer i think i have an error with a few of my usb's, and i have to switch the mouse into different usb's, restart comp. and than it will detect the mouse. :( 
February 28, 2007 6:24:42 PM

Get the latest firmware (should be 2.01) and the latest drivers. And don't swap the USB ports (as suggested by the other guy), use the same as you flash in since it installs some port specific software. Check the Razer web page for drivers and install instructions, but there have been issues reported for people that havn't installed the drivers and flash correctly.
July 29, 2009 5:19:37 PM

I've done this. Followed the instructions to the letter. when that didn't work, I tried the copperhead workaround, still didn't work. The Habu Config software still cannot detect the habu mouse, although the mouse works fine under windows. I just can't use the advanced features... but what's the point?
!