Sign in with
Sign up | Sign in
Your question

KVM problem with Windows 7 pro

Last response: in Windows 7
Share
September 4, 2012 12:35:01 PM

Hello,
I have a user that I'm tiring to help. She has two computers, and a LinksKey LKU-S04ASK 4 port KVM switch. One computer is using Windows 7 Enterprise and the other is using Windows 7 Professional. The computer with Win 7 Enterprise works fine with the KVM, but Win 7 Pro doesn't.

Problem: When both computers are booted up both work fine with the KVM switch. But once she switches from Windows 7 Pro over to Windows 7 Enterprise and then back to Windows 7 Pro, Win 7 Pro doesn't see the mouse or keyboard. Even if I disconnect the mouse and keyboard from the KVM and plug them directly into the usb port of the computer, it still doesn't see them. The only way to get that computer to see the mouse and keyboard again is to reboot the computer. I've tried changing the switch (to another one like the first one), the keyboard and the mouse, but nothing fixes the problem.

Another thing we've found with this issue is that if I boot the Window 7 Pro computer up in Safe Mode, the switch works fine. No problems. I can switch away from it and when I switch back to it, it works great.

I've been reading multi forums looking for an answer. So far I've found that Microsoft is very hush, hush about how to turn off Hot-Plug Detection. Do you know a way I can get Windows 7 Pro to work with this KVM switch? Is turning off Hot-Plug Detection the way to fix this issue? There's something in Windows 7 Pro that's different from Windows 7 Enterprise that's causing the problem, but what is it? Any idea's?
a b $ Windows 7
September 4, 2012 1:32:04 PM

If you can try plugging a usb hub inbetween the KVM switch and the Win7Pro PC it may help as I had a similar problem with a HP ML330G4 server dropping the keyboard and mouse during switchover, the usb hub seemed to ressove the issue, the other option might be to add a usb add-on card to the PC.
m
0
l
a b $ Windows 7
September 4, 2012 1:59:06 PM

Try disabling the adaptive USB power management, so they are always on.
m
0
l
September 6, 2012 6:56:32 PM

I did get the problem fixed. What I did to fix it was replace the KVM with an IOGear KVM.
m
0
l
!