Setting Up Telnet Server

I have a Linux box that is an apache web server. I do not have a DNS set up so I am accessing it by explicit IP. apache, samba, etc all those good services are running fine but I can't get a telnet connection to it. For some reason, it refuses the connection every time, whether I am in the subnet or not (on another machine on my lan or outside of it either way). The telnet service seems to be running (ie it comes up when I type "ps -aux | grep telnet") but I guess there are options somewhere that I haven't set...any ideas?

correction...the service is not running. I don't really know how to tell if it is, or not, I guess.
<P ID="edit"><FONT SIZE=-1><EM>Edited by catherinestevens on 07/04/02 12:34 PM.</EM></FONT></P>
2 answers Last reply
More about setting telnet server
  1. You just need to edit /etc/xinetd.d/telnet, and set it to "disable = no"

    Then restart xinetd.

    BTW, telnet has a horrible reputation, and sends passwords clear-text, so if you use it on an untrusted network at all, ssh is a better alternative.

    <i>Do I look like I care?</i>
  2. Oh WOW thank you! Also, in my hosts.allow file, I did not know what to put, so I just put the three IP addresses of th emachines I have on the lan. Is that correect? And also, how do I make sure that other addresses not on my intranet will be allowed?
Ask a new question

Read More